PDA

View Full Version : WADMerger update


Michiel
10-05-08, 19:45
Another update has been released, fixing a few problems with importing objects from TR2/3 levels. Also, this new version included the updated objects.h file for use with NGLE so the new object slots are displayed correctly in the editor instead of being called PLANT0-3.

The update can be downloaded from here:
http://www.trsearch.org/Tools/22/

Instructions on how to enable the extra object slots in NGLE, as well as as links to more detailed pages about these new slots can be found here:
http://www.trsearch.org/wiki/Category:NG_Objects

TRfan23
10-05-08, 19:55
Request Deletion.

igor32
10-05-08, 20:23
Tools
All tools that are in our database are listed below:

WAD Editors
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3

Texture Editors
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3

Project Tools
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3

Level Editors
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3

Script Editors

Others
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3
WADMerger 1.98 Beta 3


oops!

some bugs?!

Larson_1988
10-05-08, 20:25
Instructions on how to enable the extra object slots in NGLE, as well as as links to more detailed pages about these new slots can be found here:
http://www.trsearch.org/wiki/Category:NG_Objects

Sounds great Michiel. :) But does this apply to the old NGLE editor aswell?

TRfan23
10-05-08, 22:23
Request Deletion.

stranger1992
10-05-08, 22:24
does not, I have been using TRNG since January 2008 and NGLE since January 2007 and has never caused start up problems.

Lara's Backpack
10-05-08, 23:01
Thankyou Michiel.

Could you also have alook at the bug where when you "create new" in the WADMerger and call it an Animating, an error "Error building moveable" appears.

Also, the animtion editor has the "subscript out of range" crash ALOT.


Thanks again though, I really appreciate all the work you've put into all of this - where would the LE world be without you? :D

Michiel
10-05-08, 23:50
I made a short tutorial on how to extract the objects for the new TRNG slots. This is a general tutorial that should apply for all objects:
http://www.trsearch.org/wiki/Ripping_TR_objects_%28TRNG%29

For information about which objects and which sounds have to be copied, check the manual of the object. A list of available slots with as much information as possible is available here:
http://www.trsearch.org/wiki/Category:NG_Objects

jeffrey van oort
11-05-08, 12:21
Hi, I have a question correlating to the explanation given here: http://www.trsearch.org/wiki/RUBBER_BOAT

It says that the rubber boat requires 2 additional hardcoded sounds. These hardcoded sounds will only work in v130 wads. When copying the object, make sure the following 2 sounds are copied as well:
TR3_BOAT_IDLE (195)
TR3_BOAT_MOVE (197)

However when I use v130 wads my game stops loading like below.

http://img182.imageshack.us/img182/5751/stopsloadingep8.th.jpg (http://img182.imageshack.us/my.php?image=stopsloadingep8.jpg)

Is there a reason why this happens, did I do something wrong? Is it not vista compatible or something or what should I do to make it work?

TRfan23
11-05-08, 13:22
Request Deletion.

Michiel
11-05-08, 15:54
You do realize the recent updated version of NGLE, that is said to have better physics to when boulders go in water etc... Actually changes the way your computer starts!!!

All tools do something like that. Like WADMerger collects your credit card information, NGLE changes the way your computer starts to load up advertisements, and TREP scans all your incoming email for passwords. Just accept that this happens.


Anyway, back to the actual subject. Jeffrey, I have no idea why that could happen. Are you sure you have the latest TRNG update and converted the tom with the next gen tom2pc? If so, do you get an error report from TRNG? I never seen problems with v130 wads, so I have no idea what could cause it.

TRfan23
11-05-08, 16:08
Request Deletion.

ukraider
11-05-08, 16:50
Nothing is going to interfer or react with my laptop, I repeat nothing. I can't trust anyone at all! :(

Because of NGLE, my Vista ended up acting XP. Even when I put it back to default! And I couldn't have a desktop background

You said the magic word which explains all your computer problems "VISTA" :)

TRfan23
11-05-08, 16:51
Request Deletion.

jeffrey van oort
11-05-08, 19:54
All tools do something like that. Like WADMerger collects your credit card information, NGLE changes the way your computer starts to load up advertisements, and TREP scans all your incoming email for passwords. Just accept that this happens.


Anyway, back to the actual subject. Jeffrey, I have no idea why that could happen. Are you sure you have the latest TRNG update and converted the tom with the next gen tom2pc? If so, do you get an error report from TRNG? I never seen problems with v130 wads, so I have no idea what could cause it.

Could you post a link with the latest version please?
I have 1.17 I think..
I don't get a crash report (CRS)my vista laptop simply indicates that the program is no longer working and that it will close.

jeffrey van oort
11-05-08, 22:28
I found out that it only crashes after I converted the wad to v.130
Why I don't know but it does. What can I do to solve the problem?
Can it be solved even?