PDA

View Full Version : TR2 compatibility mode


Vladislav IV
22-08-08, 10:02
Hi guys ! Firstly, a little story...

I had a strange problem with TR 2 under Windows XP.

With compatibility mode :
Launching the game as a normal user, results in a 90 counterclockwise rotation of the screen :D
Launching as Administrator results in no problem.

The setup tool, while used by a normal user, always changes the screen definition choosed by the user :
1280x800 -> 800x1280
800x1280 -> 800x1280
1024x768 -> 768x1024
768x1024 -> 768x1024
etc.
It always chooses the smallest dimension of the selected definition, to be the screen width.

Using the setup tool as Administrator results in no such a behavior.

I tried to change these values directly in the registry, but the game doesn't matter. The problem is the same, the screen think it's vertical :D

Without the compatibility mode :
Everything is OK for everyone.


Although this could be used as an extra gaming challenge :) I found a way to take off this problem : disabeling the compatibility mode.

So, is there any real difference between the game with and without the compatibility mode ? I walked a little in Lara's mansion and the first level, everything seems OK... I want to add that the compatibility mode is turned on and set to Windows 98 by the multipatch installer.

EscondeR
22-08-08, 10:41
Hi guys ! Firstly, a little story...

I had a strange problem with TR 2 under Windows XP.

With compatibility mode :
Launching the game as a normal user, results in a 90 counterclockwise rotation of the screen :D
Launching as Administrator results in no problem.


This issue and others nest in your Intel built-in graphics adapter with outdated drivers. No need to distract other users from proper (working in 99,9999(9)% cases) install procedure by advising to turn compat. mode off! :mis:

To cure your issue:
1. Update your Intel video chip drivers from www.intel.com
2. Disable screen rotating hotkeys in Intel Video Accelerator Control panel (system tray area) and check the current mode.

Vladislav IV
22-08-08, 11:42
Sorry sorry sorry... I thought to rotate the screen to compensate the game's orientation, but not to disable it. Stupid me...

Thanks ! Problem closed, back to compat. 98 ;)