PDA

View Full Version : Win2K BSOD


aktrekker
18-09-08, 08:55
Yep. Something happened. It was running fine this afternoon. I came home from work and it won't boot. It gets all the way to where the login window pops up for a fraction of a second then BSOD.
It gives error 0x0027 (0xbaad00d5, 0, 0, 0) RDR_FILE_SYSTEM.
The first parameter indicates RDBSS_BUG_CHECK_NTEXCEPT.
I've been googling both errors and can't find any useful info.
Booting in Safe mode doesn't work - same problem.
Booting to command line locks up until I Ctrl-Alt-Del then I get a login window then BSOD.
Booting last know good configuration doesn't work.
Booting in Debug mode doesn't work.

I have Dual boot with Win98, but it can't access the Win2K partition (NTFS).
I have Partition Magic and run an error check on the drive and it gives 2 errors.
Partition improperly dismounted (DUH)
Attribute must be resident (No idea what it means).

All info I find says add memory but it worked fine 8 hours ago. And Win98 is running fine and showing all my memory, so it must be something else.

I have Win2K SP4.
Anyone know how to fix this?

EscondeR
18-09-08, 09:15
Any other hardware changes?
What antivirus software do you have?

Does the error message give you any links to specific files?

How much RAM do you have on this PC?

aktrekker
18-09-08, 10:29
No hardware changes at all.
No antivirus. I'm very careful where I go. I do have Zone Alarm.

No specific files mentioned.
256MB ram. It's been enough so far. This is an old computer :o
And as I said, it worked 8 hours earlier.

I may have to create some Win2K recovery disks just to get to the OS partition. I have no way to get at it right now. So I can't look an the memory dump, registry, or anything else.

EscondeR
18-09-08, 10:41
The root of the error can (very likely) be in low amount of RAM. Can you enlarge RAM amount to at least 512Mb?

St4r
18-09-08, 10:48
Did you update your BIOS or made some changes? Clearing CMOS might also be a solution then.

aktrekker
18-09-08, 11:36
I've had the same amount of RAM for the past 5 years and W2K never asked for more. I'm sure it isn't the memory. That's just Microsoft's way - throw more RAM or disk space at it and everything will be OK.

But I just remembered something I did do. I had downloaded Autoruns, and this afternoon I ran it to see what was there. I thought I had run it the night before, but I guess not. Anyway, I saw an entry that wasn't Microsoft, and had no description or provider of any kind. I disabled it. Guess it was a mistake.

Anyone know off-hand if booting from a recovery disk can run RegEdit on the C drive registry instead of the booted copy?

EscondeR
18-09-08, 12:13
Check PM.

Bokkie
18-09-08, 18:48
If you can't access Windows 2000, but you can boot Windows 98, then my proposal is to access to NTFS partition, backup the data and reinstall Windows 2000. To do that, you will need to download NTFS for Windows 98 (Read-Only) (1.1 MB) (http://www.themobiusproject.com/mirrors/download.sysinternals.com/Files/NtfsWindows98.exe) and then boot Windows 98 to access NTFS partition. When you backup what you need, you may reinstall Windows 2000, install SP4 and additional updates.

Here is a very good article about installing Sysinternals' NTFS for Windows 98 driver (http://articles.techrepublic.com.com/5100-10878_11-1047598.html), so you may take a look and action step by step.

Hope that helps.

aktrekker
18-09-08, 20:00
I didn't know someone had done that. Very handy.

But if I can just get to the registry, I should be able to fix it.

EscondeR
19-09-08, 04:33
^ When you do it whatever way you like, please, post this autorun entry here, for us to analyse and provide removal advice if necessary.

aktrekker
19-09-08, 09:20
This may take longer than I thought.
The Recovery Console only allows a handful of DOS commands. There doesn't seem to be a way to access the registry. I can't run anything.

I think I found the registry. I copied what appears to be the original one installed with W2K over the old one (AFTER I saved a copy :D). Now the BSOD happens a little faster than before.
But when I boot in Safe mode with command line, if I wait long enough I now get the login window. But when I try to login, I get
The application failed to initialize properly - userinit.exe (0xc0000142)

It appears I turned off something that was needed for login. But how to turn it on. If it was a service, I can enable it from Recovery Console.

EscondeR
19-09-08, 09:26
First check if there is userinit.exe in C:\Windows\System32 folder.
Then refer to PM.

aktrekker
22-09-08, 01:16
Sorry to bump. I've been working on the problem trying to avoid reinstalling. Too many service packs and driver upgrades to remember.

I decided I could copy the W2K partition, reinstall, use regedit to fix the registry in the copy, then restore the copy and be back to normal.
When I try to copy the partition, PartitionMagic gives an error about "Attribute must be Resident" and won't do it. DriveImage does the same thing. The only solution they give is to run chkdsk.
The problem is that I'm now under Win98, and chkdsk can't access the NTFS partition. Even with NTFS4DOS, chkdsk won't be able to repair the problem.

So...does anyone know a tool that will just copy a partition to another partition no matter what the data is?

After I backup the partition and install W2K, scandisk should fix the backup copy and I'll be OK.

spikejones
22-09-08, 01:34
try using a live CD of Ubuntu (http://www.ubuntu.com/) or Mandriva. (http://www.mandriva.com/)

aktrekker
22-09-08, 03:46
I can try. But so far I haven't had any luck making bootable CDs. I managed to get an ISO copy of VistaLive CD. It found the disk during boot but then it froze. Maybe my Nero 5 is too old to do it right.

spikejones
22-09-08, 03:51
use infrarecorder (http://infrarecorder.sourceforge.net/) to burn the disc.

get a torrent download to ensure it passes hash check for best image quality

also verify the disc after burning (infrarecorder has this function built in) to check against the ISO image.

edit: also burn at slowest speed your drive will go (4x or 8x) for best results.