PDA

View Full Version : Windows XP will simply not start even in safe mode.


Jordan_Boi
06-10-08, 18:55
I recently had a problem involving Windows Live Messenger where it wouldn't work properly on my mum's account. I searched on the internet and ran a program that was apparently supposed to fix my problem, but I reckon it changed a lot of system files. I restarted the computer to see if MSN would work. Well, when loading up, the PC froze at the login screen, didn't show any usernames or pictures or shut down options. I restarted again and it still would not work. So I inserted my Windows XP disc and repaired it. Now, when I boot the PC up, it goes as far as the "Welcome to Windows" screen. It's all blue with 2 dark blue bars, one at the top, and one at the bottom. The Microsoft Windows XP logo is in the middle, and the cursor is shown. But it just hangs there, and won't load. I tried booting in Safe Mode, but all it did was go to the same screen as normal boot, then it restarts the PC. I've also tried booting on the last known configuration, still nothing. I'm so sorry for all these threads...

EscondeR
06-10-08, 19:34
Can you first tell us what program exactly have you run to bring your PC to this condition?

Jordan_Boi
07-10-08, 06:38
I followed the steps on this page. It was SubInACL that I downloaded.

EscondeR
07-10-08, 07:34
SubInACL is a command line tool. So what exactly command line did you pass to it before your system got "crapped"?

Jordan_Boi
07-10-08, 14:33
Well, as the tutorial told me, I created a Notepad file, and pasted this into it:

subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f

subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=system=f

After, I saved it as "reset.bat" and saved it into C:\Program Files\Windows Resource Kits\Tools. Then, I ran the reset.bat file. It did some stuff, which I can't remember for the life of me. But all I remember is I added nothing to the bat file. Then after, I reset. I'm sorry for the lack of information, I have a bad memory.

Jordan_Boi
07-10-08, 21:20
I managed to fix the boot problem, luckily. I made myself a Linux Live CD, booted it, and moved all the files I wanted to the second harddrive. I completely formatted the C: drive and reinstalled XP, it's working fine. Although a lot of drivers are missing. And I can't connect to the internet. My modem is connected the same way as it was before, the lights are turned on, and it's working fine. I downloaded the drivers for it from the Acer website and sent them to my PC using a memory stick. I installed the drivers, and they're installed as "Agere Systems PCI Soft Modem". Yet the PC doesn't recognise the modem whatsoever. By the way, the modem is connected to a router which my sister's laptop uses, and her internet is perfect. It's an NTL 100 modem I think.

spikejones
08-10-08, 01:26
you need drivers for your ETHERNET card ;)

btw, those commands you ran looks like it was a registry tweak.

EscondeR
08-10-08, 05:26
First you got full rights over vital Registry sections - wrong move, if you don't know what you're doing/going to do.

It did some stuff, which I can't remember for the life of me.

Have you done anything in the registry manually?
Then obviously you killed/messed some keys by accident.

you need drivers for your ETHERNET card ;)

YES.