PDA

View Full Version : Problems with TR1 and TR2 on PS3


lafree
03-11-08, 15:38
Hi!
I'm having some problems with my PS3, or let's say with TR1 and 2 on it.
Everything is working fine when I put the disc in and start the game but only until the menu shows up...first there is no music playing in the background though there's sound! Ok I can live with that but whenever I try to play the actual game or croft manor a black screen shows up and nothing happens :hea:

I tried everything!!! But it's not working I thought the disc itself would be broken but I tested it on a PS2 at my friends house (since I don't have a PS2 anymore) and it worked perfectly. the only explanation I have is the f***ing update on my PS3 that stops it from running! All the other games work and I don't want to spend my money for a new PS2 just for 2 games!

Does anybody else have those problems or does anyone have an idea what I could do!!!! PLEASE HELP :(:(

lararoxs
03-11-08, 15:58
Isn't there only certain games or versions of a game that will work on the PS3?
I don't anything on it but, I though you had to have the right version to be able to play it.

lafree
03-11-08, 16:00
Oh well I forgot to mention that I have the older version of the PS3 that can run PS1 and PS2 games but the thing is that I played those games before and they ran perfectly on my console!!!!

EscondeR
03-11-08, 20:48
^ Well, you have answered your own question - the firmware update ruined backward compatibility! Was it legal (firmware)?

lafree
04-11-08, 12:44
Yes it was! I did that on my PS3 itself! S**t, now I have to think about another way to play those games since I loved them soooo much....but thx for the replies :)