PDA

View Full Version : Assassin's Creed won't work on Xbox 360


Ward Dragon
09-11-08, 21:33
My brother got Assassin's Creed for the 360 about a year ago and it worked fine for awhile. A few months ago it stopped working completely for no apparent reason. The game fails to start every single time, no matter how long we let it sit.

The disc looks flawless (no marks or scratches) and we do not get any error messages from the disc. It just sits there in the drive making noise without doing anything. We have even tried clearing the 360's cache (many people online said that solved the problem for them) but it didn't do anything for us.

Assassin's Creed stopped working before the patch came out so we never got to download it. We cannot figure out how to download the patch now because the game will not start so the auto-updater does not work. All of our other games work (including 360 and original Xbox games).

Does anybody have any advice? Thanks in advance :)

raiderfun
09-11-08, 22:30
Did you first try AC on another Xbox console ? To be sure if the problem is coming from the console or the DVD !

Ward Dragon
09-11-08, 23:05
I don't have access to another console at the moment. I don't think it's a physical problem with the disc (it looks in perfect condition) and I don't think it's a physical problem with the console (it reads all other discs just fine). I'm guessing that it's a software problem. The game probably somehow corrupted a file it needs in the console. We tried deleting all information from the game (saves and whatnot) to get a fresh start, but the console still remembers achievements so obviously there's still something from the game on the harddrive.

We thought that maybe the update might fix this problem. Is there anyway to download updates manually from Xbox LIVE without using the auto-updater?