PDA

View Full Version : Transparent "desktop.ini" file on Desktop ?!?!


fondantcookie
23-11-08, 01:45
Hey all. I noticed lastnight that two new files have suddenly appeared on my desktop. The two files both have the same name and file extension ("desktop.ini") and the icon fir them are both semi transparent....

Does anyone know what a "desktop.ini" file is? Why has it appeared? And can I just delete it?

Thanks in advance :-)

Neteru
23-11-08, 01:50
A desktop.ini file is a configuration file used to store information for the system on how to display that file and it's contents. If you have made any such recent changes, this is why you have one, but to have two doesn't make much sense. They can be deleted without any serious consequence to your system.

If you are really wondering, you can open them in notepad to see what they are configured for.

fondantcookie
23-11-08, 02:01
Thanks Neteru

I was updating windows shortly before the two icons appeared.

I opened them both in notepad as you suggested and here is what they contain:

"[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell 32.dll,-21799"

And in the second one

"[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell 32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183"

So i can just delete them then?

Thanks again mate ! :)

Neteru
23-11-08, 02:22
You can do a couple of things. If you're not worried, just delete them. That's what I'd do.

If you are worried, you could send them to the recycle bin and see if you get any problems/error messages. If you do, you can restore them. If not, permanently delete them.

Or, having system files showing as you do have, you can choose to keep them, but set your desktop folder to hide them.

To do that, go to your account folder in C:\Documents and Settings\YOUR ACCOUNT FOLDER\Desktop\

Click on Tools/Folder Options and then click on the View tab. Scroll down in the box and check the radio button: Do not show hidden files and folders. Click Apply and OK.

Incidentally, they appear transparent because they're hidden files.

EscondeR
23-11-08, 09:30
^ I'd like to add to that:
Commonly if showing hidden/system files is enabled - those files (desktop.ini) are still not shown, they appear if the option "Hide protected system files" is unticked in Tools/Folder Options > View tab. :)