PDA

View Full Version : Occasional, unexplained frame skips


Rinnerz
23-11-08, 16:29
I finally managed to get my copy of TRU last night :yah:. Before getting too into the game though, I decided to mess around with my video settings to try to get the most ideal balance between graphical quality and game performance.

The reason I put emphasis on this is because, after my first couple runs through the demo, I had noticed something a little... strange. With my current system setup, I would be able to run the demo at max settings, with a resolution of 1280x1024, 2x AA and 16x AF (and VSync enabled) with absolutely no issues... with the exception of the occasional, unexplained frame skip. By "no issues", I mean the gameplay was perfectly smooth. Tests with Fraps yielded an average framerate of 45-52 FPS as well.

But... the random frame skips are curious, and it is a problem that is apparently also present with the final game. To clarify, they are typically noticed during a cutscene (especially cutscenes that begin a level). There were times that I noticed a slight, very quick frame skip during normal gameplay, but this was usually when the game would load a new area and turning off all running System Tray apps seems to have rectified this problem.

Anyway, I've been messing with this for a couple hours now, ever since I noticed the same problem in the game itself. What puzzles me is that troubleshooting this via a process of elimination doesn't seem to help at all: turning the resolution down doesn't affect these random skips one bit; the same goes for turning off Shadows, VSync, turning down AF, and turning off AA. The random frame skips are always there, even though they're not frequent and not "game-breaking" in any way.

This all seems to point to the issue not being caused by my video card (and its limitations) but, rather, something else. But I'm not sure what, exactly. To give an idea of how "frequent" these skips are: during the demo, I would see the frame skips anywhere from once to three times. Never anymore than that. During the training level in the manor (in the actual game), I would see them: 1) at the very beginning, during the short cutscene there with the explosion, and 2) at the end of that first hallway, just as I'm about to turn the corner. After that, there is always one (sometimes two) short skips during the cutscene at the beginning of the Mediterranean level. (I haven't actually played this level yet, so I can't give any feedback for the rest of the game.)

Gah! :o I apologize for the wall of text here. :) Any theories/ideas would be most appreciated. For those curious, here are my Diagnose.exe results:

(EDIT: I should mention that, as of my last test, there were no frame skips during the training level in the manor. Maybe this was because I made sure to kill all system tray apps, or... maybe I was just lucky? <.< Who knows. There were still 2 skips in the Med level intro cutscene, though.)

------------------------------------------------------
Diagnostic tool developed for www.tombraiderforums.com
------------------------------------------------------
Version : 2.44
Author : Simulation

Select All (Ctrl A) then Copy (Ctrl C) and paste (Ctrl V) the text in Notepad into a reply on the forum.

Operating System

Windows XP Detected

COMMAND.COM
COMMAND.COM has been installed

Autoexec.NT
@echo off
lh %SystemRoot%\system32\mscdexnt.exe
lh %SystemRoot%\system32\redir
lh %SystemRoot%\system32\dosx
SET BLASTER=A220 I5 D1 P330 T3

Config.NT
dos=high, umb
device=%SystemRoot%\system32\himem.sys
files=40

Programs Currently Running

Image Name PID Session Name Session# Mem Usage
========================= ====== ================ ======== ============
System Idle Process 0 Console 0 28 K
System 4 Console 0 288 K
smss.exe 600 Console 0 420 K
csrss.exe 656 Console 0 3,652 K
winlogon.exe 688 Console 0 2,128 K
services.exe 780 Console 0 6,464 K
lsass.exe 792 Console 0 1,732 K
ati2evxx.exe 952 Console 0 3,912 K
svchost.exe 980 Console 0 4,888 K
svchost.exe 1032 Console 0 4,344 K
MsMpEng.exe 1140 Console 0 26,680 K
svchost.exe 1224 Console 0 27,364 K
svchost.exe 1260 Console 0 3,408 K
ati2evxx.exe 1304 Console 0 4,488 K
svchost.exe 1472 Console 0 5,936 K
svchost.exe 1548 Console 0 6,492 K
aawservice.exe 1636 Console 0 1,344 K
explorer.exe 1868 Console 0 28,864 K
spoolsv.exe 200 Console 0 5,520 K
smax4pnp.exe 356 Console 0 4,888 K
ctfmon.exe 628 Console 0 3,432 K
MOM.exe 632 Console 0 5,828 K
avgwdsvc.exe 2144 Console 0 2,696 K
mdm.exe 2904 Console 0 3,188 K
avgrsx.exe 3188 Console 0 49,232 K
svchost.exe 3228 Console 0 4,340 K
alg.exe 1700 Console 0 3,612 K
svchost.exe 2728 Console 0 3,540 K
CCC.exe 3500 Console 0 11,056 K
diagnose.exe 2996 Console 0 3,756 K
ns6.tmp 3104 Console 0 1,176 K
cmd.exe 2824 Console 0 1,760 K
tasklist.exe 2424 Console 0 4,536 K
wmiprvse.exe 3152 Console 0 5,784 K

System Event Log - Warning and Errors Only (last 24hrs)

Event Log from 08:00am on the 22/11/2008

Tomb Raider Game Setup Information


Tomb Raider: Legend Installed
Installed in C:\Program Files\Tomb Raider - Legend
trl.exe File Size = 16859136 bytes - Version - Universal Disc Patch 1.2

Registry Settings
Full Install - True
Version 258
Language - English
EAXSupport Disabled
Disable 32Bit Textures......... Off
Disable Driver Management...... Off
Disable Dynamic Textures....... On
Disable Hardware DXTC.......... Off
Disable Hardware Shadow Maps... Off
Disable Hardware VP............ Off
Disable Non Pow2 Textures...... Off
Disable Null Render Targets.... Off
Dont Defer Shader Creation..... Off
Enable Depth Of Field.......... On
Enable FSAA.................... Off
Enable Full screen Effects..... On
EnableReflection............... On
Enable Shadows................. On
Enable VSync................... On
Enable Water FX................ On
Full screen.................... On
UseD3DFPUPreserve.............. Off
Use Low Res Depth Of Field..... Off
Use Ref Device................. Off
Use Shader20................... Off
Use Shader30................... On

Tomb Raider: Anniversary Installed
Properties Version 1.0
Installed in C:\Program Files\Tomb Raider - Anniversary
tra.exe File Size = 9369752 bytes - Version - Original Version (1.0)

Registry Settings
Full Install - True
Version 256
Language - English
EAXSupport Disabled
Combat Mode.................... Advanced Toggle
Disable 32Bit Textures......... Off
Disable Driver Management...... Off
Disable Dynamic Textures....... On
Disable Hardware DXTC.......... Off
Disable Hardware Shadow Maps... Off
Disable Hardware VP............ Off
Disable Non Pow2 Textures...... Off
Disable Null Render Targets.... Off
Dont Defer Shader Creation..... Off
Enable Depth Of Field.......... On
Enable FSAA.................... 2xAA
Enable Full screen Effects..... On
EnableReflection............... On
Enable Shadows................. On
Enable VSync................... On
Enable Water FX................ On
Full screen.................... On
UseD3DFPUPreserve.............. Off
Use Low Res Depth Of Field..... Off

Use Ref Device................. Off
Use Shader20................... Off
Use Shader30................... On


DirectX Diagnostics Report

------------------
System Information
------------------
Time of this report: 11/23/2008, 13:04:14
Machine name: RIN
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.080814-1236)
Language: English (Regional Setting: English)
System Manufacturer: System manufacturer
System Model: System Product Name
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+, MMX, 3DNow (2 CPUs), ~2.2GHz
Memory: 2046MB RAM
Page File: 452MB used, 3486MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode

------------
DxDiag Notes
------------
DirectX Files Tab: No problems found.
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (n/a)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: ATI Radeon HD 3850
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor (0x9505)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_9505&SUBSYS_25421002&REV_00
Display Memory: 256.0 MB
Current Mode: 1280 x 1024 (32 bit) (60Hz)
Monitor: Plug and Play Monitor
Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6879 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 10/28/2008 22:52:02, 314880 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 10/28/2008 23:40:58, 3341824 bytes
Device Identifier: {D7B71EE2-D645-11CF-6D69-4805A1C2CB35}
Vendor ID: 0x1002
Device ID: 0x9505
SubSys ID: 0x25421002
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D ModeWMV8_A ModeWMV9_A
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

-------------
Sound Devices
-------------
Description: SoundMAX HD Audio
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: HDAUDIO\FUNC_01&VEN_11D4&DEV_198B&SUBSYS_104381F6&REV_1004
Manufacturer ID: 65535
Product ID: 65535
Type: WDM
Driver Name: ADIHdAud.sys
Driver Version: 5.10.0001.6110 (English)
Driver Attributes: Final Retail
WHQL Logo'd: n/a
Date and Size: 1/15/2007 21:39:06, 293888 bytes
Other Files:
Driver Provider: AnalogDevices
HW Accel Level: Full
Cap Flags: 0x0
Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: Yes
EAX(tm) 2.0 Listen/Src: Yes, Yes
I3DL2(tm) Listen/Src: Yes, Yes
Sensaura(tm) ZoomFX(tm): Yes
Registry: OK
Sound Test Result: Not run

---------------------
Sound Capture Devices
---------------------
Description: SoundMAX HD Audio
Default Sound Capture: Yes
Default Voice Capture: Yes
Driver Name: ADIHdAud.sys
Driver Version: 5.10.0001.6110 (English)
Driver Attributes: Final Retail
Date and Size: 1/15/2007 21:39:06, 293888 bytes
Cap Flags: 0x0
Format Flags: 0x0

-----------
DirectMusic
-----------
DLS Path: C:\WINDOWS\SYSTEM32\drivers\GM.DLS
DLS Version: 1.00.0016.0002
Acceleration: n/a
Ports: Microsoft Synthesizer, Software (Not Kernel Mode), Output, DLS, Internal, Default Port
Microsoft MIDI Mapper [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
Microsoft GS Wavetable SW Synth [Emulated], Hardware (Not Kernel Mode), Output, No DLS, Internal
Registry: OK
Test Result: Not run

-------------------
DirectInput Devices
-------------------
Device Name: Mouse
Attached: 1
Controller ID: n/a
Vendor/Product ID: n/a
FF Driver: n/a

Device Name: Keyboard
Attached: 1
Controller ID: n/a
Vendor/Product ID: n/a
FF Driver: n/a

Device Name: USB-compliant keyboard
Attached: 1
Controller ID: 0x0
Vendor/Product ID: 0x0518, 0x0001
FF Driver: n/a

Device Name: USB-compliant keyboard
Attached: 1
Controller ID: 0x0
Vendor/Product ID: 0x0518, 0x0001
FF Driver: n/a

Poll w/ Interrupt: No
Registry: OK

-----------
USB Devices
-----------
+ USB Root Hub
| Vendor/Product ID: 0x10DE, 0x036C
| Matching Device ID: usb\root_hub
| Service: usbhub
| Driver: usbhub.sys, 4/13/2008 15:15:37, 59520 bytes
| Driver: usbd.sys, 9/2/2003 07:00:00, 4736 bytes
|
+-+ USB Human Interface Device
| | Vendor/Product ID: 0x04F3, 0x0212
| | Location: PS/2+USB Mouse
| | Matching Device ID: usb\class_03&subclass_01
| | Service: HidUsb
| | Driver: hidusb.sys, 4/13/2008 15:15:27, 10368 bytes
| | Driver: hidclass.sys, 4/13/2008 15:15:26, 36864 bytes
| | Driver: hidparse.sys, 4/13/2008 15:15:22, 24960 bytes
| | Driver: hid.dll, 4/13/2008 20:41:54, 20992 bytes
| |
| +-+ HID-compliant mouse
| | | Vendor/Product ID: 0x04F3, 0x0212
| | | Matching Device ID: hid_device_system_mouse
| | | Service: mouhid
| | | Driver: mouclass.sys, 4/13/2008 15:09:47, 23040 bytes
| | | Driver: mouhid.sys, 9/2/2003 07:00:00, 12160 bytes

----------------
Gameport Devices
----------------

------------
PS/2 Devices
------------
+ HID Keyboard Device
| Vendor/Product ID: 0x0518, 0x0001
| Matching Device ID: hid_device_system_keyboard
| Service: kbdhid
| Driver: kbdhid.sys, 4/13/2008 15:09:48, 14592 bytes
| Driver: kbdclass.sys, 4/13/2008 15:09:47, 24576 bytes
|
+ Terminal Server Keyboard Driver
| Matching Device ID: root\rdp_kbd
| Upper Filters: kbdclass
| Service: TermDD
| Driver: termdd.sys, 4/13/2008 20:43:20, 40840 bytes
| Driver: kbdclass.sys, 4/13/2008 15:09:47, 24576 bytes
|
+ HID-compliant mouse
| Vendor/Product ID: 0x0518, 0x0001
| Matching Device ID: hid_device_system_mouse
| Service: mouhid
| Driver: mouclass.sys, 4/13/2008 15:09:47, 23040 bytes
| Driver: mouhid.sys, 9/2/2003 07:00:00, 12160 bytes
|
+ Terminal Server Mouse Driver
| Matching Device ID: root\rdp_mou
| Upper Filters: mouclass
| Service: TermDD
| Driver: termdd.sys, 4/13/2008 20:43:20, 40840 bytes
| Driver: mouclass.sys, 4/13/2008 15:09:47, 23040 bytes

----------------------------
DirectPlay Service Providers
----------------------------
DirectPlay8 Modem Service Provider - Registry: OK, File: dpnet.dll (5.03.2600.5512)
DirectPlay8 Serial Service Provider - Registry: OK, File: dpnet.dll (5.03.2600.5512)
DirectPlay8 IPX Service Provider - Registry: OK, File: dpnet.dll (5.03.2600.5512)
DirectPlay8 TCP/IP Service Provider - Registry: OK, File: dpnet.dll (5.03.2600.5512)
Internet TCP/IP Connection For DirectPlay - Registry: OK, File: dpwsockx.dll (5.03.2600.5512)
IPX Connection For DirectPlay - Registry: OK, File: dpwsockx.dll (5.03.2600.5512)
Modem Connection For DirectPlay - Registry: OK, File: dpmodemx.dll (5.03.2600.5512)
Serial Connection For DirectPlay - Registry: OK, File: dpmodemx.dll (5.03.2600.5512)

DirectPlay Voice Wizard Tests: Full Duplex: Not run, Half Duplex: Not run, Mic: Not run
DirectPlay Test Result: Not run
Registry: OK

-------------------
DirectPlay Adapters
-------------------
DirectPlay8 Serial Service Provider: COM1
DirectPlay8 TCP/IP Service Provider: Local Area Connection - IPv4 -

-----------------------
DirectPlay Voice Codecs
-----------------------
Voxware VR12 1.4kbit/s
Voxware SC06 6.4kbit/s
Voxware SC03 3.2kbit/s
MS-PCM 64 kbit/s
MS-ADPCM 32.8 kbit/s
Microsoft GSM 6.10 13 kbit/s
TrueSpeech(TM) 8.6 kbit/s

-------------------------
DirectPlay Lobbyable Apps
-------------------------

------------------------
Disk & DVD/CD-ROM Drives
------------------------
Drive: C:
Free Space: 65.6 GB
Total Space: 152.6 GB
File System: NTFS
Model: WDC WD1600AAJS-19PSA0

Drive: E:
Free Space: 10.3 GB
Total Space: 194.5 GB
File System: NTFS
Model: Maxtor 3200 USB Device

Drive: D:
Model: HL-DT-ST DVDRAM GSA-H62N
Driver: c:\windows\system32\drivers\cdrom.sys, 5.01.2600.5512 (English), 4/13/2008 15:10:46, 62976 bytes

Drive: F:
Model: XMVA LA78HM7KPAJ SCSI CdRom Device
Driver: c:\windows\system32\drivers\cdrom.sys, 5.01.2600.5512 (English), 4/13/2008 15:10:46, 62976 bytes

--------------
System Devices
--------------
Name: NVIDIA nForce 590/570/550 Serial ATA Controller
Device ID: PCI\VEN_10DE&DEV_037F&SUBSYS_82391043&REV_A3\3&2411E6FE&0&2A
Driver: C:\WINDOWS\system32\DRIVERS\nvata.sys, 5.10.2600.0687 (English), 8/21/2006 06:54:28, 105344 bytes
Driver: C:\WINDOWS\system32\idecoi.dll, 1.00.0000.0001 (English), 8/21/2006 06:54:30, 363008 bytes
Driver: C:\WINDOWS\system32\idecoiins.dll, 1.00.0000.0001 (English), 8/21/2006 06:54:30, 363008 bytes
Driver: C:\WINDOWS\system32\NVCOI.DLL, 1.00.0000.0035 (English), 8/17/2006 22:58:32, 35840 bytes

Name: NVIDIA nForce 590/570/550 Serial ATA Controller
Device ID: PCI\VEN_10DE&DEV_037F&SUBSYS_82391043&REV_A3\3&2411E6FE&0&29
Driver: C:\WINDOWS\system32\DRIVERS\nvata.sys, 5.10.2600.0687 (English), 8/21/2006 06:54:28, 105344 bytes
Driver: C:\WINDOWS\system32\idecoi.dll, 1.00.0000.0001 (English), 8/21/2006 06:54:30, 363008 bytes
Driver: C:\WINDOWS\system32\idecoiins.dll, 1.00.0000.0001 (English), 8/21/2006 06:54:30, 363008 bytes
Driver: C:\WINDOWS\system32\NVCOI.DLL, 1.00.0000.0035 (English), 8/17/2006 22:58:32, 35840 bytes

Name: NVIDIA nForce 590/570/550 Serial ATA Controller
Device ID: PCI\VEN_10DE&DEV_037F&SUBSYS_82391043&REV_A3\3&2411E6FE&0&28
Driver: C:\WINDOWS\system32\DRIVERS\nvata.sys, 5.10.2600.0687 (English), 8/21/2006 06:54:28, 105344 bytes
Driver: C:\WINDOWS\system32\idecoi.dll, 1.00.0000.0001 (English), 8/21/2006 06:54:30, 363008 bytes
Driver: C:\WINDOWS\system32\idecoiins.dll, 1.00.0000.0001 (English), 8/21/2006 06:54:30, 363008 bytes
Driver: C:\WINDOWS\system32\NVCOI.DLL, 1.00.0000.0035 (English), 8/17/2006 22:58:32, 35840 bytes

Name: PCI standard PCI-to-PCI bridge
Device ID: PCI\VEN_10DE&DEV_0377&SUBSYS_00000000&REV_A3\3&2411E6FE&0&78
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (English), 4/13/2008 15:06:44, 68224 bytes

Name: NVIDIA Network Bus Enumerator
Device ID: PCI\VEN_10DE&DEV_0373&SUBSYS_82391043&REV_A3\3&2411E6FE&0&40
Driver: C:\WINDOWS\system32\DRIVERS\nvnetbus.sys, 1.00.0003.6531 (English), 9/11/2006 08:15:38, 19968 bytes
Driver: C:\WINDOWS\system32\DRIVERS\nvnrm.sys, 1.00.0002.6531 (English), 9/11/2006 08:15:16, 1161088 bytes
Driver: C:\WINDOWS\system32\DRIVERS\nvsnpu.sys, 1.00.0002.6531 (English), 9/11/2006 08:14:58, 261632 bytes
Driver: C:\WINDOWS\system32\DRIVERS\nvtcp.sys, 1.00.0003.6531 (English), 9/11/2006 08:15:26, 110592 bytes
Driver: C:\WINDOWS\system32\bdco1.dll, 1.00.0000.0000 (English), 9/11/2006 08:13:42, 11264 bytes
Driver: C:\WINDOWS\system32\bdco1ins.dll, 1.00.0000.0000 (English), 9/11/2006 08:13:42, 11264 bytes
Driver: C:\WINDOWS\system32\nvconrm.dll, 1.00.0000.0035 (English), 9/11/2006 05:36:48, 35840 bytes

Name: Microsoft UAA Bus Driver for High Definition Audio
Device ID: PCI\VEN_10DE&DEV_0371&SUBSYS_81F61043&REV_A2\3&2411E6FE&0&31
Driver: C:\WINDOWS\system32\DRIVERS\hdaudbus.sys, 5.10.0001.5013 (English), 4/13/2008 13:06:05, 144384 bytes

Name: PCI standard PCI-to-PCI bridge
Device ID: PCI\VEN_10DE&DEV_0370&SUBSYS_00000000&REV_A2\3&2411E6FE&0&30
Driver: C:\WINDOWS\system32\DRIVERS\pci.sys, 5.01.2600.5512 (English), 4/13/2008 15:06:44, 68224 bytes

Name: Standard Dual Channel PCI IDE Controller
Device ID: PCI\VEN_10DE&DEV_036E&SUBSYS_82391043&REV_A1\3&2411E6FE&0&20
Driver: C:\WINDOWS\system32\DRIVERS\pciidex.sys, 5.01.2600.5512 (English), 4/13/2008 15:10:29, 24960 bytes
Driver: C:\WINDOWS\system32\DRIVERS\atapi.sys, 5.01.2600.5512 (English), 4/13/2008 15:10:30, 96512 bytes
Driver: C:\WINDOWS\system32\DRIVERS\pciide.sys, 5.01.2600.0000 (English), 9/2/2003 07:00:00, 3328 bytes

Name: Standard Enhanced PCI to USB Host Controller
Device ID: PCI\VEN_10DE&DEV_036D&SUBSYS_82391043&REV_A2\3&2411E6FE&0&11
Driver: C:\WINDOWS\system32\drivers\usbehci.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:35, 30208 bytes
Driver: C:\WINDOWS\system32\drivers\usbport.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:36, 143872 bytes
Driver: C:\WINDOWS\system32\usbui.dll, 5.01.2600.5512 (English), 4/13/2008 20:42:08, 74240 bytes
Driver: C:\WINDOWS\system32\drivers\usbhub.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:37, 59520 bytes
Driver: C:\WINDOWS\system32\hccoin.dll, 5.01.2600.5512 (English), 4/13/2008 20:41:54, 7168 bytes

Name: Standard OpenHCD USB Host Controller
Device ID: PCI\VEN_10DE&DEV_036C&SUBSYS_82391043&REV_A1\3&2411E6FE&0&10
Driver: C:\WINDOWS\system32\drivers\usbohci.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:35, 17152 bytes
Driver: C:\WINDOWS\system32\drivers\usbport.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:36, 143872 bytes
Driver: C:\WINDOWS\system32\usbui.dll, 5.01.2600.5512 (English), 4/13/2008 20:42:08, 74240 bytes
Driver: C:\WINDOWS\system32\drivers\usbhub.sys, 5.01.2600.5512 (English), 4/13/2008 15:15:37, 59520 bytes

Name: PCI standard RAM Controller
Device ID: PCI\VEN_10DE&DEV_0369&SUBSYS_82391043&REV_A2\3&2411E6FE&0&00
Driver: n/a

Name: NVIDIA nForce PCI System Management
Device ID: PCI\VEN_10DE&DEV_0368&SUBSYS_82391043&REV_A3\3&2411E6FE&0&09
Driver: n/a

Name: PCI standard ISA bridge
Device ID: PCI\VEN_10DE&DEV_0360&SUBSYS_00000000&REV_A3\3&2411E6FE&0&08
Driver: C:\WINDOWS\system32\DRIVERS\isapnp.sys, 5.01.2600.5512 (English), 4/13/2008 15:06:41, 37248 bytes

Name: PCI standard host CPU bridge
Device ID: PCI\VEN_1022&DEV_1103&SUBSYS_00000000&REV_00\3&2411E6FE&0&C3
Driver: n/a

Name: PCI standard host CPU bridge
Device ID: PCI\VEN_1022&DEV_1102&SUBSYS_00000000&REV_00\3&2411E6FE&0&C2
Driver: n/a

Name: PCI standard host CPU bridge
Device ID: PCI\VEN_1022&DEV_1101&SUBSYS_00000000&REV_00\3&2411E6FE&0&C1
Driver: n/a

Name: PCI standard host CPU bridge
Device ID: PCI\VEN_1022&DEV_1100&SUBSYS_00000000&REV_00\3&2411E6FE&0&C0
Driver: n/a

Name: Microsoft UAA Bus Driver for High Definition Audio
Device ID: PCI\VEN_1002&DEV_AA18&SUBSYS_AA181002&REV_00\4&154B9167&0&0178
Driver: C:\WINDOWS\system32\DRIVERS\hdaudbus.sys, 5.10.0001.5013 (English), 4/13/2008 13:06:05, 144384 bytes

Name: ATI Radeon HD 3850
Device ID: PCI\VEN_1002&DEV_9505&SUBSYS_25421002&REV_00\4&154B9167&0&0078
Driver: C:\WINDOWS\system32\DRIVERS\ati2mtag.sys, 6.14.0010.6879 (English), 10/28/2008 23:40:58, 3341824 bytes
Driver: C:\WINDOWS\system32\DRIVERS\ati2erec.dll, 1.00.0000.0015 (English), 10/28/2008 21:48:47, 53248 bytes
Driver: C:\WINDOWS\system32\ati2dvag.dll, 6.14.0010.6879 (English), 10/28/2008 22:52:02, 314880 bytes
Driver: C:\WINDOWS\system32\ati2cqag.dll, 6.14.0010.0400 (English), 10/28/2008 21:42:51, 577536 bytes
Driver: C:\WINDOWS\system32\Ati2mdxx.exe, 6.14.0010.2495 (English), 10/28/2008 22:41:12, 26112 bytes
Driver: C:\WINDOWS\system32\ati3duag.dll, 6.14.0010.0621 (English), 10/28/2008 22:27:58, 4041472 bytes
Driver: C:\WINDOWS\system32\ativvaxx.dll, 6.14.0010.0205 (English), 10/28/2008 22:11:13, 2472832 bytes
Driver: C:\WINDOWS\system32\atiicdxx.dat, 8/14/2008 14:12:21, 176214 bytes
Driver: C:\WINDOWS\system32\ativvaxx.dat, 10/28/2008 22:10:41, 3107788 bytes
Driver: C:\WINDOWS\system32\ativva5x.dat, 10/28/2008 22:10:41, 3107788 bytes
Driver: C:\WINDOWS\system32\ativva6x.dat, 10/28/2008 22:10:41, 887724 bytes
Driver: C:\WINDOWS\system32\amdpcom32.dll, 6.14.0010.0017 (English), 10/28/2008 21:55:31, 48640 bytes
Driver: C:\WINDOWS\system32\atiadlxx.dll, 6.14.0010.1017 (English), 10/28/2008 21:49:50, 44032 bytes
Driver: C:\WINDOWS\system32\ativvaxx.cap, 11/23/2008 12:13:10, 60452 bytes
Driver: C:\WINDOWS\system32\ATIDDC.DLL, 6.14.0010.0008 (English), 10/28/2008 22:37:44, 53248 bytes
Driver: C:\WINDOWS\system32\atitvo32.dll, 6.14.0010.4200 (English), 10/28/2008 21:49:40, 17408 bytes
Driver: C:\WINDOWS\system32\ativcoxx.dll, 6.13.0010.0005 (English), 11/9/2001 11:31:04, 24064 bytes
Driver: C:\WINDOWS\system32\ati2evxx.exe, 6.14.0010.4211 (English), 10/28/2008 22:39:10, 585728 bytes
Driver: C:\WINDOWS\system32\ati2evxx.dll, 6.14.0010.4177 (English), 10/28/2008 22:40:45, 143360 bytes
Driver: C:\WINDOWS\system32\atipdlxx.dll, 6.14.0010.2542 (English), 10/28/2008 22:41:35, 188416 bytes
Driver: C:\WINDOWS\system32\Oemdspif.dll, 6.15.0005.0000 (English), 10/28/2008 22:41:21, 147456 bytes
Driver: C:\WINDOWS\system32\ati2edxx.dll, 6.14.0010.2513 (English), 10/28/2008 22:41:03, 43520 bytes
Driver: C:\WINDOWS\system32\atikvmag.dll, 6.14.0010.0090 (English), 10/28/2008 21:51:21, 389120 bytes
Driver: C:\WINDOWS\system32\atifglpf.xml, 8/31/2007 09:50:49, 7167 bytes
Driver: C:\WINDOWS\system32\ATIDEMGX.dll, 2.00.3223.38500 (English), 10/28/2008 22:53:22, 425984 bytes
Driver: C:\WINDOWS\system32\atibrtmon.exe, 2.00.0000.0000 (English), 10/21/2008 14:21:43, 118784 bytes
Driver: C:\WINDOWS\system32\atiok3x2.dll, 6.14.0010.8201 (English), 10/28/2008 21:48:30, 253952 bytes
Driver: C:\WINDOWS\system32\atioglxx.dll, 6.14.0010.8201 (English), 10/28/2008 22:40:59, 10973184 bytes
Driver: C:\WINDOWS\system32\atiiiexx.dll, 6.14.0010.4006 (English), 10/28/2008 22:19:31, 307200 bytes
Driver: C:\WINDOWS\atiogl.xml, 9/12/2008 00:25:15, 14849 bytes
Driver: C:\WINDOWS\system32\ATIODCLI.exe, 1.00.0000.0001 (English), 10/21/2008 13:10:00, 45056 bytes
Driver: C:\WINDOWS\system32\ATIODE.exe, 1.00.0000.0001 (English), 10/21/2008 13:10:00, 81920 bytes
Driver: C:\WINDOWS\system32\ATIODCLI.exe.manifest, 9/29/2008 16:52:29, 529 bytes
Driver: C:\WINDOWS\system32\ATIODE.exe.manifest, 10/3/2008 17:18:01, 527 bytes

------------------

abraham
23-11-08, 23:41
In CCC turn off adaptive AA if you can.

have you got the latest ati drivers? 8.11 http://downloads.guru3d.com/

also rename the tru.exe to trl.exe and see if that helps.

Rinnerz
24-11-08, 01:49
In CCC turn off adaptive AA if you can.

have you got the latest ati drivers? 8.11 http://downloads.guru3d.com/

also rename the tru.exe to trl.exe and see if that helps.

Thanks for the reply :)

1) Not sure if I have that turned on. If I do, I'll mess around with it.
2) Yep :tmb:
3) Wasn't that "fix" focused on people using newer chipsets in CrossFire?

Also, I've just completed the Thailand chapters, and judging from the scarcity of these pauses/skips, as well as when they occur, it seems like it's just being caused by the game having to take that extra second to load up content. With maybe a few exceptions, there were no real skips during my gameplay today, so... *shrug*. Not sure what's going on there; 95% of the time, the gameplay is smooth as butter. That's why these sudden skips seem so strange to me.

EDIT: Forgot to add this. I have a habit of saving the game very often, and while playing through the Mediterranean and Thailand chapters this evening... the game actually crashed to my desktop twice. This happened immediately after I'd save my game. It was just the usual "This program has encountered an error and needs to close" type message. I'd reload the game right afterwards, and it seems that--despite the crash--the game does save my game properly. I'm not sure if this is a known/common bug with the game, so thought I'd mention it.

abraham
24-11-08, 13:03
This isnt normal. Format?lol where is Esconda??


Yea i get that pause aswell at same parts of the level. Its a issue with graphics drivers. the readme explains it. It will be fixed for Nvidia users though.

Rinnerz
24-11-08, 17:09
This isnt normal. Format?

You speak of evil, here :ohn:


lol where is Esconda??

Hah, probably enjoying not being nagged by all of us around here :p


Yea i get that pause aswell at same parts of the level. Its a issue with graphics drivers. the readme explains it. It will be fixed for Nvidia users though.

Hrmm, weird indeed. I don't know if it's the same issue, though. The problem the nVidia users are getting is supposed to be restricted to the 6/7 series cards, as far as I know.

EscondeR
24-11-08, 18:08
:p

This happened immediately after I'd save my game. It was just the usual "This program has encountered an error and needs to close" type message. I'd reload the game right afterwards, and it seems that--despite the crash--the game does save my game properly. I'm not sure if this is a known/common bug with the game, so thought I'd mention it.

1. Do you have DEP service disabled?

2. What exactly processes do you have running with TRU simultaneously?

3. Try also the following: Make your paging file of constant size: MIN=MAX=~3,5Gb

Rinnerz
24-11-08, 19:04
Thanks for the reply, EscondeR :)

1. Do you have DEP service disabled?

:o Apparently, I didn't. Just disabled it now :tmb:

2. What exactly processes do you have running with TRU simultaneously?

Well, figured this would be as good a way as any to show you:

http://i14.photobucket.com/albums/a309/Rinness/Untitled-1.jpg
http://i14.photobucket.com/albums/a309/Rinness/Untitled-2.jpg

Things to note here:

1) It dawned on me that I may not have disabled AVG's Resident Shield when playing TRU yesterday. I'll be doing that next time.

2) When I played TRU, I had just restarted my computer and disabled all obvious unnecessary processes (such as WindowBlinds), so the processes shown there may not have been taking up as much memory at the time.

3) Firefox was not running when I was playing TRU. It's running there because I had this thread open while screenshotting just now :p.

3. Try also the following: Make your paging file of constant size: MIN=MAX=~3,5Gb

Hrmm, good idea. Just did that; both min and max are set to 3584 MB now.

I'll probably be playing TRU later on this evening, so I'll let you know how it goes :)

EDIT: Also, any ideas/theories about the rare, quick frame skips/pauses?

EscondeR
24-11-08, 19:35
^ The source is the same: the game loads big data bunch and skips a frame or two.

You also have Machine Debug Manager running (mdm.exe) and Windows Defender (MsMpEng.exe) - can disable them via Control panel > Administrative tools > Services.

Rinnerz
24-11-08, 19:52
^ The source is the same: the game loads big data bunch and skips a frame or two.

Ah k then. Just wanted to get your input; it's much appreciated, btw :).

You also have Machine Debug Manager running (mdm.exe) and Windows Defender (MsMpEng.exe) - can disable them via Control panel > Administrative tools > Services.

Yeah, I noticed Windows Defender was running afterwards. Didn't take note of the MDM, though. I'll get on that :tmb:.

abraham
25-11-08, 00:08
whats DEP?

Rinnerz
25-11-08, 01:26
whats DEP?

Data Execution Prevention.

Also, after playing smooth-as-butter for 3-4 hours... the game just crashed to the desktop again. Just like the other times, the crash was triggered by me manual saving at a checkpoint.

abraham
25-11-08, 07:32
Really?? woah time to optimise my pc!!

how do i get rid of DEP?

EscondeR
25-11-08, 07:43
^ CLICKY (http://www.tombraiderwiki.com/index.php/DEP) :)

abraham
25-11-08, 12:11
loL! made a wiki for it! mad, ok thanks, isnt it too unprotective though? like viruses and such.

EscondeR
25-11-08, 12:53
DEP won't protect you against viruses. It's made to **** you off only :rolleyes:
To be protected use decent firewall and antivirus.

Rinnerz
25-11-08, 17:10
Just thought I'd pop in to say that although the game still crashes periodically after a manual save (:(), I didn't experience any "unexplained" stutters/pauses yesterday during gameplay. Either the steps I took with disabling processes helped, or... I just got lucky yesterday. Only time will tell, I suppose.

The only time there were any frame skips was right after I had returned to the game after having Alt-Tabbed out of it. It skipped occasionally for the next few mins of gameplay and was pretty annoying, but it eventually returned to normal. So as long as I don't disturb its flow while playing, it seems to be all right. At least for now.

Now if only it could stop crashing when I decide to save...

eraser
25-11-08, 19:10
Mine freezes constantly, rendering the game pretty much unplayable. Although I think I'm in the same boat as a lot of people with the Geforce 6/7 problem. I have the following:

AMD Athlon 2.21 Ghz
1GB Ram
Geforce 7800GTX 256MB
And the latest drivers installed.

I've turned all setting off and lowered the resolution down to 1024. Yet she moves, then it stalls for up to 3 seconds at a time. This is constant. I know the PC is fast enough because when it doesn't stall, the frame rate is pretty much desirable...

Guess I gotta wait for this patch eh!

Thing is, shouldn't have this been beta tested before release?

Rinnerz
25-11-08, 19:16
Mine freezes constantly, rendering the game pretty much unplayable. Although I think I'm in the same boat as a lot of people with the Geforce 6/7 problem.

Yeah, that would be the main factor I'd blame at this point. Of course, you could also have unnecessary processes running in the background that could be interfering, as well. Anything that could be taking up CPU processing time would hurt your gameplay to varying extents.

Thing is, shouldn't have this been beta tested before release?

Definitely, but I think that--at the end of the day--there's only so much they can do if they're given a deadline that can't be negotiated with. Personally, I think they should have been given more time to handle the various bugs/glitches and issues the game seems to have, but oh well. At least they're trying to remedy the problem now ;).

Rinnerz
27-11-08, 13:12
I hate to earn a metaphorical "slap on the hand" for bumping this (:o my apologies), but the slight pauses during cutscenes returned yesterday.

As stated before, turning down graphical settings--or even completely disabling some of them--doesn't seem to help resolve this issue at all.

A (desperate) thought that occurred to me was maybe setting "tru.exe" to a higher priority in the Task Manager, but having to Alt-Tab out of the game for anything can cause really bad frame skips once you're back in the game, so I'm not sure there would be a good way to gauge whether or not the priority change helps it at all. It seems a bit iffy to me.

:( Any other suggestions for helping the game load these cutscenes better? Would increasing my min/max pagefile size (again) help at all? As always, any and all feedback would be appreciated :).

EDIT: And as a sidenote, the crashes after manual saves also still occur *sigh*.