PDA

View Full Version : Win2K Dialup problem


aktrekker
02-05-09, 10:46
Had a problem with my PC awhile back and had to reinstall Win2K.
I then installed SP4, then a bunch of KB patches.
I tried to setup the dialup network connection. It just won't stay connected. After playing with the settings for awhile, I made sure they match the settings in my Win98 installation (which works) and my Vista laptop (which works).
It connects, logs me in, then gets to "Registering your computer on the network". At that point it fails with either error 720 or 733, depending on the connection settings. It indicates that server and client could not agree on a PPP protocol.

I used netsh to enable tracing and got a PPP log file. Unfortunately I don't have details about the packet formats so I can't figure out the exact problem.
Basically it looks like Win2K sends a couple of configuration requests for protocols. It then receives an IPCP request from the server which it rejects (and I have IP header compression on). Then the server rejects the Win2K protocol requests. Then PPP just shuts down.

Any idea what might be happening?

EscondeR
03-05-09, 16:39
Right click the RAS connection, select Properties, go to Network tab, press Options button right under protocol choice field and set all three flags on there. Press OK button twice.

Check also those:
http://help.expedient.net/dialup/dun720.shtml
http://www.modemsite.com/56k/duns720.asp

aktrekker
04-05-09, 04:02
Thanks. I should have googled it first :hea:

Unfortunately the networking seems to be totally screwed up.
When I reinstalled, I didn't get any options. It examined my hardware and auto installed. When I booted, it was trying to access a LAN card and I don't have one. I tried disabling the hardware and it didn't work completely. Probably all the protocols are setup for the LAN.
I guess I need to wipe the partition clean and re-reinstall.

BTW, anyone know of a trustworthy boot manager?

EscondeR
04-05-09, 05:40
Try THIS (http://www.tombraiderhub.com/faq/download/esc/rarepair.zip) program first. Download, unZIP, run. It'll reinstall LAN adapters and IP protocol.

aktrekker
04-05-09, 06:30
Thanks, I'll try it. But I don't have a LAN adapter, so I hope it will UNinstall all of that.

Thanks, it worked. At least I'm online. Now I just have to cleanup the protocols (remove NetBIOS, NetBEUI, etc).
There are 2 protocols that weren't there on my previous install - Network Monitor Driver and QoS Packet Scheduler. I can't disable them and they have no properties. Very strange. Whatever, I can continue rebuilding my Win2K setup.

EscondeR
04-05-09, 07:44
Be aware that disabling NetBIOS completely can lead to the same error we fixed. The other 2 things are from WinXP typical setup.