PDA

View Full Version : Climable pushable objects and switch animations


tomb2player
25-06-09, 10:34
Hi everyone,

Anyone know, how to make pushable blocks climable like tr1,2,3 ?

I have switch from TR3, an when i push it in game, lara has wrong animation ( like pushing other switch ).

KurtisandLara
25-06-09, 10:54
theres a tut on how to make a pushable block on trsearch and skribblerz.
The switch has the wrong animation because you have to enable it. I dont know which switch your talking about so ill just use the a big level switch as an examble...
Go into wadmerger and click on the switch, now click on switch manager, now find what type of switch your switch is the have that one. for examble im using the big level switch so ill open switch manager click on the arrow next to one untill i find BIG LEVEL SWITCH" click on that then click save.
Save your wad then close reload your objects on the LE and you got it.

1upMushroom
25-06-09, 11:01
To make pushable blocks climbable, you need to use either TREP; or be using NGLE and the TRNG Tomb4.exe.

Here is the Skribblerz page on pushable objects, :D but I am not sure about tutorials for TREP. :(
http://skribblerz.com/tuts/ngle/nglepushables.htm

As for the switch, you need to assign the animation in the OCB of the switch. Also, that particular anim needs to be in your particular WAD file.
The revised WADS have all anims in them, but some of the original WADs that came with the LE are lacking certain animations. (Like trying to get Lara to swim with the Settomb WAD. :vlol:)
Play around with the switch OCB to find the right animation.

tomb2player
25-06-09, 12:30
Ok, now i know everything, last trouble is: "Place the switch in the map and put 0 in the ocb" -but i dont know where is this "ocb" option in roomedit :(

1upMushroom
25-06-09, 12:35
Ok, now i know everything, last trouble is: "Place the switch in the map and put 0 in the ocb" -but i dont know where is this "ocb" option in roomedit :(

In your 3d view of the room, with face edit off, when you click the object (switch), it will turn red.
Press "O" on your keyboard, and it will bring up your object menu.

tomb2player
25-06-09, 13:02
Ehh... now i cant turn on my level. I dont know this with this switches, and i destroyed my level. I pushed O and there were 5 switches. I dont know this. In WADmerger it were OCB 0, OCB2, OCB3. And i changed 0 to large lever, 2 to small button push , 3 to wheel. And when i started making tests with o my level broken down ( lucky it was test level with two rooms )
Ah, and readme say" put 0 in the OCB, but i have only 1,2,3,4,5.

help :(

KurtisandLara
25-06-09, 13:37
Those buttons arent the ocb there should be a box after you hit o. Its just a plain white box with the number 0 in it. you type the ocb in there.

tomb2player
25-06-09, 13:50
hehe now it works ! :)

Thanks KurtisandLara :hug:

KurtisandLara
25-06-09, 13:56
Your welcome.

tomb2player
25-06-09, 16:34
Omg... now it again not working! , i dont now what is wrong!

Ok, ill write all steps, what i do:

1) In WADmerger I'm making WAD, adding SWITCH1, SWITCH2, etc.
2) I push " Switchmanager " button and adding something like this: OCB 0 - Big level switch / OCB 2 - small push switch / OCB 3 - big push button.
3) I'm placing switch to level ( SWITCH1 ) And i know, animation for this type of switch is " small push switch " ( OCB 2 ). I'm clicking on the switch, pushing "O" and in this white window i removing 0 and writing 2. And in game when lara pushing switch, there is animation from OCB 0 (Big level switch ).

Now ill write my spekulations and ideas:

I'm writing number of correct OCB in this white window and closing. When i again click on the same switch and check, there is number 0 ( its looking like reset? ) Maybe it's reason?

EDIT: eh.. now i know it! i just pushed Enter after writing number in OCB window. After pushing Enter number dont reset and it works... :)
:confused:

Titak
01-01-14, 22:49
Gigantic bump...
What on earth for?! :confused:

Never mind.
Leave the thread be from now on please.

SrDanielPonces
01-01-14, 23:54
Sorry, I didn't saw the date.. :hea:
My bad..