PDA

View Full Version : Trouble with AOD!


Nicky
24-09-04, 22:44
http://www.tombraiderforums.com/images/smilies/wave.gif

After completing "AOD without a scratch" this summer, I had uninstalled the game from the PC, so as to give everyone/thing the chance to have some rest.

Now that I got a new and bright monitor, I thought I'd install it again, so as to finally be able to see its great graphics as they are supposed to be seen. I installed the game alright - full installation and all the rest - but when I try to run it, the screen gets black for a second as if trying to load the game, but immediately it crashes and I get the following error message:

Build Jun 24 2003 23:52:07

The Following Error has occured

Generic Game Error

ASSERTION: 'pData && length>0' at C:\projects\tomb raider\Game\ai\script_mgr.c(400)

This happens when I run the TRAOD_P4.exe (since I have P4), and I get the same error both with and without the patches. When I run the TRAOD.exe, the game does load and run, but it's like slow motion and Lara's movements are static (she moves like Robocop :confused: ).

I don't understand why this happens, since in the past and on the same PC the game run perfectly. I tried uninstalling and reinstalling it, but still I get the same. It also happens when I install EAX Unified, but also when I don't install EAX Unified as well.

Joseph
24-09-04, 22:53
Nicky http://www.tombraiderforums.com/images/smilies/wave.gif Moving like Robocop is related to your settings. Could you printscreen them all here to make discussion simple?

EAX is only if you have a Creative soundcard, you are aware of that?

Nicky
24-09-04, 23:17
Jo http://www.tombraiderforums.com/images/smilies/wave.gif

No, I didn't know this about EAX http://www.tombraiderforums.com/images/smilies/bash.gif Anyway, forget I said that :D I remember installing it along with the game the very first time (last summer), but never wondered what its function was http://www.tombraiderforums.com/images/smilies/redface.gif

OK, my settings http://www.tombraiderforums.com/images/smilies/smile.gif Here they are:

http://www.tombraiderforums.com/~nicky/settings1.jpg

http://www.tombraiderforums.com/~nicky/settings2.jpg

http://www.tombraiderforums.com/~nicky/settings3.jpg

Simulation
24-09-04, 23:24
Hi Nicky, http://www.tombraiderforums.com/images/smilies/wave.gif

Uncheck the Multi Threaded on the General Tab.

Joseph
24-09-04, 23:37
What happens if you choose "Shader Hardware" in Render type?

Nicky please be aware, and i am sorry to say (correction: i am not.) that you, as our AOD specialist, deserve a much better graphic card than the Gf2-MX400. It simply has a very hard time with AOD. :(

Nicky
24-09-04, 23:58
Sim http://www.tombraiderforums.com/images/smilies/wave.gif

Well, I did what you both suggest. Same thing happens again and again. TRAOD.exe moves like Robocop - it's not so obvious in the game, as it's in the introductory movies where the logo and menus of the game show. And TRAOD_P4 crashes again :(

Nicky
25-09-04, 07:39
Hi again http://www.tombraiderforums.com/images/smilies/wave.gif

Problem fixed http://www.tombraiderforums.com/images/smilies/smile.gif After many unsuccessful attempts, I thought of running the game through Bokkie's SCU. I selected the TRAOD_P4.exe from the program's menu and guess what - it loaded perfectly and didn't crash http://www.tombraiderforums.com/images/smilies/thumb.gif

Simulation
25-09-04, 18:45
Glad to hear it is sorted. ;)

Nicky
25-09-04, 19:25
Thanks, Sim http://www.tombraiderforums.com/images/smilies/smile.gif

However, the game keeps crashing if I don't start it via the SCU :confused: I just can't understand what this error message implies :confused: