PDA

View Full Version : Cog Switch Problem


tweetygwee
09-04-07, 17:35
I'm using a cog switch with a door with OCB 1 (closes slowly). If Lara does not complete the timed run, and the door closes, the cog switch loses its collision so that Lara runs right through it, and it stops working. This isn't a problem if you complete it the first time, but if you fail, you're stuck with a non-working cog switch. Any ideas?

Thanks in advance.

aktrekker
10-04-07, 07:07
Is it the standard tomb4 or is it patched?

tweetygwee
10-04-07, 10:23
Yes. The only patch I've used though is "Force volumetric fx off", because I seem to have lost my "setup tomb4.exe". I just tried with the standard tomb4 and I have the same problem. :confused:

aktrekker
11-04-07, 07:37
I checked an ocb list that shows the ocb used for each object in all of the TR4 levels. The cog switch is used in 2 levels and it has ocb 0 both times. Maybe this is a bug in tomb4.

To get back your setup, create a shortcut to tomb4.exe. Right click on the shortcut and select properties. Go to the shortcut tab. For Target, place the entire pathname in quotes if it isn't already. After the closing quote, add a space then -setup. Click OK. The shortcut will start tomb4 in setup mode.

tweetygwee
11-04-07, 11:16
Thank you so much!

I have tried a cog switch from a different wad, and it works perfectly. I changed the textures in strpix on the one that was causing me problems, but since I didn't test it before I retextured it, I'm not sure whether something in strpix affected it, or if it was like that anyway. I'm just going to stick with the new one now.