PDA

View Full Version : Decompile Aborted...why?


Chocolate
07-05-07, 11:50
Right, I'm trying to decompile the SCRIPT.DAT file for Tomb Raider Chronicles. I'm placing my thread here because the software used will be familiar to those who use the Level Editor.

I'm currently using TR West to decompile my files. It asks for a language DAT file and the script file itself. The language file is decompiled without a problem. TR West doesn't give any error messages but when I check the newly created SCRIPT.TXT file I end up with this at the end of the file:

[Level]
ResetHUB= 111
Invalid opcode = 0 @0x00000162
Decompile Aborted

...thus getting an incomplete SCRIPT file, which I cannot edit and convert back to SCRIPT.DAT.

If you're wondering why I'm trying this, it's because I want to get the dozy cheat to work. Any help will be appreciated.

Titak
07-05-07, 12:23
I don't know how this decompiling thing works exactly, but I do know that not all custom scripts can be decompiled for some odd reason.
Maybe that's the case with this script? :confused:

Izzie404
07-05-07, 12:24
Is this a Dxtre3d question? Because you said something about TRC...:confused:
If you are just using the normal Tomb4 engine you can just enable TREP to get the DOZY cheat to work, but I'm not really sure what you are doing...

dox online
07-05-07, 12:27
Download Scripter4. Its not in english but you will recognise the words. Goto options then goto [cant remember word] DOZY And tick it on. Google scripter 4 to find it.

Chocolate
07-05-07, 12:39
Dox, thanks for the tip but Scripter 4 isn't installing for me, and I don't understand the error messages....

Ok, let me rephrase what I'm saying in a nutshell.

I'm trying to get the DOZY cheat for Tomb Raider 5.
So I'm trying to decompile the SCRIPT.DAT file, so I can modify it on notepad to set it to Flycheat = ENABLED. To decompile I'm using TR West.
TR West isn't decompiling the SCRIPT.DAT file properly. At the end it says "decompile aborted" and what I end up with is an incomplete script.txt file.

Active Man
07-05-07, 12:50
Maybe it aborted because you used a very high ResetHUB value :)
Try a lower one (not above 99)
I am only guessing ;)

Chocolate
07-05-07, 12:59
I can't really change the ResetHUB value until I decompile it completely. The irony...:(

aktrekker
08-05-07, 07:23
TRWest is an old program. I don't think it was ever updated to handle TRC. So it isn't recognizing some of the TRC upgrades to the script.
If you have access to a hex editor, you can add DOZY manually.
Look at the first byte in script.dat. If it is even, add 1. This should turn on DOZY (if it works in TRC).

Chocolate
08-05-07, 18:08
Ok, I managed to do that. But from the instructions I've been given, DOZY doesn't work. How do I activate DOZY? Thanks :(

aktrekker
09-05-07, 09:21
If the hex edit didn't work, there are two reasons.
1) They changed the script files with TRC and dozy is in a different place.
2) DOZY doesn't work in TRC.

Skateboard Kid
09-05-07, 09:58
Go to DXtre3d.com and in the downloads section is an already decompiled TRC script. It have dozy enabled and working..We have been using it for years.

Chocolate
09-05-07, 16:23
It could simply be because I'm doing the instructions wrong.

What I'm doing is that I face north [I've tried with all directions] and then go to the inventory. Then I highlight the flares [they said highlight the torch, but I assumed it was the flare] and then press DOZY. Is that how you activate it?

Skateboard Kid
09-05-07, 16:52
It works just the same as trle...The only thing that could be wrong is if you are using a hacked .exe or dozy is not enabled in your script.
You just need to push keys dozy at same time. Find that script that Turbopascal made and compile using trle script.exe and should work fine.

Chocolate
09-05-07, 17:49
Well, decompiling for TRLE and using DOZY worked. :D But using the Hex Editor for Chronicles doesn't work. So I'll try download that decompiled SCRIPT you gave me and try it out one more time. Thanks for the help so far.