PDA

View Full Version : Adding keys & puzzles to a level


Tony the Loon
12-05-07, 22:08
I'm having trouble adding keys & puzzle items to my level...

I've already used WADMerger many times to add enemies and statics objects... and it all works fine.

Now I need to add a key & keyhole or some kind of puzzle, I can add these objects to my .was file with WADMerger... but when I build my level and try to play it, the game crashes before the level starts...

I was trying to add all the city level puzzles to the cleopal level as a start:

1. used WADMerger to copy the city items to my cleopal file & save.

2. edited script -- deleted original cleopal puzzle references (because I deleted these objects from the .was file) and copyed city level puzzle references under the cleopal level heading. saved and generated new script .dat file using SCRIPT.exe

3. Went to Room Editor, opened my prj, outputed .tom file.

4. Built level file w/ Level Converter.

5. Run Tomb Raider, start new game with Cleopatra's Palaces... level proceeds to load, but when the progress bar reaches the end, tomb4.exe crashes....

So, I don't know... maybe my .was file is too big, so it causes the crash?
Or did I not add the puzzle items correctly?

This is the only problem I have w/ my custom level...
My level has working custom enemies & objects such as plants, etc.

But I can't get keys or puzzles to work w/ my level.

If anyone here has made a custom level .was/.wad file, can you outline the steps to properly add working keys/puzzles to a level?
Or point me to a post where this was already discussed?

Thanks.

SSJ6Wolf
12-05-07, 22:24
Of the items you removed, were any of them still existing in your project? It is a good idea to save a .PRJ with the items removed before you remove them from the WAD.

Also, when you copied the city items over, were they in the same slots as in the city WAD? If not, then the puzzle slots might not be matching the puzzle/key numbers in the script lines that you copied.

Tony the Loon
12-05-07, 22:58
Hey, thanks for the reply.

No, the items that I removed from the cleopal wad were never going to be used in my custom level, and were never placed in the level at any point; so I took them out to save space.

I'm not sure about the slots... I'll have to try it again and make a note of it.
For all I knew, I thought that the copied items were automatically placed in the correct slots... I'll check it out.


EDIT:

Is there a difference between ObjectID's and Slot?

SSJ6Wolf
13-05-07, 02:10
No, in WADMerger they are one in the same.

Tony the Loon
13-05-07, 16:04
Still no luck.

I checked the slots of my clepal wad after I copied everything I wanted from the city wad... when I click on the object ID's in both windows, it shows me the same 3d model in wadmerger, so I assume it's in the correct slot.

Maybe it's just too big... after adding the puzzle items to the cleopal wad, I get a total of 1175 textinfos and 11 tiles. I think I have over 350 room tex infos, because when I use level converter, it doesn't show the progress (looks like it's frozen but i know it still compliles the new .tr4 file because I can see the time and date created in the file properties).

pedro
13-05-07, 17:21
First of all , you are one of the lesser people who can explain excactly what you have done! The fact that tr2 shows no progress, is no problem it does do that at times ( don't know why!).I am not a hero at this, but it sounds good! As you removed old items and installed new keys and slots, did you allso changed your English.text, it's just a suggestion, maybe someone gets a brainwave? :confused:

Tony the Loon
13-05-07, 18:06
As you removed old items and installed new keys and slots, did you allso changed your English.text, it's just a suggestion, maybe someone gets a brainwave? :confused:

Thanks, I'll check the english.text file... maybe I have to add an object's name?

I'm going to start over by trying to add just one puzzle; before, I was trying to add a few at once.

I’ve restored all my custom trle files to the point before I tried adding puzzles/keys to my level.

So, starting over…

I want to add this VCI puzzle to my level

http://www.trsearch.org/Items/332

I’ve copied it to my custom cleopal wad, just the same as I’ve copied enemies and other objects in the past…

I place the "key (data disc)" and the "keyhole (computer console)" in my level to test it. When I load my custom level from the new game menu, it crashes when the loading progress bar reaches the end.

Is this VCI puzzle supposed to work just by adding it with WADMerger?

Or do changes need to be made in the script/english files?

Has anyone here tried to use this VCI puzzle before? Did it work & how did you make it work?

EDIT:
Found a great "lock/key/door" tutorial: http://www.trsearch.org/Tutorial.php?action=gettut&id=18

Now I just need to get a "lock, key and door" combo into my custom wad with out it crashing the game!