www.tombraiderforums.com

Go Back   www.tombraiderforums.com > Digital Experience > Lara Croft and the Temple of Osiris

Reply
 
Thread Tools
Old 25-12-16, 20:55   #1
charmedangelin
Archaeologist
 
charmedangelin's Avatar
 
Join Date: Jan 2016
Location: USA
Posts: 1,179
Default Have they fixed the lag issues on PC?

Just got the game and man does this lag. I just played Guardian of Light and the game runs smooth on high settings, but for some reason this game lags like crazy. Can only play it in window mode with the lowest resolution set. Now I know my laptop specs aren't the best, but I can run TR Reboot, Bioshock, RE4 HD, The Sims 3 with absolutely no problems what so ever then why is the game lagging so much. I find it hard to believe that a game like this could be that demanding on the system. Exactly what changes were made to the game from Guardian of Light to this game?

Last edited by charmedangelin; 25-12-16 at 21:10.
charmedangelin is offline   Reply With Quote
Old 25-12-16, 21:15   #2
Nigel Cassidy
Professor
 
Nigel Cassidy's Avatar
 
Join Date: Apr 2015
Posts: 2,908
Default

I think the game was made for consoles anyway, as it can barely be played with mouse and keyboard... Have you searched the internet for technical issues?
Nigel Cassidy is offline   Reply With Quote
Old 25-12-16, 23:22   #3
charmedangelin
Archaeologist
 
charmedangelin's Avatar
 
Join Date: Jan 2016
Location: USA
Posts: 1,179
Default

Yeah, I'm googling it now.

EDIT

Ok I think I optimized the game as much as I could. I can play it full screen and get steady frame rate by messing around with some options in AMD's control panel. Now I just gotta not get my behind handed to me by the hoards of scarabs in the first few levels.

Last edited by charmedangelin; 26-12-16 at 03:51.
charmedangelin is offline   Reply With Quote
Old 26-12-16, 13:50   #4
NoahCrofRaider
Explorer
 
NoahCrofRaider's Avatar
 
Join Date: Jun 2015
Location: United States
Posts: 934
Default

I've finished the game and it's only when I start to play that it lags. After playing for, like, 5 minutes, the lag is gone.
__________________
"Whatever you say, Eggman!" (Sonic The Hedgehog, 1999)
NoahCrofRaider is offline   Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 17:39.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.