www.tombraiderforums.com

Go Back   www.tombraiderforums.com > Tomb Raider Modding > Tomb Raider Level Editor > Software Development

Reply
 
Thread Tools
Old 14-11-17, 15:02   #21
MontyTRC
Historian
 
MontyTRC's Avatar
 
Join Date: Mar 2010
Location: Italy
Posts: 272
Default

Just checked, .NET 4.7 is supported up to Windows 7 SP1. But Tomb Editor requires 4.5
Also check that you have a DX10 GPU class (but 99.99999% you have it).
__________________
Tomb Editor Main developer
MontyTRC is offline   Reply With Quote
Old 14-11-17, 15:10   #22
Xopax
Archaeologist
 
Xopax's Avatar
 
Join Date: Dec 2012
Posts: 1,890
Default

Quote:
Originally Posted by Dustie View Post
Please post your system version and go to Installed Programs in Control Panel to check if you have any NET Framework versions installed.
Windows 10 Pro 64-bit with Net Framework 4.6
Xopax is offline   Reply With Quote
Old 14-11-17, 15:13   #23
MontyTRC
Historian
 
MontyTRC's Avatar
 
Join Date: Mar 2010
Location: Italy
Posts: 272
Default

My dev PC is Windows 10 Pro with all versions of .NET up to 4.7.2.
Can you also tell me your GPU model and look into the Event registry for errors about .NET Runtime or CLR errors?
__________________
Tomb Editor Main developer
MontyTRC is offline   Reply With Quote
Old 14-11-17, 15:19   #24
Xopax
Archaeologist
 
Xopax's Avatar
 
Join Date: Dec 2012
Posts: 1,890
Default

^ Nvidia GT610, there's absolutely nothing in the event registr (or i don't know where to find the errors)

Last edited by Xopax; 14-11-17 at 15:23.
Xopax is offline   Reply With Quote
Old 14-11-17, 15:21   #25
Mordyga
Historian
 
Mordyga's Avatar
 
Join Date: Jan 2014
Posts: 436
Default

Went to play with it for a while and I love it! Especially the objects rotating and moving, changing the celling triangular thing. Finally
Thank you guys.

But I have some questions about the wad editor, is the Play animation feature not working only for me? Will it have an option to load UV mapped .mqo files? Looks like .mqo aren't listed and can't be imported.
Mordyga is offline   Reply With Quote
Old 14-11-17, 15:22   #26
Dustie
Relic Hunter
 
Dustie's Avatar
 
Join Date: Apr 2005
Location: Poland
Posts: 7,371
Default

Quote:
Originally Posted by Xopax View Post
Windows 10 Pro 64-bit with Net Framework 4.6
Can you install other versions or are there problems? You could try with version 4.7. You might need to reboot after installing, just to be sure.
Dustie is offline   Reply With Quote
Old 14-11-17, 15:23   #27
-Roli-
Relic Hunter
 
-Roli-'s Avatar
 
Join Date: Jul 2007
Posts: 5,450
Default

Yaayyyy, thank you so much for all your hard work guys!
-Roli- is offline   Reply With Quote
Old 14-11-17, 15:24   #28
Xopax
Archaeologist
 
Xopax's Avatar
 
Join Date: Dec 2012
Posts: 1,890
Default

Quote:
Originally Posted by Dustie View Post
Can you install other versions or are there problems? You could try with version 4.7. You might need to reboot after installing, just to be sure.
My PC doesn't support 4.7
Xopax is offline   Reply With Quote
Old 14-11-17, 15:26   #29
Xopax
Archaeologist
 
Xopax's Avatar
 
Join Date: Dec 2012
Posts: 1,890
Default

Found this in the event registry:

Aplicativo: TombEditor.exe
Versão do Framework: v4.0.30319
Descrição: O processo foi terminado devido a uma exceção sem tratamento.
Informações da Exceção: System.TypeInitializationException
Pilha:
em TombEditor.Geometry.Room.UpdateBuffers()
em TombEditor.Geometry.Room.UpdateCompletely()
em TombEditor.Geometry.Room.Resize(TombEditor.Geometr y.Level, SharpDX.Rectangle, Int16, Int16)
em TombEditor.Geometry.Room..ctor(TombEditor.Geometry .Level, Int32, Int32, System.String, Int16)
em TombEditor.Geometry.Level.CreateSimpleLevel()
em TombEditor.Editor..ctor(System.Threading.Synchroni zationContext, TombEditor.Configuration)
em TombEditor.Program.Main()
Xopax is offline   Reply With Quote
Old 14-11-17, 15:27   #30
MontyTRC
Historian
 
MontyTRC's Avatar
 
Join Date: Mar 2010
Location: Italy
Posts: 272
Default

Mmmm two strange things here. First, you have Windows 10 Pro so you must support it. Second, Tomb Editor is compiled against 4.5. Can you show me a screen of the error about 4.7?
__________________
Tomb Editor Main developer
MontyTRC is offline   Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 03:12.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.