Tomb Raider Forums

Tomb Raider Forums (
-   Tomb Raider Next Generation (
-   -   TRNG - Bugs & Limitations Thread (

Mulf 13-02-13 23:09

I recently replayed a level I built with the original TRLE way back when, using the TRNG tomb4.exe with 'keep dead enemies' enabled. On loading a savegame, two of the enemies I had killed previously reappeared, standing upright and with full collision—not moving though, and Lara wouldn't target them (technically still dead I guess). I realised that those two enemies were the ones I had killed using explosives.
I'm not sure whether this is a known bug, but it certainly goes beyond a mere glitch, since dead enemies with full collision could easily get you stuck.

tomb2player 08-04-13 19:53

It would be nice if Assign_slot command from TRNG had nice features like: Assigned Enemies can have different sounds, can affect to Lara different damage, can have different animations...

I noticed some bug in this command with baddy_2 type enemies ( those with mesh_swap ) : If I place in script line with this type of enemy, other lines won't work which are below script line of baddy_2... for example, If i have something like this:


In this case because of bug only ANIMATING1 and ANIMATING4 will work. SCORPION and SAS_CAPTAIN won't work, because they are below BADDY_2 in script. If i do something like this:


All will work now, because BADDY_2 is the last one. Could it be fixed? Of course, I can put BADDY_2 as last one and it will be ok, but I can't have more than one assigned enemy from BADDY_2...

Crischanneedst 14-04-13 11:42

If you customize the properties of an enemy with the "Enemy=" entry, you can use NEF_ONLY_EXPLODE, so the creature can be killed with explosives only (like the mummy). At least it should. Unfortunately the enemy becomes completely immortal. :( I wonder if I'm the only one who has this problem? :confused:
Maybe this issue can be fixed with the next TRNG version coming this summer. :)

Titak 14-04-13 12:07

Since this bug is not confirmed yet by other TRNG users |(at least not that I know), it is best to post this in a new thread or the general TRNG chat thread.
So it can be discussed and perhaps confirmed.

Also, it is best if you would give some more details, like which slot the enemy is in, whether or not the slot is customized (like it is now a TR3 enemy which has been converted to work in this slot for example) and/or what the rest of your Enemie= script looks like.

Titak 12-05-13 22:04

[QUOTE=Irishwolfhound;6773153]Ok I've done the animate ranges thing with my water textures set them to 6fps but no matter what theres still no movement from them in the game?[/QUOTE]

[QUOTE=Titak;6773387]Wrong. :p
They do make a difference.
I use it all the time to get a good speed for the animating textures. [/QUOTE]
Something I just noticed...

I have a couple of river-rotate animating textures in my level.
But there was no difference ingame between speed 1 and speed 4.

In my testroom I also applied the textures as [I]normal non-transparant[/I] AND I placed them [I]semi-transparant and double-sided[/I].
Guess what?
When they are applied as [I]non-transparant (opaque)[/I] the speed is the one I assigned in the Animation Ranges window AND they properly animate when applied to triangles.
The [I]semi-transparant + double-sided[/I] ones however all move at speed 1 (first animationrange I assigned) and they do not animate properly on triangles.

AkyV 27-07-13 13:04

So in this thread we will collect bugs for Paolone for the released TRNG 1227?
Then here are some newer finds:
Click on "place object" button, and then – instead of clicking on a square to place the object there - accidentally click on this new window of buttons. - The editor freezes now.
(In fact this freezing problem was discovered by Raymond two years ago during the early beta tests.)

Hitting F5 on the directive – but not being in the main Script -: NG Center will crash – “Run time error 9 Subscript out of range” (It doesn't seem a constant problem.)
Using F5 and F6 will tabulate the first row of the main and sub script files, again and again.
Hitting F1, F5, F6 when the cursor is not on the proper place, in any (main/sub) script will SOMETIMES (?) crash the NG Center with “Run time error”. – Sometimes it could be very dangerous: once the crash removed English.dat, then I can’t really reopen NG Center after that, because error messages come, and the NG Center crashed again when I closed the messages. I needed to copy/paste a fake English.dat from somewhere else so I was able to open NG Center.

It is not easy to describe this problem:
I used a DEFINE directive with a FIRST_ID in a “sub-script” (“include file”), with BS_TG for a TriggerGroup ID. Then, I replaced BS_TG by X (just being curious). - A similar case worked in the main Script, so constants could be anything in DEFINE.
So, I hit F1 at the TriggerGroup, using the DEFINE/FIRST_ID rows of X, and this message pops up (F1 didn’t put an ID now):


(That temp…txt is the name of the actual sub script file.)
After that, I let DEFINE+FIRST_ID rows for X there, but also type DEFINE BS_TG again – without typing FIRST_ID for BS_TG again.
And X works for TriggerGroup ID now! – So, hitting F1 was successful now (for X), but without any task for DEFINE BS_TG row. But without that DEFINE BS_TG row, an error will occur.

The odd is it happened with other constans too (eg. TG), not only with BS_TG but eg. it did not happened with that X.

AkyV 28-07-13 12:39

Sorry for the doublepost but I don't want Paolone to miss these bugs.
[B]NG Center – Checking for available Updates:[/B]
Only an error message comes up. Maybe the new website isn’t attached to the button?

[B]NG Center – Change version:[/B]
- Info in the green window: is not for Mk2, it’s Mk4.
- Error messages come up, changing down/up (tried between and
Eg. from 1227 to 1226:





[CODE]Short Path of Folder to restore: D:\TOMBRA~1\NG_CEN~2\Versions\v1_2_2_6
Long Path of Folder to restore: D:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6
Loading: D:\Tomb Raider\NG_CENTER\center_settings.bin
Found: C:\Program Files\InstallerForTRNG\Settings_installer.bin
Paths found in: Settings_installer.bin
Trle = d:\Tomb Raider\Level Editor
NG_Center = d:\Tomb Raider\NG_CENTER
WadMerger = d:\Tomb Raider\Accesorries\WAD szerkesztő\WADmerger\1.98B
Merger.exe= d:\Tomb Raider\Accesorries\WAD szerkesztő\WADmerger\1.98B\WADMerger.exe
DirWadMerger=d:\Tomb Raider\Accesorries\WAD szerkesztő\WADmerger\1.98B
NomeExeWadMerger=d:\Tomb Raider\Accesorries\WAD szerkesztő\WADmerger\1.98B\WADMerger.exe
Found wad merger exe: d:\Tomb Raider\Accesorries\WAD szerkesztő\WADmerger\1.98B\WADMerger.exe
Starting restore version: D:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6
Start timer event
Locate current version for: d:\Tomb Raider\Level Editor\Tomb_NextGeneration.dll
The folder for current version is: d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_7
Found current version folders:
d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_4
d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6
d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_7
Version folders after the sorting:
d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_4
d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6
d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_7
Index of Current Version=2
Index of version to install=1
Increment to move from Current to Install version: -1
Install version of folder: d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6
FullDest=d:\Tomb Raider\Level Editor\Tomb_NextGeneration.dll
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\Tomb_NextGeneration.dll
ERROR copying file from:
d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\Tomb_NextGeneration.dll
d:\Tomb Raider\Level Editor\Tomb_NextGeneration.dll
FullDest=d:\Tomb Raider\NG_CENTER\NG_Scripter.exe
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\NG_Scripter.exe
FullDest=d:\Tomb Raider\NG_CENTER\help_new_script_command.txt
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\help_new_script_command.txt
FullDest=d:\Tomb Raider\NG_CENTER\help_ocb_list.txt
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\help_ocb_list.txt
FullDest=d:\Tomb Raider\NG_CENTER\help_ButtonsWindow.txt
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\help_ButtonsWindow.txt
FullDest=d:\Tomb Raider\NG_CENTER\TRNG\Tomb_NextGeneration.dll
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\Tomb_NextGeneration.dll
FullDest=d:\Tomb Raider\NG_CENTER\TRNG\new_32_TOMB4.exe
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\new_32_TOMB4.exe
FullDest=d:\Tomb Raider\NG_CENTER\TRNG\Tomb4.exe
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\Tomb4.exe
FullDest=d:\Tomb Raider\NG_CENTER\scripter_constants.txt
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\scripter_constants.txt
FullDest=d:\Tomb Raider\NG_CENTER\RestoreVersion.exe
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\RestoreVersion.exe
ERROR copying file from:
d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\RestoreVersion.exe
d:\Tomb Raider\NG_CENTER\RestoreVersion.exe
FullDest=d:\Tomb Raider\Accesorries\WAD szerkesztő\WADmerger\1.98B\TR4Objects.dat
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\TR4Objects.dat
FullDest=d:\Tomb Raider\Accesorries\WAD szerkesztő\WADmerger\1.98B\Objects.h
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\Objects.h
FullDest=d:\Tomb Raider\Level Editor\Tomb4.exe
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\Tomb4.exe
FullDest=d:\Tomb Raider\Level Editor\Objects.h
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\Objects.h
FullDest=d:\Tomb Raider\Level Editor\ng_constants.txt
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\ng_constants.txt
FullDest=d:\Tomb Raider\Level Editor\WideScreen_ButtonsWindow.txt
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\WideScreen_ButtonsWindow.txt
FullDest=d:\Tomb Raider\Level Editor\NetBook_ButtonsWindow.txt
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\NetBook_ButtonsWindow.txt
FullDest=d:\Tomb Raider\Level Editor\help_ButtonsWindow.txt
SourceFile=d:\Tomb Raider\NG_CENTER\Versions\v1_2_2_6\help_ButtonsWindow.txt

Though another message says the version is restored. However if NG Center opens now, it says for the versions: 1227 (new), 03.039 (old).

[B]NG Room Editor Help menu:[/B]

Check for updates: refers to the old site.
About NGLE: old site typed here.
NGLE Help: refers to the old site.
Revised Level Editor Help: refers to the old site.

AkyV 29-07-13 19:18

[B]Fresh revelations[/B]

ENV_NO_BOX: the green walls (including the walls made by the green button) are handled as boxes now.

Change the sentry gun angle in the lightning demo into 180 degrees (from $254 to $854 in TriggerGroup2), and you will see clearly:
- the angle is less than 180 degrees
- 180 degrees must be a 90 degrees in the right/left half, but that „less-than-180” sector is clearly not divided into two equal half. In fact, the condition starts becoming true only in front of the gun, if the gun is turning right, so the left half is always false.
- Sometimes, if I save/load the game then that “less-than-180” sector turned left with 90 degrees.
- If I saved/loaded the game when the condition was just true then the next time the text didn’t show up.

It is just an example, so the problem is not the 180 degrees itself.

Titak 30-07-13 11:19

The background track(s) stop playing when using images.
Tested this with [I]Customize= CUST_BACKGROUND, BKGDT_INVENTORY, ****[/I].
This was also the case in

(Background tracks do keep playing when going into the SaveGamePanel.
This was fixed in

Paolone 30-07-13 12:37

Thanks for the signalations.

About #define directive perhaps it's more easy if you post the script or subscript where it happens that problem.
There are some limitation about #define:
1) You have to define a constant before using it (of course)
2) The define work in local way only in current source, therefor you cann't define a constant in a sub script and use that constant in main script or viceversa.

About detection of lara and angle view there could be a problem about the method I used to show text "I see you"
Pratically I put the mistake to set a durate time to show that text (I see you) and for this reason it remains on the screen for some second in spite the sentrygun didn't no more detecting Lara.

I'll try to fix other bugs.

About the chance to use eastern charset in game, could you (akvy) try to use ungarian text in game?
This only if there were problems in the past to show some unguarian characters in game.

All times are GMT. The time now is 01:26.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Tomb Raider Forums is not owned or operated by CDE Entertainment Ltd.
Lara Croft and Tomb Raider are trademarks of CDE Entertainment Ltd.