Tomb Raider Forums

Tomb Raider Forums (
-   Tomb Raider Next Generation (
-   -   TRNG - Bugs & Limitations Thread (

-Roli- 30-04-10 18:35


Originally Posted by Raymond (Post 4561144)
Just to remember: If someone wants a bug to be fixed like this one above, you need to prepare a bugproject with all the necessary files and the description of the issue and then load it up and give the link to me.
Otherwise you wonīt get the bug fixed.:)

Okay Raymond, I will do it :) Thanks!

Lucky Cookie 01-05-10 16:07

Not sure if it really is a bug but when i try to rotate the texture all the textures in that room goes white, but if you go to a certain angle the textures don't go white :confused::confused:

Titak 01-05-10 16:20

Try to set compatibility to Windows XP or an earlier version.
I've heard this solved the problem in some cases.

Other than that, it is a more graphicscard + drivers related problem than TRNG.

Lucky Cookie 01-05-10 16:32

Oh i see, forget to set it back to that lol

Thank you :D

Piega 12-06-10 17:07

A want to present a new bug, that is if it is a bug. After testing all afternoon I cannot get my leveljumps to work properly.

In TREP my leveljumps where fine and working. Things that I have checked are:
load camera,
Lara object (even checked with the animation tool in NGcenter)
Title flyby (same Lara object as my levels and flyby starts with 1)
Lara skin and everything is 100% the same in the levels.

Deleted possible errors from the crash report like,
missing font,

All I get is a file close in the crash report. No errors in the script. I can leveljump 2 or 3 times and then the game crashes. I have no TREP related stuff in the project left behind as it was more patching then actual triggers in the project.

In other leveljumps I get an invisible Lara, flickering meshes or objects dissapearing. Are there other games made with leveljumps in TRNG?

Resethub is no option as my levels are interconnected. This is a serious problem and I encounterd one of the same bugs with objects missing in the levels from Titak. If there are things I discouver I'll report them here but for now I think this is a serious issue.

Wad size, 40 pages.
Objects, still under 255 placed.

God Horus 12-06-10 17:09

^ I have had this problem, my Lara would go invisible sometimes and random objects would go missing.

There may be a fix, but I didn't have the time to wait for one and I knew that Paolone had his own issues so I just worked around it.

We should look into it however.

Titak 12-06-10 17:15


Originally Posted by Piega (Post 4669524)
I encounterd one of the same bugs with objects missing in the levels from Titak.

Yep, confirmed.
Never noticed it before but objects seem to go missing when going back and forth between levels, especially when going back and forth several times.
I haven't had any crashes, "only" the missing objects.

This is a very serious issue for me because my manor can't be played without the leveljumps that take you back and forth between the different parts. :(

Going from one level to the next is fine in my case. Nothing goes wrong then.
It is purely related to the going back and forth between levels.

God Horus 12-06-10 17:24

I posted this problem about a month ago and I tried experimenting with placing the missing objects in the other level as well but it didn't help.

It is serious though because the animating objects in my level (all the manor columns) were all spread out afterwards and the banisters were missing, and everything in the library was missing!

Piega 13-06-10 16:52

I did some more testing. To be sure it is not a limit I copied the new TRNG levels into TREP. Sinds the levels are still under the original 255 object and texture limit they work fine in TREP. And what happens? The levels load back and forth without any problems. I've level jumped about then times with weapons drawn and everything.

So I highly believe this is due to the modifications of the TRNG engine that makes level jumping not compatible. While I have absolutely no idea about programming I sense it has to do with the increase of the object placement of animatings and maybe even statics sinds statics can also dissapear. Sinds they are all stored in the savegames this info also travels with leveljumps (so that a door stays open when you return in the level and a picked up item is really picked up). Could this be the cause that the engine go's wacky after level jumping more then two times?

I think this is very high priority as some major games that depend on TRNG can never be finished :(

Walrus 13-06-10 17:18

I have as well 3 or 4 levels with leveljump, and after read this I tried to see if those levels have the same problems, but nothing: i tried with Lara shooting, bathing, burning and everything, all goes right. Maybe, as Piega said before, the problem is about the animatings in the levels. I have about 6 animatings in the wads, and even the hi-res objects are multiple statics. Have you tried to use a flipeffect variable to add some animatings to the memory code?

Piega 13-06-10 18:26

Urmm, I know nothing about special triggers yet in TRNG only the standard tutorial things. How come 3 people so far has these problems and not you? Do you use extra static slots for example? Multiple jumps within one level?

Why do I have no problems in TREP or even the original exe for that matter. I used the exact same data files converted from the NGLE tom2pc. So I doubt this is level related but some other external thing. And to be on the safe side all latest updates are installed.

You may have only six animatings in the wad but I have not gone over the 255 limit yet so I doubt I need a flipeffect for memory code.

Titak 13-06-10 19:00

Update on the leveljumping and disappearing objects and levelcrashes.

It could be related to one of the latest DLL updates.
I'm currently using version and this one has that problem.
However, my manor levels were betatested with DLL version and the problem isn't there then. Nothing has been changed in my manor levels since, I've only updated the TRNG to version

So it seems that this problem appeared somewhere in between versions and

So, to get the information on this matter as complete as possible, could everyone who is using one of the above mentioned DLL versions report the following here:
1. which DLL version are you using?
2. Do objects disappear, does the game crash or do you have other problems when leveljumping?
3. Did the leveljumping work properly before?
If so, which DLL version were you using then?

Hopefully we will then be able to pinpoint where the bug appeared and this might help Paolone to find the problem and fix it. :hug:

Piega 13-06-10 19:03

He sorry for an extra reply but I have found something that may be important. My game crashes or go's weird with levels that has EXTRA static slot items used. My first garden level works and loads ok and has no EXTRA static items in the wad. It's in the second garden level that contains extra statics. It's those statics that dissapear!

In my other level that I was working on I added EXTRA static items. It is also that level that behaves strange after level loading.

So Walrus my question directed to you is if you have EXTRA static slots in the wad. If not then that is probably the reason why you dont have problems.

EDIT: Just read you post Titak and this DLL might be the problem that handles the EXTRA static slot items wrong that makes them dissapear. All valuable info for Paolone.

Titak 13-06-10 19:08

That is also a good find! :tmb:
In my X Marks the Spot leveljump problems it were indeed the EXTRA static slots objects that went missing.
But in my manor some animatings go missing also.
I'll check which ones they are.

Piega 13-06-10 19:10

I checked the DLL and indeed my levels work OK!!! Thank god this is going to be solved :) No more crashing or dissapearing items. And to be sure, this problem probably only occurs when you have EXTRA static slots in the wad. I'm going to keep this DLL for a while :)

Titak 13-06-10 19:17

Okay, did a check on those missing objects in my manor: they were indeed all EXTRA static objects.

In my X Marks the Spot however also some (not all... :confused:) animating9 objects went missing, as well as one of the COG objects I placed.
And one of the animating9 objects even went horizontal while it does not even have an animation which turns it horizontal... :confused:

I'm assuming you are now using DLL, Piega?

The thing is that I have already implemented some things that are not possible with :(
So I really hope this problem can be fixed, otherwise I'll have to change quite a bit in my levels...

Piega 13-06-10 19:22

The EXTRA static dissapearence maybe infects the animations too. Without EXTRA statics there are no problems but for TRNG those slots are really needed. While Paolone might be busy with other things in life I'm sure it will be solved. I have not used any of those new things but I know you have. Patience should be the key for now. I'm using DLL So far everything is ok again.

Raymond 13-06-10 19:25

Oh, missed this discussion.
This problem is already known. Itīs related to the extra-static objects and if you leveljump back and forth without reloading in the previous level.
Will be fixed hopefully soon.

Piega 13-06-10 19:40

Duh, I spent all my testing for nothing :( Where is the most active discussion about TRNG about bugs? Probably not in English right?

deskj 13-06-10 20:03

oh well the italian one is almost ignored too :p

Raymond 13-06-10 20:23

This one was found by a LB-builder, but I would say, the most active discussion is here.

Delta 16-06-10 18:12

I think there is a bug in some condition triggers, often when I use these triggers in a triggergroup they don't work as they should ...

And then I'm trying to activate a triggergroup when the player uses PISTOLS_ITEM but the GlobalTrigger "GT_USED_INVENTORY_ITEM" on this object doesn't work ...
Someone knows if is there another way to activate a triggergroup using PISTOLS_ITEM from inventory?

Laras Boyfr. 16-06-10 20:25

I think weapons cant be assigned with that flag...
What do you want to achieve?

Delta 16-06-10 21:23

I'm trying to make the magnum guns without definitively overwrite another weapon slot. I'm using Pistols slots, GlobalTriggers, TriggerGroups (swapmesh, variables, other triggers) etc.
Currently Lara can use pistols, extract and use magnums (like it is another weapon), but she can't re-extract the pistols because I can't activate a TriggerGroups when you select the PISTOLS_ITEM from the inventory :o

Raymond 17-06-10 06:44

No problem, Delta. Use GT_CONDITION_GROUP and the condition "Exporting: CONDITION(35:0) for PARAMETER(1); <#> : Holding_Pistols; <&> : Lara. (Holds) Lara is holding/driving the <#>item" instead.

Delta 17-06-10 09:57

Unfortunately I can't use that condition ... the magnum guns are in a fake new weapon slot, really I used the PISTOLS_ANIM slot to make them, and then the condition "Lara is holding pistols" will be true also if Lara holds the magnum guns ...

Scurvy 06-08-10 17:41

stupid bug/glitch i dont know, but when i want to change the floor height it goes up by 4 not 1??

Any solutions :)?

God Horus 06-08-10 17:42

Are you right clicking?

Scurvy 06-08-10 17:43

nope, left clicking

Laras Boyfr. 09-08-10 15:16

ah lol a lot of things have changed since I wasnt here:o
so I saw the new update of TRNG and it looks very promising though I havent tested it yet:). So I wanted to ask if the object dissapearing bug when switching levels is still there?:)

Raymond 09-08-10 15:25

Unfortnately yes. Iīll remember Paolone to fix it soon.

Level NextGen 10-08-10 14:47

Kayak_Strangy mist on land!
Yeh! With the new update I tested the kayak and it works fine :D (even if it's quiet hard to move)... I add the OCB 1 to make mist with the Kayak but I noticed that on land the mist becomes strange, she moves too far away from the kayak, see HERE (in red circle)! But it's happened only on flat land!
I just wanted to notice that for perhaps deleting it or just fixing it! ;)

-Roli- 16-08-10 07:37

Hi there,

I have a bug long time ago, and still don't know what can be the problem, i made a video:

When i go to the options screen, the thunder sound is there, and if i switch between the sound qualities, then after the "high" a blank word is there. :confused:

And this happens in the game too, not just in the title screen.

Never heard about this bug.

Thank you! :)

Raymond 16-08-10 14:22

This isnīt a trng-bug. Your sounds are simply messed. So do a good sound conversion. I donīt know the name of the sound, which should be there instead of the thunder sound.

-Roli- 16-08-10 14:34


Originally Posted by Raymond (Post 4822329)
This isnīt a trng-bug. Your sounds are simply messed. So do a good sound conversion. I donīt know the name of the sound, which should be there instead of the thunder sound.

No, that impossible. Already did that...
And what could you say for the blank word after the "high"? That's not sound.

Raymond 16-08-10 14:50

Then your sound conversion isnīt good enough.
About the blank word: Check your PCStrings in your english. txt, if everything is like the original.

Raymond 16-08-10 14:51

double post

Ceamonks890 17-08-10 04:48

I know these bugs have been fixed in TREP, but it would be great to have these fixed for TRNG too.

Dissappearing flare bubbles underwater
Lara's reflection has binoculars when you look at a mirror through binoculars
Show health meter in inventory when small/large medipack selected(like TR1-TR3)
Jeep/motorbike exploding in water fix

l.m. 17-08-10 09:55

it would be fine,
if the TRNG can handle more Fog Bulbs in one Level, respectively the limit of fog bulbs will increase.

If you place par example 7,8 or more Fog Bulbs in one level, the fog disappear and appear,
when lara reach it.

-Roli- 17-08-10 10:01


Originally Posted by Raymond (Post 4822437)
Then your sound conversion isnīt good enough.
About the blank word: Check your PCStrings in your english. txt, if everything is like the original.

Everything like the original. :(

All times are GMT. The time now is 02:10.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Tomb Raider Forums is not owned or operated by CDE Entertainment Ltd.
Lara Croft and Tomb Raider are trademarks of CDE Entertainment Ltd.