Tomb Raider Forums

Tomb Raider Forums (https://www.tombraiderforums.com/index.php)
-   Tomb Raider Next Generation (https://www.tombraiderforums.com/forumdisplay.php?f=40)
-   -   TRNG - Bugs & Limitations Thread (https://www.tombraiderforums.com/showthread.php?t=165980)

Paolone 07-08-13 13:00

[QUOTE=AkyV;6870685]IMPORTANT NOTE: while when you use CUST_BACKGROUND for binoculars, alone, the binocular image for background can have any size, when you wish customize advanced features for binoculars with this CUST_BINOCULARS command, you have to use as background image for binoculars an image with size 1024 x 768.
This requirement is necessary to work on a well-known size to grant correct alignment between the background and the different values, bars or strips that will be added to it.[/QUOTE]

Ah, now I understand.
Above text doesn't speak about full screen or less but only about the source size of the image.
When you do not use the cust_binoculars but only cust_background with binoculars, you can use any source size for image and it will be always fit to the full screen.
While with cust_binoculars the source size of image has to be always of 1024x768 (and then it will be fit to the full screen, too)

Paolone 07-08-13 13:01

[QUOTE=Dino14;6871081]When I updated TRNG I started to see in game lines which goes down to up (like in old VHS). Looks like those doesn't appear in screens (haven't try video yet). I don't know what causes it. I don't see those lines in levels which haven't this new update. Is it only my computer or this new update?[/QUOTE]

You should perform at least once the setup (hit CTRL key while tomb4 is starting) and set a reasonable resolution for your pc.

Paolone 07-08-13 13:07

[QUOTE=AkyV;6872013]
1. Characterset 1 (Default) was useful, ő, Ő, ű, Ű now was OK!

[I]But it didn't work with "usual" Text Flipeffects, using DefaultWindowsFont. (Still not using UNICODE or UTF8.) [/I]
[/quote]
I believe you have to use UTF8 otherwise the font will work fine only "fortunately" when the target PC has already the right setting.
Differently, if you use UTF8 (using write.exe to type your text) or UNICODE (using words) trng will force the right charset and conversion.

More, using a text editor (like write.exe) on your computer, you can verify what font name you are using and what characters are really supported. Some fonts could have not some special character.

AkyV 07-08-13 17:16

[B]1227f test[/B]

- CUST_KEEP_DEAD_ENEMIES is still not OK for "Exploding Moveable" feature. (It is OK with "Exploding creature", but that was never buggy.)
- Fixed bug for BKGDT_TITLE:
So we should be able to use it? As opposed to what you say in NG Center?
However, it is not useful, covering all the texts, except volume bars. (I mean, transparent parts naturally won't cover them with IF_TRANSPARENCE.)
And "big" pictures (see eg. your BMP1 in lightning demo) seems to have low quality.
- BINF_SOUND: they work, including the customization.
One little problem: if you hit zoom, you will hear the sound even if you reached the maximum/minimum.
- Compass/sextant strips: if the player reaches the left/right/up/down maximum of the actual POV, and keeps hitting the arrow buttons, then the swinging continues, though the binoculars won't move.

Paolone 07-08-13 19:33

[QUOTE=Titak;6872086][B]RUBBER_BOAT[/B]
When Lara climbs or jumps into the rubber boat, it goes either backwards or forwards a bit.
[I]When repeated it can even go into a wall this way!
And it also causes issues when it is placed in a corner, back towards a wall.[/I]

The animations of both the rubber-boat and rubber-boat-lara do not show any going back or forth so it must be coded into the behaviour of the rubber boat in another way somehow.

I also checked the MOTOR_BOAT and this boat does NOT show the same behaviour: it keeps its position when Lara climbs or jumps into it. :D
[/quote]
I had never noticed this. :confused:
But this movement does it happen after she entered in the boat?
Isn't it a problem of initial alignment?
I have to check in game to understand better. :o

Paolone 07-08-13 19:51

[QUOTE=AkyV;6874264][B]1227f test[/B]

- CUST_KEEP_DEAD_ENEMIES is still not OK for "Exploding Moveable" feature. (It is OK with "Exploding creature", but that was never buggy.)
[/quote]

Then, I had not understood very well the problem.
You mean that using the A15 trigger in the mode "Exploding moveable on ground/sky" there is that problem...
Ok, but do you applied that mode on a creature like Baddy1?
Because I set different method own to work in according with item kind.
Anyway now I'll check but in this case it's only a matter of settings.

[quote]
- Fixed bug for BKGDT_TITLE:
So we should be able to use it? As opposed to what you say in NG Center?
However, it is not useful, covering all the texts, except volume bars. (I mean, transparent parts naturally won't cover them with IF_TRANSPARENCE.)
[/quote]
The problem was own that background image seem really a foreground image, convering all standard texts.
Anyway, in limited situation of using DefaultWindowsFont, now BKGDT_TITLE can work.
[quote]
And "big" pictures (see eg. your BMP1 in lightning demo) seems to have low quality.
[/quote]
I'll check this and other problem you discovered, I thank you.

Titak 07-08-13 22:18

[QUOTE=Paolone;6874383]I had never noticed this. :confused:
But this movement does it happen after she entered in the boat?
Isn't it a problem of initial alignment?
I have to check in game to understand better. :o[/QUOTE]
It happens[U] during[/U] her [U]climbing[/U] into the boat (animation 0 of the RUBBER_BOAT and RUBBER_BOAT_LARA) and [U]jumping[/U] into the boat (not sure which animation this is exactly because I can't see any meshes when viewing RUBBER_BOAT_LARA in WADMerger Animation Editor... It might use the last frames of animation0 for all I know... :o)

The boat goes either about 1/3 of a tile forwards or backwards.
This seems to alternate as long as you keep doing the same animation: climbing in all the time or jumping in all the time.
When you switch from climbing in to jumping in, or visa versa, the boat might go forwards or backwards again. And this is how it can end up in a wall/block.


[B]**** EDIT ****[/B]
I was using CUST_ROLLING_BOAT for the RUBBER_BOAT and it turns out that it is this command that causes the boat to go forwards or backwards when Lara jumps/climbs in.

AkyV 08-08-13 07:00

[QUOTE=Paolone;6874405]Then, I had not understood very well the problem.
You mean that using the A15 trigger in the mode "Exploding moveable on ground/sky" there is that problem...
Ok, but do you applied that mode on a creature like Baddy1?
Because I set different method own to work in according with item kind.
Anyway now I'll check but in this case it's only a matter of settings[/QUOTE]

(A14 is that A15.)
Yes I tested it only with Baddy_1.
But the problem seems a bit more complex for me:

Try C14 with an "enemy dead" condition. (Use that F355 red light as I said, to test the condition, it is very spectacular, if the screen is red, when the condition is true.) Kill the enemy with pistols, then save/load the game - and the screen stop being red.
Or try the same, but this time kill the enemy with a poisoned arrow - the screen won't go red when the enemy dies.

So we have two problems with death conditions:

- they are not savegame-stable,
- C14 can't detect special deaths.

See Chapter 1.1.6. Condition combination (3) here:

[url]http://www.skribblerz.com/tuts/ngle/ngle3/akhiddentriggers3.htm[/url]

As you see there, Flags of Item field is able to detect many special deaths, using their own values for them. - Btw, the value is 4 here for a "usual" death (i.e. eg. death by pistols).
I discovered in most of these cases the "death value" of the field turns back to 36 (if I remember the value well...) if we save the game, and then we load that.

This probably has something to do with the "killed enemies" Statistics data, because, with "killed enemies"

- each killing by explosive ammunition now is calculated as if Lara had killed 2 enemies at once,
- “special” deaths (killings by ACTION triggers, WRAITH1 disappears in the water, poisoned death, “headless” skeleton etc.) isn’t calculated in "killed enemies".

I think that is why "killed enemies" is missing from TR4 Statistics Screen...

EDIT:
Paolone, did you read some "new" bug descriptions since your last post (#300) in this thread?:

[url]http://www.tombraiderforums.com/showthread.php?t=197687&page=31[/url]

AkyV 14-08-13 09:42

[B]1227j test[/B]

[B]Update issue (only on a given computer)[/B]
The Office installer always launches by itself when I launch NG Center or WADMerger.

[B]Play button fix[/B]
“Start Tomb4.exe”, “Last backup” and similar messages in Room Info Box isn’t removed after the conversation. (And after other procedures?)
[B]
Hide Objects[/B]
From raiderromero:
[I]emm paolone the "hide objects" buttom is now messed up if i click on it the warning message appears and appears then after a while all the objects disappeared cant be restore, i need to close NGLE[/I]

I can confirm it.

EDIT:
On another computer, NGLE crashed when I hit Hide Object.

[B]Dart bug[/B]
Now all the dust directions are good. But a new bug arose: till now, the darts are emitted from the square side where the bottom of the red pyramid nullmesh is, towards the pyramid tip. But now the darts are emitted from the square side where the pyramid tip is – the dart direction hasn’t changed.
(Note: maybe it is old but I discovered it now: if a dart poisons Lara with DRT_FIX_POISON_BUG flag, then the health bar disappears for some moments – but if she is poisoned, then the bar shouldn’t do that, right?)
[B]
Pushable/pickup bug[/B]
What do you mean with we should remove the collision with WADMerger? I.e. we should use “Disable Collesion” button or we should use “Collesion/Disable Colesion (frame)” or “Disable Mesh Sphere” menu command in Animation Editor, when that pickable item is selected? Because none of them seems to work to solve this problem.

[B]Weather. Set in advance the rain setting using the intensity of <&>Room[/B]
This F361 trigger name is still the same.

[B]Variables. Convert the <&>NGLE Room index in TOMB Room Index to CurrentValue[/B]
It happens even with a very simple brand new test project like that: I still have only the original room Room0 (0:0), and then I create another one: Room16 (16:1). Now I placed this trigger (F297) in Room0, about Room16. So Current Value is 0 now, but Lara steps on the trigger. Now Current Value should be 1, right, because this is the Tomb index of Room16. But, no, Diagnostics on the screen says Current Value has become -1 now.

But these triggers worked:
301: Variables. Convert the NGLE Item Index to Tomb Item Index in CurrentValue
299: Variables. Convert the NGLE Room Index to Tomb Room Index in CurrentValue
300: Variables. Convert the Tomb Item Index to NGLE Item Index in CurrentValue
298: Variables. Convert the Tomb Room Index to NGLE Room Index in CurrentValue

Maybe you meant F298-301 when you say it worked, so you were not talking about F297?

[B]F195 for fog start point. But what about end point?
F227 "Weather. Fog. Set Hardware <&>End Fog limit"[/B]
No, that is wrong. First of all, F227 description is: “Weather. Fog. Set <&>End Fog limit for Distance fog”.
Besides, F227 works with a sudden move, so F227 is the pair of F194, that is the sudden move for the start point.
F195 changes the start point during a given time. There is no trigger that moves the end point during a given time.
(By the way, other pairs:
- Looped changes: F228, F229 – and F230 to stop the looped sequence.
- Pulsing changes: F196, only for the start point but it also affects the end point, because the range is constant during the moves - and F198 to stop the pulsing sequence.)

Paolone 14-08-13 21:09

[QUOTE=AkyV;6879419]
Pushable/pickup bug[/B]
What do you mean with we should remove the collision with WADMerger? I.e. we should use “Disable Collesion” button or we should use “Collesion/Disable Colesion (frame)” or “Disable Mesh Sphere” menu command in Animation Editor, when that pickable item is selected? Because none of them seems to work to solve this problem.
[/quote]
I tried with three different pickups (lasersight and two puzzle items) and it works.
You have to:
1) Open wadmerger
2) Select pickup you wish modify
3) Click on [Animation Editor] button
4) Click on in bottom left panel, on "Animation 0" (and it should be the only with pickups)
5) Now from Collesion menu choose [Disable colesion (frame)]

[quote]
[B]Variables. Convert the <&>NGLE Room index in TOMB Room Index to CurrentValue[/B]
It happens even with a very simple brand new test project like that: I still have only the original room Room0 (0:0), and then I create another one: Room16 (16:1). Now I placed this trigger (F297) in Room0, about Room16. So Current Value is 0 now, but Lara steps on the trigger. Now Current Value should be 1, right, because this is the Tomb index of Room16. But, no, Diagnostics on the screen says Current Value has become -1 now.

But these triggers worked:
301: Variables. Convert the NGLE Item Index to Tomb Item Index in CurrentValue
299: Variables. Convert the NGLE Room Index to Tomb Room Index in CurrentValue
300: Variables. Convert the Tomb Item Index to NGLE Item Index in CurrentValue
298: Variables. Convert the Tomb Room Index to NGLE Room Index in CurrentValue

Maybe you meant F298-301 when you say it worked, so you were not talking about F297?
[/quote]
I tried the F297 and for me it works.
The only theoretical bug should be if the ngle room was higher than 255, but in our example that didn't happen.
[quote]
[B]F195 for fog start point. But what about end point?
F227 "Weather. Fog. Set Hardware <&>End Fog limit"[/B]
No, that is wrong. First of all, F227 description is: “Weather. Fog. Set <&>End Fog limit for Distance fog”.
Besides, F227 works with a sudden move, so F227 is the pair of F194, that is the sudden move for the start point.
F195 changes the start point during a given time. There is no trigger that moves the end point during a given time.
[/quote]
It's true, now I remember. The end fog limit is set in hardware mode and it doesn't work fine to change it continuosly, for this reason I let only the dynamic change for start point since that is comptued in software way.


All times are GMT. The time now is 23:38.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Tomb Raider Forums is not owned or operated by CDE Entertainment Ltd.
Lara Croft and Tomb Raider are trademarks of CDE Entertainment Ltd.