Tomb Raider Forums

Tomb Raider Forums (https://www.tombraiderforums.com/index.php)
-   Tomb Raider Next Generation (https://www.tombraiderforums.com/forumdisplay.php?f=40)
-   -   TRNG - Bugs & Limitations Thread (https://www.tombraiderforums.com/showthread.php?t=165980)

Piega 13-06-10 18:26

Urmm, I know nothing about special triggers yet in TRNG only the standard tutorial things. How come 3 people so far has these problems and not you? Do you use extra static slots for example? Multiple jumps within one level?

Why do I have no problems in TREP or even the original exe for that matter. I used the exact same data files converted from the NGLE tom2pc. So I doubt this is level related but some other external thing. And to be on the safe side all latest updates are installed.

You may have only six animatings in the wad but I have not gone over the 255 limit yet so I doubt I need a flipeffect for memory code.

Titak 13-06-10 19:00

[B]Update on the leveljumping and disappearing objects and levelcrashes.[/B]

It could be related to one of the latest DLL updates.
I'm currently using version 1.2.2.1 and this one has that problem.
However, my manor levels were betatested with DLL version 1.2.1.8 and the problem isn't there then. Nothing has been changed in my manor levels since, I've only updated the TRNG to version 1.2.2.1.

So it seems that this problem appeared somewhere in between versions 1.2.1.8 and 1.2.2.1.

So, to get the information on this matter as complete as possible, could everyone who is using one of the above mentioned DLL versions report the following here:
[B]1.[/B] which DLL version are you using?
[B]2. [/B]Do objects disappear, does the game crash or do you have other problems when leveljumping?
[B]3. [/B]Did the leveljumping work properly before?
If so, which DLL version were you using then?

Hopefully we will then be able to pinpoint where the bug appeared and this might help Paolone to find the problem and fix it. :hug:

Piega 13-06-10 19:03

He sorry for an extra reply but I have found something that may be important. My game crashes or go's weird with levels that has EXTRA static slot items used. My first garden level works and loads ok and has no EXTRA static items in the wad. It's in the second garden level that contains extra statics. It's those statics that dissapear!

In my other level that I was working on I added EXTRA static items. It is also that level that behaves strange after level loading.

So Walrus my question directed to you is if you have EXTRA static slots in the wad. If not then that is probably the reason why you dont have problems.

EDIT: Just read you post Titak and this DLL might be the problem that handles the EXTRA static slot items wrong that makes them dissapear. All valuable info for Paolone.

Titak 13-06-10 19:08

That is also a good find! :tmb:
In my [I]X Marks the Spot [/I]leveljump problems it were indeed the EXTRA static slots objects that went missing.
But in my manor some animatings go missing also.
I'll check which ones they are.

Piega 13-06-10 19:10

I checked the DLL and indeed my levels work OK!!! Thank god this is going to be solved :) No more crashing or dissapearing items. And to be sure, this problem probably only occurs when you have EXTRA static slots in the wad. I'm going to keep this DLL for a while :)

Titak 13-06-10 19:17

Okay, did a check on those missing objects in my manor: they were indeed all EXTRA static objects.

In my [I]X Marks the Spot[/I] however also some (not all... :confused:) animating9 objects went missing, as well as one of the COG objects I placed.
And one of the animating9 objects even went horizontal while it does not even have an animation which turns it horizontal... :confused:

I'm assuming you are now using DLL 1.2.1.8, Piega?


The thing is that I have already implemented some things that are not possible with 1.2.1.8... :(
So I really hope this problem can be fixed, otherwise I'll have to change quite a bit in my levels...

Piega 13-06-10 19:22

The EXTRA static dissapearence maybe infects the animations too. Without EXTRA statics there are no problems but for TRNG those slots are really needed. While Paolone might be busy with other things in life I'm sure it will be solved. I have not used any of those new things but I know you have. Patience should be the key for now. I'm using DLL 1.2.1.9. So far everything is ok again.

Raymond 13-06-10 19:25

Oh, missed this discussion.
This problem is already known. Itīs related to the extra-static objects and if you leveljump back and forth without reloading in the previous level.
Will be fixed hopefully soon.

Piega 13-06-10 19:40

Duh, I spent all my testing for nothing :( Where is the most active discussion about TRNG about bugs? Probably not in English right?

deskj 13-06-10 20:03

oh well the italian one is almost ignored too :p


All times are GMT. The time now is 17:48.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Tomb Raider Forums is not owned or operated by CDE Entertainment Ltd.
Lara Croft and Tomb Raider are trademarks of CDE Entertainment Ltd.