www.tombraiderforums.com

www.tombraiderforums.com (https://www.tombraiderforums.com/index.php)
-   Software Development (https://www.tombraiderforums.com/forumdisplay.php?f=55)
-   -   Meta2tr update. (https://www.tombraiderforums.com/showthread.php?t=135733)

meta2tr 18-07-10 15:02

Quote:

Originally Posted by Walrus (Post 4754822)
This happens every time I try to import an object. The object, in this case, is modeled and mapped in 3ds Max 2009, and use a 256x256 texture....

I *think* that when you are importing the object into moveall, it also imports a new material, could you check? The material list in Metasequoia should have Tile001 first, Tile002 second and so on. Is there a new material added to the end?

Walrus 18-07-10 15:22

Yes, when I import the model, a new tile is added at the end of the list, but usally I delete it and I apply the tile imported with the level.

meta2tr 18-07-10 15:59

Well you are doing everything right in Metasequoia, as far as I can tell. In any case, don't change the order of the materials in the material panel, as this is what meta2tr uses to determine the tile number, eg the 5th material in the list is taken to be Tile005, etc.

Importing the object into the level should now be very simple. With your new object highlighted in the object list, click on Misc then Show only current, so only the object is visible (this saves time in the next step).
Then save the file. Then drop it onto meta2tr. It should say importing ANIMATING5 or whatever slot you've chosen. No need to import any of the tiles, because they haven't been changed. Then run newlevel.tr4, and everything should be ok. Does that work?

meta2tr 18-07-10 16:12

Quote:

Originally Posted by Walrus (Post 4754888)
Still the page doesn't load the demo file... I tried with Mozilla and explorer, too. I downloaded the v5 hours ago, and the problem above happens just with v5 (the v4 had the UV points too near or crossed problem and the conversion was aborted).

OK, I'll create an object with the same uv points as yours and test it.

Walrus 18-07-10 16:20

Yes, it works! :jmp: So, it was only the visibility flag on the model? :confused: Man...

http://www.aspidetr.com/forum/downlo...p?id=17454&t=1

meta2tr 18-07-10 17:00

Quote:

Originally Posted by Walrus (Post 4755085)
Yes, it works! :jmp: So, it was only the visibility flag on the model? :confused: Man...

http://www.aspidetr.com/forum/downlo...p?id=17454&t=1

:jmp:Looks great !

The visibility flag is used by meta2tr to determine whether or not to import the object. It's just to avoid importing objects that haven't changed therefore saving time.

I *think* that your Tile list was out of order in your first moveall file, anyway that would explain why the room textures were ok (they have tiles with lower numbers) and Lara's textures were not (she has tiles with higher numbers). For example, this could happen if you take an added material at the end of the list, and you drag it up the list, it gets inserted, and bumps half the existing tiles down.

meta2tr 18-07-10 17:27

Quote:

Originally Posted by Walrus (Post 4754888)
Still the page doesn't load the demo file... I tried with Mozilla and explorer, too. I downloaded the v5 hours ago,

I'll upload the demo to a different server and post a link here shortly.

Quote:

Originally Posted by Walrus (Post 4754888)
the problem above happens just with v5 (the v4 had the UV points too near or crossed problem and the conversion was aborted).

It's strange, I haven't been able to reproduce the problem you're having. So I don't think it's related to the uv points.

I've created a BADDY_1 object, with UV points like yours.. in Metasequoia it looks like this:
http://img413.imageshack.us/img413/5...od3metaseq.gif

Checking the mqo file in Notepad shows exactly the same uv coordinates (1,0 0,0 0,0 1,0):
http://img697.imageshack.us/img697/8...y1mod3text.gif

The conversion happens with no errors:
http://img35.imageshack.us/img35/607...mod3import.gif

And in game it worked:
http://img541.imageshack.us/img541/5...y1mod3game.gif

So can you give me the exact error message you have? If it scrolls off the screen, just open report.txt, go to the bottom of the file, and look for the error there.

Thanks.

Walrus 18-07-10 17:33

Ops, sorry, I think that there was a misunderstanding :hug: I was talking about my problem with the bad texturing, not about the baddy with the UV Points too near or crossed of TR-Freak. I had that error using the old version, but now the problem there isn't anymore with the new one. As you said him, probably he was using the v4. I tried with one of my model that meta2tr doesn't import 'cause the Uv problem, and it works great :D

meta2tr 18-07-10 17:41

Quote:

Originally Posted by Walrus (Post 4754888)
Still the page doesn't load the demo file... I tried with Mozilla and explorer, too

Try here as an alternative.

TR-Freak 18-07-10 18:27

Thx for the help!
But...
http://npshare.de/files/50d9fcd9/Unbenannt.jpg
But I can't change the Pivot! The whole Mesh will move,too!


All times are GMT. The time now is 10:23.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.