www.tombraiderforums.com

www.tombraiderforums.com (https://www.tombraiderforums.com/index.php)
-   Next Generation Level Editor (https://www.tombraiderforums.com/forumdisplay.php?f=40)
-   -   AkyVís released plugins (https://www.tombraiderforums.com/showthread.php?t=219148)

DJ Full 12-03-18 22:55

I did exactly as you said. TRNG crashes instantly after launch :/
This persists even after I uninstalled the plugin... dammit...
I need to clean up the entire folder and reinstall the workshop.
Then I'll make a video to show you precisely what happens.
There's a little chance I hit some uncharted glitch or what...

AkyV 12-03-18 23:07

1. Video. Okay.
2. Some people reported crashes or similar issues with plugins (not only this one) when realized they don't have the minimum 1.3.0.7. Do you have? :D
3. Some of us established some weeks ago that the best way to install any plugins after a fresh installation of TRLE/TRNG. (Not for everyone. As far as I know Titak installed it successfully for a working, huge and important TRNG project, her Avalon2. Funny, anyway, that we can never say OS issue. I mean, I wrote this plugin in my old PC, under XP, and Titak uses it with Win10.)
4. After I installed TRNG 1.3.0.X (I don't remember what was X exactly), I encountered random crashes. Before doing anything with plugins. And that still exists. My solution is I have another TRLE installed as well (yes, a pure one, without any TRNG), where I use ALT+ENTER to switch on/off window mode. Perhaps also starting/loading something in that TRLE. Just for a few moments and then I exit. Then that crash is fixed. For a while...

klona 12-03-18 23:18

Quote:

Originally Posted by DJ Full (Post 7832169)
I did exactly as you said. TRNG crashes instantly after launch :/
This persists even after I uninstalled the plugin... dammit...
I need to clean up the entire folder and reinstall the workshop.
Then I'll make a video to show you precisely what happens.
There's a little chance I hit some uncharted glitch or what...

I do have a similar problem. If it still crashes, just delete ng_settings in your TRLE folder and then launch ngle again.

AkyV 12-03-18 23:28

As far as I can see, ng_settings.bin is the file where the list to open "last projects" is stored. Perhaps is it detected that older projects of the list aren't compatible (?) with the plugins and that causes the crash? :ponder:

DJ Full 12-03-18 23:50

No way at least in my case: project 1.3.0.7, plugin 1.3.0.7.
Apparently klona is correct... it was this very file, ng_settings.bin.
It appears to remember projects from several previous trle folders.
A chunk of it even contained an... enemy jeep tutorial???

Deleted. Recreated. The projects open. Weird...

Edit:
In the light of the above I tried again to use the Mix1 plugin.
But nope, as soon as installed it, NGLE does an instant crash.
And no, it's not the project because I can't even load any.
Yep, gonna make that video...

AkyV 13-03-18 18:24

A log info could be also helpful.

1. Launch Tomb4_log.exe in TRLE/tools folder.
2. Launch the game. It crashes.
3. Maybe you could also see the issue in the log program window, but it is the better if you can open tomb4_log.txt in tools folder: this is the result of the last run of log.exe. Probably the last row(s) of the log info have something useable about the reason of the crash.

Edit:
Wait, you mean NGLE, the editor, not the game?
That also has a log exe/txt there, tomb5_log.

DJ Full 13-03-18 21:26

Yep, it's NGLE not the game.
Will check out the log file.
Recording for you right now...

EDIT: Now I can't download your plugin at all.
It says "bad gateway"...

AkyV 13-03-18 22:19

Quote:

Originally Posted by DJ Full (Post 7832604)
Yep, it's NGLE not the game.
Will check out the log file.
Recording for you right now...

Okay, I am here. :D

Quote:

EDIT: Now I can't download your plugin at all.
It says "bad gateway"...
Must be a web issue.
No problem here...

Titak 13-03-18 22:40

How odd it doesn't install properly on your end, DJ Full. :confused:
I haven't had any issues with AkyV's plugin or the rollingball plugin.

I sure hope you guys figure out what the problem is.

DJ Full 13-03-18 23:45

I guess I just made some obvious mistake or what.
Here's the entire procedure as I'm trying to follow it:



All times are GMT. The time now is 12:11.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.