www.tombraiderforums.com

www.tombraiderforums.com (https://www.tombraiderforums.com/index.php)
-   Next Generation Level Editor (https://www.tombraiderforums.com/forumdisplay.php?f=40)
-   -   Global Triggers aren't working (https://www.tombraiderforums.com/showthread.php?t=223222)

TR-Freak 04-08-19 10:04

Global Triggers aren't working
 
I have a weird issue where Global Triggers do not want to work at all.

I have the following script:

Code:

Parameters=        PARAM_SET_CAMERA, 1, IGNORE, IGNORE, -4096, 5472, 15
#DEFINE        TG_DEATH_CAM        42
GlobalTrigger=        112, IGNORE, GT_LARA_HP_LESS_THAN, 1, IGNORE, TG_DEATH_CAM, IGNORE
TriggerGroup=        TG_DEATH_CAM, $2000, 214, $1
; Set Trigger Type - FLIPEFFECT 214
; Exporting: TRIGGER(1:0) for FLIPEFFECT(214) {Tomb_NextGeneration}
; <#> : Camera. Change camera mode with <&>Parameters for (E)time
; <&> : Parameters=PARAM_SET_CAMERA,    1
; (E) : Forever (use other action/effect to disable it)
; Values to add in script command: $2000, 214, $1

It's straight forward:
Once Lara's HP is less than 1 (i.e. equal to 0), switch to the Camera set in PARAM_SET_CAMERA 1.

However, it does not work.
I noticed that not a single Global Trigger works!
I tried doing it even simpler, without any defines or includes.
I tried different GT_ Flags to do other stuff (e.g. killing Lara by using an Inventory Item or killing lara just with GT_ALWAYS) but even then, it does not work.
I dont have any GTs or Scripts that could interfere and no plugins installed.
Anyone know where the issue lies?

klona 04-08-19 10:14

Your trigger group doesn't have an ID.

This is your TG:
Quote:

TriggerGroup= TG_DEATH_CAM, $2000, 214, $1
Replace the bold part with the ID. In this case I assume it's 42.

TR-Freak 04-08-19 10:21

Quote:

I tried doing it even simpler, without any defines or includes.
Already tried that

Dustie 04-08-19 10:36

have you tried with really basic setups with GT ALWAYS and actual TGs for conditions, like when Lara's health goes below X flash the screen in green or play sound?

TR-Freak 04-08-19 10:51

Yes. Like this:

Code:

GlobalTrigger=        1,FGT_SINGLE_SHOT_RESUMED,GT_CONDITION_GROUP,IGNORE,1,2,IGNORE
Triggergroup=        1,$8000,1,$0023 ; LARA Holding Pistols
Triggergroup=        2,$2000,89,$0012 ; Decrease Lara HP by 10 percent

it simply doesnt work


Tried GT_ALWAYS instead of GT_CONDITION_GROUP, too

LoreRaider 04-08-19 11:19

Try to reinstall NG_center, it happens sometimes that when you add or remove folders from it, scripted triggers doesn't work unless you reinstall the program

Dustie 04-08-19 11:23

Maybe check if ANY changes to your script file work? Maybe there is a permissions issue and your script file isn't actually being saved or is being saved elsewhere, maybe caught by the Compatibility Layer thing in Windows or idk what else...

TR-Freak 04-08-19 11:47

Quote:

Originally Posted by LoreRaider (Post 8117734)
Try to reinstall NG_center, it happens sometimes that when you add or remove folders from it, scripted triggers doesn't work unless you reinstall the program

that was it. reinstalling helped.
TRNG is retarded

SrDanielPonces 04-08-19 16:44

I would tell you to replace Tomb_NextGeneration.dll with the one in ng_center because that usually solves the issue, but i'm glad it's working now

JMN 04-08-19 16:56

When you add a new TRLE folder in NG Center, you need to restart it and go through the Updates flow again to make sure the folder is using the latest TRNG version.


All times are GMT. The time now is 15:05.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.