www.tombraiderforums.com (https://www.tombraiderforums.com/index.php)
-   Technical Support (https://www.tombraiderforums.com/forumdisplay.php?f=15)
-   -   Strange New TR5 Launch Issue (https://www.tombraiderforums.com/showthread.php?t=222987)

fallenangle 19-06-19 11:37

Strange New TR5 Launch Issue
I installed TR5 a couple of years ago from my original disc but also used no CD files (a replacement .exe and a .dll).

It has been working fine and I've played through it now twice since without problems but sometime during my recent no scratch run an odd thing started happening at initial launch.

I click on the shortcut and it looks as though it is booting but eventually does not. I click again and it launches perfectly. If the PC remains on I can close and relaunch it normally but if I shutdown/restart the PC the same thing will happen the first time, every time.

What I also hadn't noticed until yesterday, as I'm wearing headphones when playing TR5 and my PC runs fairly quiet, is that after these 'double' launches at some point the CPU use goes up to 100%.

That is very unusual and when I realised this was happening and investigated I found that I had to two instances of the PCTR5.exe being shown in the Task Manager as active processes. Even after I had closed and exited the game the second one still remained. That was what was hogging the CPU with an associated Windows Host Process (Rundll32) being the culprit taking up 67% of the CPU.

What is worrying is that 'Host Process' remains running too unless I terminate it from the Task Manager. How long this has been happening I do not know. I've tried replacing the no CD .exe and .dll with backups and the original files too and the problem persists.

No other TR I have installed in the same Core Design folder has this double, double click launch problem or provokes the high CPU use, far from it. TR3 for instance uses about 24% and the process stops, as it should, when you Exit the game.

Anyone have some idea what is going on here and if can be resolved without doing a full TR5 uninstall/reinstall?

laravision 19-06-19 14:02

How strange. Just recently, I have been experiencing a very similar issue, if not the exact, only it's happening with TR4/TRLE and TR2 (I don't have TR5 installed). It just started happening seemingly out of the blue; nothing has changed with my Windows 7 settings. In fact, I have updates turned off, but yet something has changed. Are you running Windows 7?

Like you, I click to launch the game/s and they do not launch, the process just hangs, alongside Rundll32. Running a 2nd time will then launch the game, but memory isn't freed up from the first launch attempt, plus a dllhost32 continues to loop following this.

I did some research and it appears this has been a problem in the past, not just with TR, but with older games in general. I saw multiple posts online stating the same symptoms of having to run games twice or having to kill processes. Then I noticed people mentioning something about the "games explorer" in Windows 7, a feature I totally forgot existed and never use. Some people were claiming that the reason why a game doesn't launch the first time, could be due to the options that have been set in the games explorer in which it tries to obtain game info from the internet and, if there is no active internet connection, the game you want to launch will fail to do so. But this cannot be the sole reason as I have an active connection 95% of the time, and this has only become an issue in the last week or so.

I'm stumped with this one.

fallenangle 19-06-19 15:16

Windows 7 (64bit) too.

As this behaviour for me is very new my immediately thought was actually not TR but that either it was something in the MS monthly updates I'd installed a couple of weeks ago. I too have those turned off but unless they are identified as snooping or telemetry gathering I, usually, install them later manually.

But whatever this is it is unique to my TR5 installation.

Interesting that you mention Game Explorer I think that by default Win7 installed games are added to the: "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Games" folder and launched from there using shortcuts.

I now think it maybe a Games Explorer issue: I normally use a Start Menu shortcut to access that folder but I've found if I launch Games Explorer from Win7 Start > Games (right side menu) between Music and Computer the CPU shows Windows Explorer use goes up to 60% and stays there. Even if you exit the folder the CPU use does not drop.

I checked Task Manager and there are two explorer.exe instances, presumably the second is actually the Games Explorer. It showed the process as using 55% - 60% so I ended the task and everything went back to normal. Retried Start > Games and the problem repeats.

This is the problem EXE name/location (probably Games Explorer):-

C:\Windows\explorer.exe /factory,{ceff45ee-c862-41de-aee2-a022c81eda92} -Embedding File

and this is the main Windows Explorer EXE


They are both shown as running process in Task Manager. As said if I terminate the first instances the CPU use drops back from almost 100% to normal. It is the clearly the culprit.

But if this is some Games Explorer issue why is it not affecting other games in that folder?


mizuno_suisei 20-06-19 02:57

I have trouble with older no CD exes on my Windows 10 (since the big upgrade last year) some just dont open like you're experiencing or some just appear with a CD check!?

Anyway I suggest you get your hands on a gog pctomb5.exe, or a quick Google to find out how to hex edit the most current win10 TR5 patch to be no CD. It's very simple.

I also have to open with Application high DPI and always open as administrator set on the file
properties. File directory must also be set to have "Everyone" security permissions with no restrictions. If you have resolution restrictions when setting up pctomb5, (sometimes it maxes at 1280x720), rename to something else like tomb5.exe and you'll be able to choose bigger resolutions. I dunno why renaming fixes it..works for tr234 aswell.

That's the prerequisits I find work best when reinstalling a classic tr, I coincidentally installed TRC just a few days ago and did all the above. It's running beautifully

Ceamonks890 20-06-19 04:27

I started up a custom level and this exact issue happened to me for the first time.

Thankfully, there's been an unofficial fix for this random nonsense available for some time now, that seemingly resolves the issue permanently. Might give it a shot- https://answers.microsoft.com/en-us/...?page=2&auth=1

EDIT: Nope, that didn't work. What on earth did Microsoft do without my knowledge recently, to suddenly have this random issue pop up? I've had Windows Update disabled since the whole unwanted forced Windows 10 install debacle. So the only logical explanation for this sudden bug, would be through updating Windows Defender as that has been the only program I've been continuing to update. God, I hope someone finds a solution for this soon as I want to continue playing my games without having to deal with this 100% CPU issue :(

TheLostSecret 20-06-19 06:51

Change the name of the executable
It always happens for me, even with custom games.... I found the solution in changing the name of the executable to something different only for custom games and that seemed to solve the issue. However, I'm not sure whether you can do it with official games or not.

On my side, whenever I want to launch an official game on my Windows 7 ( x64 ), I'll first launch it, then I'll end the process using Task Manager, and I'll run the game again. It will work, without the overuse of CPU. :D

Ceamonks890 20-06-19 08:40

I managed to fix the problem! Downloaded this completely safe .bat file from this link provided through an internet blog and ran it as admin(which you have to do in order to get it working, completely disabling the pointless Game Explorer/rundll32 exe file permanently). The .bat file is programmed to automatically detect which version of Windows you're using by the way. So just run it as admin, click any key and its done.

Now every custom level and no doubt official game boots up the first time reliably for me now without pushing the CPU to 100%:D


fallenangle 20-06-19 11:43

Permanently disabling Games Explorer, which is what that .BAT file appears to do, sounds a bit drastic. So I'll consider it as a last resort. Thanks for the link info, suggestion and tool.

I've been doing some more research on this and the explanation, in this case, for this, an apparently 'sudden' behaviour change, may be that a .DLL which Game Explorer is trying to launch has become corrupted.

The idea about this, not from me, comes from the fact that it has been reported that certain corrupted but non-critical .WAV or other .DLLfiles in programs can cause Windows Explorer to go into an infinite launch loop. It tries to launch them can't and then tries again and again causing the quick rise to 100% CPU use. The suggestion is because they're non-critical the program actually boots OK but is accompanied by this high CPU use.

It sounds plausible and even the fact that launching Games Explorer from the Start menu results in the same thing could be explained by application prefetching/superfetching. On launch Games Explorer is pre-caching or has already pre-cached files from the entire Games folder which includes a corrupted .DLL from one particular game. It then goes into this infinite launch loop with the same result.

It could also explain why other games in the same folder are launched without the problem. I launch all my games from the Start Menu > Games folder not by using "Games" in the side menu. I'm therefore launching each game directly via a shortcut to its .EXE so Games Explorer is not involved or only pre-fetches/super-fetches for that game.

This is little more than extended guesswork. But what it does suggest is that the problem could be just in the TR5 installation and the most sensible way of testing that is to uninstall/reinstall it and see if that fixes the problem. :)


Tried uninstalling/reinstalling TR5. Obviously once uninstalled I tested the Win7 "Games" menu link in the hope it was just a TR5 issue.............and the damned thing went up to 90% so I was not expecting that to change when I reinstalled TR5. What I was hoping is that it wouldn't do the same thing when launching TR5.......but it did.

It also triggered the problem when launched from the disc rather than the no-CD install I use but that is not surprising as the the PCTomb5.exe is installed in "Games" folder.

So this is definitely some sort of Games Explorer issue not directly related to TR5 but why TR5 is only only TR game that triggers it when all the rest are in the same directory and launched in the same way I can not even begin to speculate.

Looks like I'll have to run that .bat file to disable Games Explorer to get it sorted.

fallenangle 25-06-19 11:56

Just to confirm that I've run the .bat file Ceamonks890 provided/linked to and thank him for that as does it appear to have fixed the problem completely. I was a bit skeptical that it would but it has. :)

Games Explorer can now be launched without the CPU use going mental and TR5 launches first time without provoking the same thing.

I'd still like to understand what the .bat file actually does and, if anyone here can offer an explanation, as to why, AFAIK, TR5 was the only game I have installed which triggered the problem?

Could it be because, despite its age, it is the most recent game I have installed and it does something older games (TR1 - TR4) do not do?

But that also raises the question as to why when TR5 was thoroughly uninstalled (using the ever reliable Revo Uninmstaller) Games Explorer when launched directly still caused the CPU use to go mad.

I may simply have not noticed before as I rarely launch games, including MS ones from "Games", and have not always used Resource Hacker 2 to monitor CPU use. But I think in the three and a half years since I clean installed the Windows OS on a newly built PC I would have noticed such extreme CPU use before now if it had been happening from day one.

If it was not are there any ideas about what might have triggered this issue later?

Finding information about this particular problem was quite difficult even though it has clearly been known about for some time. This does suggest it did develop later ie. something broke Games Explorer after installation but what?


Apparently the whole problem is not an OS problem at all, it is Microsoft, yet again, recently removing services as explained in this thread:-


I thought it very strange I had not noticed the 'problem' before and now I know there actually hadn't been a problem until MS made it one. :p

BTW the link in the OP at that forum to the MS 'announcement' is broken.

laravision 11-07-19 18:20

Fallenangle, thank you for updating your latest post with new information. Thanks to Ceamonks890 as well. Hopefully this issue can be put to rest now.

All times are GMT. The time now is 02:39.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.