Tomb Raider Forums

Tomb Raider Forums (https://www.tombraiderforums.com/index.php)
-   Tomb Raider Next Generation (https://www.tombraiderforums.com/forumdisplay.php?f=40)
-   -   TRNG - Bugs & Limitations Thread (https://www.tombraiderforums.com/showthread.php?t=165980)

igor32 26-12-11 23:21

Contidion gone crazy.

I have a contidion in my trigger group to activate things only after the enemy is dead, It worked nice until minutes ago, I only changed the script in the last boss, but it seems to have "affected" the first one:

Quote:

Organizer= 1, ignore, ignore, 1, 3, 4, 4
TriggerGroup= 3, $5000, 908, $2B ; Enable Hydra
TriggerGroup= 4, $2000, 109, $101 ; Perform GT
GlobalTrigger= 1, FGT_SINGLE_SHOT_RESUMED+ FGT_DISABLED, GT_CONDITION_GROUP, IGNORE, 1, 2, ignore
TriggerGroup= 1, $9000, 908, $E ;hydra dead
TriggerGroup= 2,$5000, 1070, $11A ;open door
What happens, I pickup, it triggers the organizer, activate the boss, but seconds after, the door that was supposed to only open after it is death, open and my weapons are removed and the key "action" is continuously pressed (like if I draw a weapon it keep shooting) :mad: :hea:

TrueRaider 28-12-11 20:03

Snow

This is an old bug which used to apply to rain but I don't think it was fixed for snow. Several TRNG versions ago, for it to rain you had to have at least 2 rooms stacked and have the sky texture in view at all times. Whenever the sky went out of camera shot, the rain would stop. This caused problems in stacked rooms that were narrow as it only rained when you looked upwards. It was, however, fixed and now works perfecty. But with snow I encounter this old problem using the newest version of TRNG. Is there a chance it could be fixed, or is there something I should do about it?

Raymond 28-12-11 20:30

@igor32
How do you want to know, that "conditions gone crazy"? What did you do to verify it?
Better check for errors in your script or level.
@TrueRaider
No chance for a fix. Better do a good geometry to reduce the problem. You`ll have to live with it.

dcw123 13-01-12 19:24

EDIT: *whispers awkwardly* Ooops, sorry..

Titak 13-01-12 19:25

Please post in the regular TRNG section by either making a new thread or posting in the genral TRNG chat level.

This particular thread is for reporting bugs only, not for asking questions. ;)

Bogey 18-01-12 10:55

Lara uncontrollable due to wrong process priority
 
I have encountered two levels in which Lara cannot be controlled because key strokes are not executed immediately, but are buffered up and executed some moments later. The levels are Greece Artifact by TheTiger and Mists of Avalon by Titak. In both cases the base priority of the tomb4.exe process is high (13). Lowering the base priority of this process will make Lara controllable, but as soon as a savegame is loaded, the base priority is raised again. When I played TheTiger's level, I used a shell script that lowered the base priority to idle (4) once per second. This made the level perfectly playable, except that flybys froze momentarily once per second due to the shell script. Titak supplied a note with her level, suggesting to run the game in suitable compatibility mode. I tried Windows 98 compatibility and the problem disappeared, and the base priority of the tomb4.exe went down to normal (8) as well. This also worked for TheTiger's level.

My computer is an old XP notebook with a Celeron CPU, but other players have reported similar problems on systems with powerful quadcore processors and other operating systems. I have also tried the levels on an Atom powered netbook with Windows 7 Starter. There is no problem to control Lara on this machine, even though the base priority of tomb4.exe is still high (13). The heavy graphics of Titak's level is too much for the netbook, though, so the frame rate is rather bad. At first, I thought that the netbook could cope with the high process priority because the Atom processor has two cores, but as I said, the problem does occur on quadcore machines too. On my XP computer, I have also tried to manually raise the base priority of the tomb4.exe process for some normal TRNG games, and then the problem to control Lara appears also in those games. Thus, there is a strong connection between the base priority of the tomb4.exe process and the controllability of Lara.

Somehow, it seems that some input related thread or process is starved when the base priority of the tomb4 process is high, but I'm quite puzzled about how it happens and why it happens on some computers but not on others. The behaviour is triggered by something in the script. I tried to replace the script.dat in TheTiger's level with another script, and the controllability problem disappeared and the base priority went down to normal. Naturally, the level wasn't playable with the wrong script.dat, the first issue being that the new moves didn't execute, even though they were superficially the same in both levels.

Even though I don't really know what is going on here, I think that the high priority of tomb4.exe is a bug. As Microsoft writes: "The high-priority class should be reserved for threads that must respond to time-critical events ... a high-priority thread should execute for a brief time, and only when it has time-critical work to perform." If the base priority of tomb4.exe is high, some threads will probably violate this rule.

Although, there seems to be a simple workaround, i.e. running tomb4.exe in compatibility mode, it would be better to fix the bug if possible, as otherwise players will need to be informed about workaround, and players do not always read the documentation. I don't know whether the bug is TRNG itself or in the scripts, and since I have never tried to learn how build levels using TRNG, I have no idea of where to look for it. Hopefully, some TRNG guru here could provide some insights into this problem. Sorry for the long post.

BTW, both games are very nice. Mists of Avalon is simply breathtaking.

Bogey

kaufi-lc 20-01-12 11:50

I'm currently having some trouble with Animations. I want Lara to perform a certain Animation for a Cutscene but she will only do the first frame of the Animation :confused:
Framerate is set to 2 and the Animation has about 160 Frames.
I remember having Animations with much more Frames and they worked perfectly. Anybody else ever had this problem?

Raymond 20-01-12 13:42

No idea, but this is the wrong thread for your question. This is the thread for verified bugs.
So open an own thread for the question and then we`ll (hopefully) clarify, what´s going on.
@bogey
Thanks! I`ll bring this to the attention of Paolone. This can take some time.

Bogey 21-01-12 10:24

Thanks Raymond!

Since there are workarounds, it is not so urgent.

/Bogey

Bogey 30-01-12 11:29

Thanks to an old post by Taras in a recently bumped thread at trle.net, I think that
I may have found the culprit that makes Mists of Avalon and Greece Artifact unplayable
on some systems (unless tomb4.exe is run in a suitable compatibility mode).

In TRNG, there is a new script command "Turbo" with various optimization flags.
One of these is TRB_HIGH_PRIORITY. I have verified that it causes problems controlling
Lara. In general, it will not have any positive effect. It will only improve performance if
there is some other process competing for the CPU, and then it is better that the
player stops that process (or possibly lowers its priority or suspends it).
Anyway, if players really want to increase the priority of the tomb4 process, they can
easily do so with the task manager. Thus, I would like to urge builders not to use the
optimization flag TRB_HIGH_PRIORITY, and I think that it should be removed from TRNG.

It would be interesting to know if this optimization was indeed used in
Mists of Avalon and Greece Artifact, so the case can be closed.

Regards,

Bogey


All times are GMT. The time now is 23:53.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
Tomb Raider Forums is not owned or operated by CDE Entertainment Ltd.
Lara Croft and Tomb Raider are trademarks of CDE Entertainment Ltd.