www.tombraiderforums.com (https://www.tombraiderforums.com/index.php)
-   Tomb Raider Anniversary (https://www.tombraiderforums.com/forumdisplay.php?f=27)
-   -   4K gameplay with the Trilogy (PS3) version (https://www.tombraiderforums.com/showthread.php?t=219120)

GFY2013 19-04-20 20:06


Originally Posted by GFY2013 (Post 8187466)
From what I've seen in Anniversary the hair is kinda broken, but only in cutscenes. I still haven't checked to see those blocks in Underworld, but some effects are sped up. (Like here in Jan Mayen the falling snow things. (not the falling snow outside of Jan Mayen, but some particles))


Originally Posted by Wooxman (Post 8188809)
Can you check if it works normally at 85 FPS? That number may sound arbitrary, but the PC versions actually work fine at that frame rate, probably because 85Hz was pretty common for CRT monitors, so the games would run at 85 FPS on a CRT with v-sync activated.

Okay so I checked and also recorded it. It was running at around 90-140fps, the blocks were manageable. They were a little bit glitchy, but they didn't break the game at all.

(i spammed some buttons to see if I can glitch it out)

Wooxman 19-04-20 23:42

Nice, thank you, GFY2013! :) Yeah, the stones slide around more than they should but it's much better than when I tried to play the PC version with an uncapped frame rate (although I can't remember on what frame rate the glitches were the worst, though I probably had well over 100 FPS). When you threw the grenade and the frame rate dropped to 85-90, they behaved exactly the way they should, so that's probably the limit for that version of the engine.

AimlessThunder 20-04-20 01:44


Originally Posted by GFY2013 (Post 8186405)
PC and the X360 versions are almost the same: X360 has the water effects and some more shadows. The PS3 version I think has specular maps as well (at least on Lara?), also it has a slightly higher res Lara model. (note at https://youtu.be/Ec2pjClT5CA 1:42 her shoulders and backpack, but its noticeable on her ears too)

I don't know, I just prefer the PS3 version cause it looks nicer to me. :) Imo PC looks the worst, to me anyway.


yaron 25-04-20 18:03

Wait. I didn't get it.. is it for the PC?
and how can I get it?

ian2006 26-04-20 18:54


Originally Posted by yaron (Post 8190629)
Wait. I didn't get it.. is it for the PC?
and how can I get it?

You need the PS3 emulator called RPCS3 and a legal backup of the Tomb Raider Trilogy.

GFY2013 02-05-20 10:56

There is a new shader option in the GPU tab settings.
Recommended value is either Async with shader interpreter, or Async if you don't want to use this new feature yet.

What this does is:
"...shader interpreters to take over for the normal rendering pipeline when no shader is available and the compiler has yet to finish generating one. In this case, the interpreter is invoked to render the missing graphics while the compilation is ongoing in the background.
[...] Performance is not the best, although recent optimizations have made the interpreters viable to begin with. I am working on this, but it requires some re-structuring of the rpcs3 code before this code can be added in."
from developer kd-11 on GitHub.

I haven't thoroughly tested it yet. I'll report back how it is.

GFY2013 28-07-20 13:40

Let me bump this thread again with some TRA graphics comparisons between RPCS3 and Xenia :p

(open the images in new tab to see them in fullres)

Performance is still pretty bad on Xenia unfortunately, and still won't go in-game. (Except for the Manor.) TRU works the same just as before. :/

RPCS3 however improved again, in TRA big areas now run above 60fps in 4K! My title screen FPS also jumped to 120fps. These improvements show in TRU as well. (I might upload a 4K60 video montage :) )
Also NOTE: before Relaxed ZCULL sync setting didn't cause any performance penalties, now it does, so if you have it enabled turn it off in the advanced tab.

Unfortunately there is a regression in Legend though: whenever I try to upscale the resolution, the game won't even make it to the menus, with an error message in the logs: out of memory. (This happens when you set the upscaling too high. But it worked before at 2K-4K res). I should be looking into this more, and find out which PR caused the regression, and open up an issue on GitHub. EDIT: ok the problem was with my resolution scale threshold.

Legend running at 4K 55fps.

All times are GMT. The time now is 18:06.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.