View Single Post
Old 29-12-18, 03:59   #412
dgo6
Hobbyist
 
Join Date: Dec 2018
Posts: 3
Default FMV Playback Problems

Hey guys, I have the exact same problem as Trap_One3. I believe I’ve tried all the listed solutions both in Steam forums and Peixoto’s Help application. I even tried downloading the K-lite codec pack to play around with the H.264 settings and changed the “Use Merit” to “LAV Video” on both x32 and x64 (alternating them and both on the same option). I tried turning off antialiasing from Nvidia’s control panel but to no avail. I also tried pasting both the .bik and .mp4 files in the FMV at the same time but still got a black screen. I also tried different combinations of the Help application options and playing around with the scaling but was still met with a black screen. I also just updated the graphics driver. (The .rpl files are still in the FMV folder. I haven't removed them.)

The game seems to run perfectly fine as far as gameplay is concerned. It’s just the high quality FMVs that do not run. For some reason I can only hear the LOGO FMV sound and occasionally the ANCIENT FMV sound (I haven’t pinpointed why it sometimes pops up). The following are my specs and the CMD like log that appears when running the Help application for TR2. Let me know if you need anything else. Any help is greatly appreciated!


Quote:
Specs:

OS: Windows 7
Processor: Intel Core i7
Video Card: Nvidia GeForce GTX 1080
Native Res: 4k

SYSTEM:
Operating System: Windows 10 Pro 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
BIOS: 2202 (type: UEFI)
Processor: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
Memory: 16384MB RAM
Available OS Memory: 16312MB RAM
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 216 DPI (225 percent)
System DPI Setting: 144 DPI (150 percent)
DWM DPI Scaling: Enabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported

GRAPHICS
Card name: NVIDIA GeForce GTX 1080
DAC type: Integrated RAMDAC
Device Type: Full Device (POST)
Display Memory: 16234 MB
Dedicated Memory: 8079 MB
Shared Memory: 8155 MB
Current Mode: 3840 x 2160 (32 bit) (60Hz)
HDR Support: Not Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Monitor Name: Generic PnP Monitor
Monitor Model: ROG PG27AQ
Monitor Id: ACI27B3
Native Mode: 3840 x 2160(p) (59.997Hz)
Output Type: Displayport External
Monitor Capabilities: HDR Not Supported
Display Pixel Format: DISPLAYCONFIG_PIXELFORMAT_32BPP
Advanced Color: Not Supported
Power P-states: Not Supported
Virtualization: Paravirtualization
Block List: No Blocks
Catalog Attributes: Universal:False Declarative:False
Driver Attributes: Final Retail
Driver Date/Size: 12/10/2018 6:00:00 PM, 957800 bytes

Quote:
CMD-like log while the game is running and is at the title screen:

900
65536 2147418111
65536 2147418111
900
Peixotos's patch remote settings:
#args: setup
32bit: 1
;compatlayer: WinXPSP2
AF: 1
CompatLayer: HIGHDPIAWARE
D3D: 2
D3D_Driver: C:\WINDOWS\System32\DriverStore\FileRepository\nv_ dispi.inf_amd64_e7b3660b4830c245\nvldumd.dll
dshow: 1
error_log: D:\Users\Diego\Desktop\Peixoto\error.log
FMV: 1
GPad: A=1;B=2;X=3;Y=4;LEFT_SHOULDER=5;RIGHT_SHOULDER=6;b LeftTrigger=7;bRightTrigger=8;Start=9;Back=10;LEFT _THUMB=11;RIGHT_THUMB=12;deadzone=0.000000;
HBdr: 1
injector_dir: D:\Users\Diego\Desktop\Peixoto
J2K: u=False;a=Up,Down,Left,Right,end,alt,space,ctrl,de l,PgDn,shift,numpad0,esc,/,8,9,Up,Down,Left,Right;dz=0.25;
max_4x3_res: 2048x1536
modspath: D:\Users\Diego\Documents\Games\TombRaider2\mods
Mydocs: D:\Users\Diego\Documents
os_version: 10.000000
resolutions_list: 640x480 720x480 720x576 800x600 1024x768 1152x864 1280x720 1280x768 1280x800 1280x960 1280x1024 1360x768 1366x768 1600x900 1600x1024 1600x1200 1680x1050 1920x1080 1920x1200 1920x1440 2048x1536 2560x1440 2560x1600 3840x2160
script: Scripts\Tomb2.ahk
script_hwnd: 0x2509d8
singlecore: 1
target: D:\Steam\steamapps\common\Tomb Raider (II)\Tomb2.exe
target_dir: D:\Steam\steamapps\common\Tomb Raider (II)
target_name: Tomb2.exe
Textswap: path=Tomb2Fix\textures;samples=4;thumbnail=256;Nex t=];Prev=[;dump=p;Switch=i;color_switch=o;mips=0;Quick=;

CreateProcessA Hook: 0
CreateProcessW Hook: 0
Desktop 3840x2160
Direct3D user mode driver implemented in C:\WINDOWS\System32\DriverStore\FileRepository\nv_ dispi.inf_amd64_e7b3660b4830c245\nvldumd.dll
OpenAdapter Hook 0
DDraw.dll : C:\WINDOWS\SYSTEM32\DDRAW.dll
DirectDrawCreate Hook: 0
IDirectDraw2: 0:DDERR_OK
IDirectDraw4: 0:DDERR_OK
CoopLevel: 0:DDERR_OK
Surface4: 0:DDERR_OK
Surface3: 0:DDERR_OK
Surface2: 0:DDERR_OK
Surface: 0:DDERR_OK
Succeeded to create DirectDraw
Direct3D: 0:DDERR_OK
ViewPort: 0:DDERR_OK
Texture: 0:DDERR_OK
Direct3D2: 0:DDERR_OK
ViewPort2: 0:D3DERR_OK
Texture2: 0:DDERR_OK
Direct3D3: 0:DDERR_OK
ViewPort3: 0:D3DERR_OK
VertexBuffer: 0:D3DERR_OK
Device3: 0:DDERR_OK
IDirect3DDevice2: 0:DDERR_OK
Device: 0:DDERR_OK
Exec Buffer: 0:D3DERR_OK
Succeeded to create Direct3D
Succeeded to hook IDirectDraw2::CreateSurface
Succeeded to hook IDirectDraw::CreateSurface
Succeeded to hook IDirectDrawSurface::restore
Succeeded to hook IDirect3DDevice2::EndScene
Succeeded to hook IDirect3D2::CreateDevice
Succeeded to hook IDirectDrawSurface::Blt
Succeeded to hook IDirectDrawSurface::Lock
Succeeded to hook IDirectDrawSurface::UnLock
Succeeded to hook IDirect3DTexture2::GetHandle
Succeeded to hook IDirect3DTexture2::Release
Succeeded to hook IDirect3DTexture2::Load
Succeeded to hook IDirect3DDevice2::SetRenderState
Succeeded to hook IDirectDraw::SetDisplayMode
Succeeded to hook IDirectDraw2::SetDisplayMode
Succeeded to hook IDirectDrawSurface::flip
Succeeded to hook IDirectDraw::GetDisplayMode
Succeeded to hook IDirectDrawSurface::QueryInterface
Succeeded to hook IDirectDrawSurface::GetPixelFormat
Succeeded to hook IDirectDrawSurface::GetSurfaceDesc
Succeeded to hook IDirectDrawSurface::GetDC
Succeeded to hook IDirectDrawSurface::ReleaseDC
Succeeded to hook IDirectDrawSurface::SetPalette
Succeeded to hook IDirectDrawPalette::SetEntries
Succeeded to hook IDirectDrawPalette::GetEntries
Succeeded to unhook IDirectDrawSurface::Lock
Succeeded to unhook IDirectDrawSurface::UnLock
Succeeded to hook IDirectDrawSurface::Lock
Succeeded to hook IDirectDrawSurface::UnLock
Succeeded to hook IDirectDrawSurface::Bltfast
Succeeded to hook IDirectDraw::SetCooperativeLevel
Succeeded to hook IDirectDraw2::SetCooperativeLevel
FileHooks 0
CreateFileA_Hook Hook : 0 <- 0 means no error
OpenFile: 0
Succeeded to hook IDirect3DDevice2::DrawPrimitive
IDirectDrawSurface::QueryInterface is already hooked
Method BeginScene is not hooked yet
Succeeded to hook IDirect3DDevice2::BeginScene
161:161:184
228:228:64
42:42:11
75:75:0
0:0:0
153:153:153
arrays 0xA1 0xA1
arrays 0xE4 0xE4
arrays 0x2A 0x2A
arrays 0x4B 0x4B
arrays 0x0 0x0
arrays 0x99 0x99
arrays 0xDB 0xDB
arrays 0x5 0x5
arrays 0xE4 0xE4
arrays 0x2A 0x2A
arrays 0x4B 0x4B
arrays 0x0 0x0
dgo6 is offline   Reply With Quote