View Single Post
Old 08-09-21, 17:34   #1
Join Date: Aug 2002
Location: Oklahoma City, Ok USA
Posts: 5
Default Inconsistent frame pacing in TR1

Hello everyone!
Been struggling to nail down this problem on and off for the last year and a half. Now that I've duplicated the issue on three separate machines I figured I'd start posting online to see if anyone has an idea.

Old retired desktop:
Windows 10
Intel i5 4960k
Nvidia GTX 970

Fancy desktop:
Windows 10
Intel 10700k
Nvidia GTX 970 (same gpu as above build)

Mid-range laptop:
Windows 10
Intel i5 (don't have model memorized; I'll go look if relevant)

I have experienced this problem with both the 'Automated Fix' and the 'Tomb Raider Retail Fix' that are outlined on

In most cases, the game runs okay at first. Smooth and even 30 FPS; feels great. Next thing I know, it starts hitching as I pan the camera around or turn Lara. I finally realized that this is not completely random. I can trigger bad frame pacing by picking up an item, using an item on a trigger (like the gears in lost valley), sometimes by entering the pause menu, and sometimes by entering the pause menu and then pressing up/down to view inventory or options. When bad pacing is introduced, I can usually just pause/unpause, but like the previous sentence, sometimes I have to go up or down to one of the sub-menus.

I've distinctly noticed that the screen flickers (a single frame of solid black) when navigating the up/down menus in the pause screen, and I think this directly correlates with getting the game to sync back up with the display/gpu.

I've tried getting some analytics on performance with tools like RTSS, but I'm convinced that whatever data it shows is not relevant to the actual game. Like, it's weird, but I strongly suspect that there's some kind of dual video overlay or compositing -which goes back to that bit about the screen flashing for a second in the pause menu. For this, I don't think RTSS is giving me good frametime data in the graph I'm looking at. Maybe it has something to do with the marriage of DosBox, this old game, and the mods we're using to update it.

I have since learned that setting my display's refresh rate to 30hz helps a LOT. At 60hz, nothing I do seems to affect or fix pacing; it's just trash all around. At 30hz, at least I can fiddle with the pause menu every 5 or 10 minutes to get it running smoothly again.

If I use RTSS to lock the framerate to 30, the graph smooths out completely -but in reality it looks like every. single. frame. is out of pace.

I've also noticed that regardless of any settings I try to apply to the glrage.ini file, it must not be possible to achieve exclusive fullscreen mode, only what looks like fullscreen borderless -and I wonder if figuring this out might be a way to solve my problem.

So those are all the details I can think of, and I really really hope someone has an idea. In any case, I've been a long time lurker and this community is the bee's knees!
Ghaleon4 is offline   Reply With Quote