View Single Post
Old 27-01-22, 19:38   #4
Join Date: Dec 2019
Posts: 12

Cheers for the reply.

So I went back and tested out the theory of disabling vsync in the GPU profile of TombATI.exe and it results in choppy 30FPS and tanked after 10mins instead of around 30mins.

I also disabled everything in the GPU profile of TombATI and still it tanked 10mins later, really strange. When you activate GPU profile vsync, it looks like 60FPS even though its rendering 30FPS, so strange indeed.

What I did was allocate a UseLargePages 1 hex to TombATI and it played the game brilliantly, no stutter when the music plays, no stutter what so ever, played epic for 1hour 20 mins, all I did was look up in a small room in Atlanta from testing and all of a sudden it tanked just stood there looking up at a ceiling.

I also increased/decreased the global view distance in the settings but no luck.

Tested this all running in 4k because using the default Automated patch settings the GPU seems to downclock on low resolutions and that was my initial theory. Also bumped up the shader AA settings x128, basically in the background the textures were too pixelated, to a point where it looked like noise on ground textures. This prevents the GPU from downclocking but still again tanks.

Seems from testing, most of the time the FPS tanks sooner in areas with water/lava or alternating textures. Example the first river section, FPS dropped instantly, had to save, quit and restart the game to get the FPS back to normal.

Would be great if the TombATI source code was available, seen a mod online which has reverse engineered TombATI and these edits sound interesting.
Changed internal game memory limit from 3.5 MB to 16 MB
Changed moveable limit from 256 to 10240
Changed maximum textures from 2048 to 8192
Changed maximum texture pages from 32 to 128

I wonder if these updates could be allocated on the Automated patch version of TombATI? I believe that would fix the issues here, its a memory issue.

TR800 is offline   Reply With Quote