View Single Post
Old 07-04-11, 16:16   #108
gidierre
Grease Monkey
 
gidierre's Avatar
 
Join Date: Nov 2007
Posts: 1,554
Default workaround for Ati/Amd cards

I guess it's good to sum up info and some advice for owners of latest ATI(AMD) Radeon gfx cards, whose Catalyst Control Center has come to miss the option to tweak the depth buffer, so recreating the nasty well known depth artifacts issue
this can be worked out via a couple of simple things to do to play without too many glitches, like with GeForce and Intel cards
the bottom line: scroll down to.. the bottom line to skip the annoying details
this is continuing from this earlier post of mine about Radeon HD 5470
http://www.tombraiderforums.com/show...9&postcount=74
I've just had another laptop to test, an Asus this time (Intel Core i5 CPU @2.67GHz , Win7 Home Premium 64bit, AMD Radeon HD 6370M)

Catalyst Panel (3D tab/ OpenGL settings) has no Force z-buffer depth entry, depth artifacts consistently reproduce what I already showed in post #74
in the Registry btw there are multiple keys such as
Quote:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Cl ass\{.....}\0000\UMD\"ForceZBufferDepth"=hex:30,00 ,00,00
I started tweaking them far and wide, no luck, option stays disabled

Workaround:
use the alternate glide wrapper dll provided by the freeware nGlide
once installed, no more artifacts

there's a big con though here concerning anti-aliasing with nGlide (and with other wrappers too): you can toggle that on/off ingame (hotkey=F3) but neither is good

on one side you can put up with having all the jagged contours of gunshots etc., but the issue looms way larger than that, it sometimes/someplaces creates pretty funny outlandish geometric patterns all around the scenery like:


which is imho very disturbing as much as the depth fiasco would be

or else you get rid of it all but then fall back to the other side of it, like shown in following screen



and consider that this still frame I've chosen delivers much less than actually meets the eye as with every movement the glitch is keenly enhanced

so it's a matter of either getting a glut of absurd lines all around the place or a deluge of "holes" in texture seams

Workaround:
forget F3 (toggle it so that the uncanny lines disappear anyway) and to eliminate the second screenshot's disturbance, open CCC
see
http://www.pcgameshardware.com/aid,6...ail/Knowledge/
although this example I found applies to an older driver version, go to your 3D standard settings:
standard antialiasing settings, pull slider all the way to the right for maximum/optimal quality (vs. performance), voilą it's all going well

Bottom line

Radeon users of the 5XXX, 6XXX series or whatever (and only these, since nVidia and Intel cards don't seem to need anything of this):
use nGlide dll, then change AA settings in CCC

you'll have no depth artifacts, and also no antialiasing bloopers in either direction
you can have a good visual experience even as you're a happy (?) Radeon user fighting to emulate the TRI 3dfx/glide gameplay look
HTH
__________________
We often forgive those who bore us--we cannot forgive those who find us boring.

Last edited by gidierre; 31-07-14 at 21:20.
gidierre is offline   Reply With Quote