View Single Post
Old 01-03-21, 20:56   #3
Sat42's Avatar
Join Date: Aug 2017
Posts: 29

Originally Posted by CircusBabysGal View Post
I'm afraid there isn't a fix yet, the FMV's are generally quite weird when you run them on modern hardware, as an example it's weird when I play the game in my native resolution but when an FMV sequence plays in TR1-TR5 the window turns really small like 366x400 something probably.
That would be a shame!
Strange also that FMVs in TR1-2-3 work perfectly by comparison, it's really just with TR4 that I have this problem.

I tried dumb stuff like downloading dgvoodoo2_73, extracting D3DImm.dll and DDraw.dll (only available for x86 apparently and I have x64) and putting them in the installation folder for TR4: that does mean perfect playback of the FMVs (no glitch yay) but while I can move Lara around if I press escape or P for the menus the game freezes (also textures seems way more pixellated)

I have to elaborate a bit now that I have the time: I found this thread on GOG that is where I got the idea for using dgvoodoo2 which in fairness I have used before for games like MDK or POD.
If I add the dgvoodooCPL and config file than I can get bilinear or trilinear filtering for textures etc. that is not a problem.
The D3DImm.dll and DDraw.dll being listed under x86 just means they're for 32 bit games which TR4 is.
The real problem is that, while using the above completely fixes any visual glitch in the FMVs, I cannot open the inventory or main menu in-game - pressing the Escape button or P just freezes the whole program, I tried compatibility with XP and Windows 98 but still it doesn't solve the problem.
EDIT2: using Glide instead just makes the game playable like it was with the default GOG install, complete with glitches in the FMVs!

Last edited by Sat42; 02-03-21 at 10:16.
Sat42 is offline   Reply With Quote