View Single Post
Old 20-06-19, 11:43   #8
fallenangle
Archaeologist
 
fallenangle's Avatar
 
Join Date: Apr 2006
Location: NW London
Posts: 1,824
Default

Permanently disabling Games Explorer, which is what that .BAT file appears to do, sounds a bit drastic. So I'll consider it as a last resort. Thanks for the link info, suggestion and tool.

I've been doing some more research on this and the explanation, in this case, for this, an apparently 'sudden' behaviour change, may be that a .DLL which Game Explorer is trying to launch has become corrupted.

The idea about this, not from me, comes from the fact that it has been reported that certain corrupted but non-critical .WAV or other .DLLfiles in programs can cause Windows Explorer to go into an infinite launch loop. It tries to launch them can't and then tries again and again causing the quick rise to 100% CPU use. The suggestion is because they're non-critical the program actually boots OK but is accompanied by this high CPU use.

It sounds plausible and even the fact that launching Games Explorer from the Start menu results in the same thing could be explained by application prefetching/superfetching. On launch Games Explorer is pre-caching or has already pre-cached files from the entire Games folder which includes a corrupted .DLL from one particular game. It then goes into this infinite launch loop with the same result.

It could also explain why other games in the same folder are launched without the problem. I launch all my games from the Start Menu > Games folder not by using "Games" in the side menu. I'm therefore launching each game directly via a shortcut to its .EXE so Games Explorer is not involved or only pre-fetches/super-fetches for that game.

This is little more than extended guesswork. But what it does suggest is that the problem could be just in the TR5 installation and the most sensible way of testing that is to uninstall/reinstall it and see if that fixes the problem.

EDIT

Tried uninstalling/reinstalling TR5. Obviously once uninstalled I tested the Win7 "Games" menu link in the hope it was just a TR5 issue.............and the damned thing went up to 90% so I was not expecting that to change when I reinstalled TR5. What I was hoping is that it wouldn't do the same thing when launching TR5.......but it did.

It also triggered the problem when launched from the disc rather than the no-CD install I use but that is not surprising as the the PCTomb5.exe is installed in "Games" folder.

So this is definitely some sort of Games Explorer issue not directly related to TR5 but why TR5 is only only TR game that triggers it when all the rest are in the same directory and launched in the same way I can not even begin to speculate.

Looks like I'll have to run that .bat file to disable Games Explorer to get it sorted.

Last edited by fallenangle; 24-06-19 at 14:52. Reason: Additional Info
fallenangle is online now   Reply With Quote