www.tombraiderforums.com

Go Back   www.tombraiderforums.com > Tomb Raider Modding > Tomb Raider Level Editor

Reply
 
Thread Tools
Old 19-10-19, 10:07   #19461
dinne
Archaeologist
 
dinne's Avatar
 
Join Date: Aug 2016
Location: Italia
Posts: 1,085
Default

How do I avoid that ugly effect on the logo and fonts, where you can see a "non-anti-aliased" black border?

It changes on/off depending on where the camera moves...
dinne is offline   Reply With Quote
Old 19-10-19, 11:20   #19462
LoreRaider
Archaeologist
 
LoreRaider's Avatar
 
Join Date: Jul 2016
Location: Italy
Posts: 1,196
Default

^it's a renderer bug I think
Do you have any Layer= script lines on the title? If so get rid of them
__________________
"Everybody lies, no exceptions."
LoreRaider is online now   Reply With Quote
Old 19-10-19, 14:11   #19463
dinne
Archaeologist
 
dinne's Avatar
 
Join Date: Aug 2016
Location: Italia
Posts: 1,085
Default

Quote:
Originally Posted by LoreRaider View Post
^it's a renderer bug I think
Do you have any Layer= script lines on the title? If so get rid of them
Perfect, as usual.
dinne is offline   Reply With Quote
Old 22-10-19, 21:57   #19464
dinne
Archaeologist
 
dinne's Avatar
 
Join Date: Aug 2016
Location: Italia
Posts: 1,085
Default

I have a chase in a wall where Lara is supposed to crawl into. She does, but when she crawls out (from back) slowly, and she grabs the ledge, she gets buggy and stands on her feet -inside- the crawlspace. It prevents her to exit...
It happened to me also other times, but I haven't figured out how to avoid it and what are the common structural cases when it happens... To avoid it always.
dinne is offline   Reply With Quote
Old 22-10-19, 23:27   #19465
Baslakor
Explorer
 
Baslakor's Avatar
 
Join Date: Jan 2006
Location: Somewhere, somehow
Posts: 919
Default

Does this happen every time or only in this particular chase?

If every time, could be something with your Lara animations. If only in this instance probably some error in the room.
Baslakor is offline   Reply With Quote
Old 22-10-19, 23:53   #19466
dinne
Archaeologist
 
dinne's Avatar
 
Join Date: Aug 2016
Location: Italia
Posts: 1,085
Default

Quote:
Originally Posted by Baslakor View Post
Does this happen every time or only in this particular chase?

If every time, could be something with your Lara animations. If only in this instance probably some error in the room.
Only in that chase... It's irregular because it's like a broken part, it's not a "squared" chase, maybe this is the why...
dinne is offline   Reply With Quote
Old 23-10-19, 00:04   #19467
Baslakor
Explorer
 
Baslakor's Avatar
 
Join Date: Jan 2006
Location: Somewhere, somehow
Posts: 919
Default

Try to adjust the shape a bit, maybe that should fix it.
Baslakor is offline   Reply With Quote
Old 23-10-19, 05:04   #19468
Mulf
Archaeologist
 
Mulf's Avatar
 
Join Date: May 2001
Location: Hamburg, Germany
Posts: 1,179
Default

"Chase" as used here has a specific technical sense in engineering; to avoid confusion it would have been better to simply call it a crawlspace, as that's the term commonly used in levelediting.

As to the problem itself: the irregular shape of the crawlspace may be a contributing factor, but I suspect that the core of the problem lies with faulty room connections. Check the elevation of the relevant rooms and see if they match up properly. Perhaps you raised or lowered some sectors after you've connected the rooms, resulting in such faulty connections.
Mulf is offline   Reply With Quote
Old 23-10-19, 07:03   #19469
Krystian
Explorer
 
Join Date: May 2010
Posts: 886
Default

My findings are that this bug of Lara teleporting back to the middle of the crawlspace happens most commonly with triangulated tiles. Don't ask me why, it's some weird engine fault that I haven't been able to track down yet.
The solution is "simple", though it imposes some limitations in terms of geometry, i.e. the slope has to be non-triangular. It can slope in any direction, it just can't be split in half
Krystian is offline   Reply With Quote
Old 23-10-19, 09:31   #19470
dinne
Archaeologist
 
dinne's Avatar
 
Join Date: Aug 2016
Location: Italia
Posts: 1,085
Default

Thanks a lot to everyone, yes the geomerty has tiles splitted in 2 triangles, and there are no faulty connections. I'll reshape it with these indications, thanks!!!
dinne is offline   Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 06:24.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.