www.tombraiderforums.com  

Go Back   www.tombraiderforums.com > Tomb Raider Modding > Tomb Raider Modding > XNALara

Reply
 
Thread Tools
Old 20-02-14, 13:35   #501
kingfisher13
Student
 
kingfisher13's Avatar
 
Join Date: Oct 2010
Posts: 106
Default

Howfie, yes, she is my girlfriend, lol.... I didn't think this would become such a big topic, besides, does it really matter? She's been trying to keep on the down low, she has a few stalkers from when she had a modeling page... please don't harass her, and please don't spread around the idea that I'm pretending to be a girl, that sort of thing can really damage someone's reputation, considering that is a social taboo.

As a matter of fact, me and her live together, hence the same IP address, computer issues, and anything else you might find similar when researching us XD

Anyway, I can't seem to shake the rigging issue... a friend, Alpha920, knows how to repair bone weights in the final mesh.ascii file, but I have no idea how to go about doing that..

Thanks for the info, adngel... I don't have any problems with the rig in 3ds max, its only once I export it into mesh.ascii format that the rig screws up.
kingfisher13 is offline   Reply With Quote
Old 20-02-14, 18:33   #502
howfie
Student
 
howfie's Avatar
 
Join Date: Apr 2012
Posts: 181
Default

oh ok lol, sorry then .
lemme remove that stuff.

btw, remember, mariokart's script, as he mentioned, doesn't do any validation checking, and if you have one thing enabled that shouldn't be enabled, your export goes bonkers. Let someone else see your model, like adngel, runa, or thepwa, who I know use Max, and let them see what's wrong. I've seen a few posts about his script giving a few weight errors, but nothing as bad as you've described.
howfie is offline   Reply With Quote
Old 20-02-14, 21:02   #503
king.neko212
Professor
 
king.neko212's Avatar
 
Join Date: Apr 2011
Location: why ? what are you going to do with me ?
Posts: 4,076
Default

I know that this is kinda off-topic but , @kingfisher13 : is your Girlfriend a volleyball player *-*
__________________
My diamond ring so bling bling.
king.neko212 is offline   Reply With Quote
Old 04-03-14, 20:07   #504
mariokart64n
Historian
 
mariokart64n's Avatar
 
Join Date: Jul 2006
Location: Ontario, Canada
Posts: 339
Default

hm? if someone could please just upload a max save where when you export it becomes bad then I could identify the problem and help (~_~)

but pages of random complaining and people not fully understanding 3dsmax makes it difficult to troubleshoot any problem

EDIT
... ok well looked over the skin weight part of the script and noticed that I just exclude vertex weights after 4.
Xnalara only supports 4, but 3dsmax defaults to 20.. so theoretically if you custom rigged your own model in 3dsmax you may exceed the 4 bone weights per vertex.. and this causes a weighting error in my script when going from 20 to 4...

So I updated the script and added a vertex weight check, it normalizes to meet the requirement of only 4 bone weights then checks to see if it sums up to 1.0

https://dl.dropboxusercontent.com/u/...20Converter.ms

and as I've said hundreds of times, if you have trouble send me more info then "it don't work" <_< ???
I need the files you were working with and as most detail as you can give me describing the error
__________________
No Swearing/Spaming/Trolling/Flaming/Advertising/Warez/Alts/Sigs/Quoting/Linking

Last edited by mariokart64n; 05-03-14 at 01:17.
mariokart64n is offline   Reply With Quote
Old 09-04-14, 04:38   #505
ngovandang
Hobbyist
 
Join Date: Apr 2014
Posts: 3
Question

Can you fix that bug when import model with your script?


ngovandang is offline   Reply With Quote
Old 09-04-14, 20:00   #506
mariokart64n
Historian
 
mariokart64n's Avatar
 
Join Date: Jul 2006
Location: Ontario, Canada
Posts: 339
Default

hard to fix bugs when nobody explains them. also the script seems to be memory hungry, what works on my system doesnt appear to work on other people's system

regardless I will investigate any bugs people find, but you need to provide samples and a explanation so I can replicate the error on my side
__________________
No Swearing/Spaming/Trolling/Flaming/Advertising/Warez/Alts/Sigs/Quoting/Linking
mariokart64n is offline   Reply With Quote
Old 10-04-14, 03:33   #507
ngovandang
Hobbyist
 
Join Date: Apr 2014
Posts: 3
Default

Quote:
Originally Posted by mariokart64n View Post
hard to fix bugs when nobody explains them. also the script seems to be memory hungry, what works on my system doesnt appear to work on other people's system

regardless I will investigate any bugs people find, but you need to provide samples and a explanation so I can replicate the error on my side
ngovandang is offline   Reply With Quote
Old 20-04-14, 19:53   #508
AnnaShepard
Hobbyist
 
AnnaShepard's Avatar
 
Join Date: Jun 2012
Posts: 30
Default

Do you happen to know the latest version of 3D studio Max that this works with? I recently got my hands on 3DS max 2015 and it won't work with it :x
__________________
I don't think it's really fair for me to be on a jury because I'm a hologram.
AnnaShepard is offline   Reply With Quote
Old 20-04-14, 20:39   #509
AnnaShepard
Hobbyist
 
AnnaShepard's Avatar
 
Join Date: Jun 2012
Posts: 30
Default

scratch my previous statement. It works in 3DS Max 2014. :>
__________________
I don't think it's really fair for me to be on a jury because I'm a hologram.
AnnaShepard is offline   Reply With Quote
Old 05-06-14, 03:06   #510
Lim1tD
Student
 
Lim1tD's Avatar
 
Join Date: Aug 2012
Location: Dead Island
Posts: 195
Default

Sorry to bump this thread, but there is a problem with the export for me. Whenever I'm done exporting the file I get this (The long number-letter thingy)

The textures don't get applied even though they are in the same directory and I checked the copy textures box in the export options
__________________
Does anyone feel like eating some bagels?
Lim1tD is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 17:30.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.