www.tombraiderforums.com  

Go Back   www.tombraiderforums.com > Tomb Raider Modding > Tomb Raider Modding > XNALara

Reply
 
Thread Tools
Old 13-05-12, 05:07   #1
AsuraSpike10
Explorer
 
AsuraSpike10's Avatar
 
Join Date: Aug 2010
Posts: 705
Default Bump maps

What's a simple way to add bump maps to a model? The model has the bumps but there not showing.

P.S. I can't use blender.
__________________
People who don't care about anything will never understand the people that do.
AsuraSpike10 is offline   Reply With Quote
Old 13-05-12, 05:19   #2
SKing
Archaeologist
 
SKing's Avatar
 
Join Date: Aug 2011
Location: Buenos Aires
Posts: 1,042
Default

Are you using XNALara? Or another program?

Could you post a screenshot?
SKing is offline   Reply With Quote
Old 13-05-12, 05:25   #3
AsuraSpike10
Explorer
 
AsuraSpike10's Avatar
 
Join Date: Aug 2010
Posts: 705
Default

I'm using XNALara. The only thing I have tried is going in to the generic_item.mesh using wordpad and adding them but it still doesn't show.
__________________
People who don't care about anything will never understand the people that do.

Last edited by AsuraSpike10; 13-05-12 at 05:32.
AsuraSpike10 is offline   Reply With Quote
Old 13-05-12, 05:31   #4
SKing
Archaeologist
 
SKing's Avatar
 
Join Date: Aug 2011
Location: Buenos Aires
Posts: 1,042
Default

Does the textures has the same name?
Like:-mouth_diffuse.png
-mouth_bump.png

Also be sure the option "Display Bump-maps" is enabled in XNALara
SKing is offline   Reply With Quote
Old 13-05-12, 05:40   #5
AsuraSpike10
Explorer
 
AsuraSpike10's Avatar
 
Join Date: Aug 2010
Posts: 705
Default

Quote:
Originally Posted by SKing View Post
Does the textures has the same name?
Like:-mouth_diffuse.png
-mouth_bump.png

Also be sure the option "Display Bump-maps" is enabled in XNALara
Here's a view

__________________
People who don't care about anything will never understand the people that do.
AsuraSpike10 is offline   Reply With Quote
Old 13-05-12, 08:15   #6
Runa
Archaeologist
 
Runa's Avatar
 
Join Date: Nov 2011
Location: Milan, Italy *vomits*
Posts: 1,065
Default

Quote:
Originally Posted by AsuraSpike10 View Post
Here's a view

I don't want to say something stupid, but I think it's a render group problem. Render group 7 supports one texture if I remember well, that's why XNALara shows only the diffuse and not the norm..
Runa is offline   Reply With Quote
Old 13-05-12, 08:17   #7
Goha
Explorer
 
Join Date: Jul 2011
Location: GMT+1
Posts: 729
Default

Render group #7 supports only one texture (diffuse). You have to use other group for what you need to do.

Here are groups listed. And here are most of them described with examples of use.
Goha is offline   Reply With Quote
Old 13-05-12, 10:17   #8
AsuraSpike10
Explorer
 
AsuraSpike10's Avatar
 
Join Date: Aug 2010
Posts: 705
Default

So how do I change the render group?
__________________
People who don't care about anything will never understand the people that do.
AsuraSpike10 is offline   Reply With Quote
Old 13-05-12, 11:24   #9
Runa
Archaeologist
 
Runa's Avatar
 
Join Date: Nov 2011
Location: Milan, Italy *vomits*
Posts: 1,065
Default

Quote:
Originally Posted by AsuraSpike10 View Post
So how do I change the render group?
Just like you change anything else, manually. Instead of 7 you should insert a group number that supports bump textures. Try writing 4 instead of 7, it should support both diffuse and bump.
Runa is offline   Reply With Quote
Old 13-05-12, 12:32   #10
AsuraSpike10
Explorer
 
AsuraSpike10's Avatar
 
Join Date: Aug 2010
Posts: 705
Default

Quote:
Originally Posted by Runa View Post
Just like you change anything else, manually. Instead of 7 you should insert a group number that supports bump textures. Try writing 4 instead of 7, it should support both diffuse and bump.
Finally got it. However I have found just changing the generic_item.mesh along isn't enough. After editing I open the model in XPS it has a load generic_item option that allows opening the generic_item.mesh which loads the model with bumps showing afterwards I save it as a generic_item and then bumps work.

Thanks for all the help I would have never figured it out without you-all.
__________________
People who don't care about anything will never understand the people that do.
AsuraSpike10 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 17:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.