www.tombraiderforums.com  

Go Back   www.tombraiderforums.com > Tomb Raider Series > Tomb Raider Underworld

Reply
 
Thread Tools
Old 23-11-21, 13:54   #1
Tremolo
Hobbyist
 
Join Date: Nov 2016
Posts: 59
Default Tomb Raider Underworld stuttering in Windows 10

I'm trying to play TRU on Windows 10 and the game seems to work fine with all settings at High and 1920x1080 resolution. But I'm experiencing a lot of random stuttering during gameplay. I don't know why.

I have a Ryzen 3 processor with Vega 8 graphic card. I tried to low all the settings at Low and change the resolution to 800x600, but the stuttering is still there. I don't have FPS issues, so I'm sure is not my graphic card. It's only all this strange stuttering that drops the FPS constantly.

I tried changing the parameters on regedit for Disable Dynamic Textures and
Dont Defer Shader Creation. But it only fixed the stuttering in the loading screen.
Tremolo is offline   Reply With Quote
Old 24-11-21, 06:28   #2
ATombRaiderFan
Historian
 
Join Date: May 2020
Posts: 372
Default

Try enabling VSync in external settings.
ATombRaiderFan is offline   Reply With Quote
Old 24-11-21, 13:20   #3
Tremolo
Hobbyist
 
Join Date: Nov 2016
Posts: 59
Default

I already tried that, but the stuttering still appears.

Also, I tried to change the settings on my graphic card, but still doesn't work as it should.

The stuttering appears randomly, for example, in one scene the stuttering may appear, but if I go back to the same area later, it works fine. And if I change from one room to another, the stuttering appears again. It happens in the cutscenes too.
Tremolo is offline   Reply With Quote
Old 24-11-21, 16:28   #4
JAMJOOM
Student
 
JAMJOOM's Avatar
 
Join Date: Mar 2020
Location: dubai
Posts: 238
Default

Quote:
Originally Posted by Tremolo View Post
I'm trying to play TRU on Windows 10 and the game seems to work fine with all settings at High and 1920x1080 resolution. But I'm experiencing a lot of random stuttering during gameplay. I don't know why.

I have a Ryzen 3 processor with Vega 8 graphic card. I tried to low all the settings at Low and change the resolution to 800x600, but the stuttering is still there. I don't have FPS issues, so I'm sure is not my graphic card. It's only all this strange stuttering that drops the FPS constantly.

I tried changing the parameters on regedit for Disable Dynamic Textures and
Dont Defer Shader Creation. But it only fixed the stuttering in the loading screen.
This may be due to another program running in the background

Did you change anything in the graphics card settings?

This also happens if there is a gap of system files

Or maybe because of the crack

https://www.lonebullet.com/cracks/do...-free-5057.htm


Or cooling the device and there are many reasons
__________________
jamjoom

Last edited by JAMJOOM; 24-11-21 at 16:34.
JAMJOOM is offline   Reply With Quote
Old 25-11-21, 02:21   #5
Tremolo
Hobbyist
 
Join Date: Nov 2016
Posts: 59
Default

Mmm, I'm pretty sure it has to do with the game itself. I'm playing Resident Evil 2 Remake and works fine. I'm sure is not about the requirements. I'm using the GOG version, so the game is updated and is legitime.

Years ago I played it on Windows 7 with a nVIDIA GeForce 6200 and it worked fine. I haven't touch the settings in the graphic card. I only changed the Vsync after trying everything else. I tried to change the register options and I only could fix the stuttering in the loading screen.

This is the only game I've been experiencing this.

EDIT:

I installed dgVoodoo2 and now the game runs better, but not completely smooth. I even could fix the stuttering in the loading screen without modify the register. It seems the stuttering is related when the game has to load a new room. The game is playable now but very annoying when the stuttering appears.

Last edited by Tremolo; 25-11-21 at 14:25.
Tremolo is offline   Reply With Quote
Old 25-11-21, 17:07   #6
JAMJOOM
Student
 
JAMJOOM's Avatar
 
Join Date: Mar 2020
Location: dubai
Posts: 238
Default

Quote:
Originally Posted by Tremolo View Post
Mmm, I'm pretty sure it has to do with the game itself. I'm playing Resident Evil 2 Remake and works fine. I'm sure is not about the requirements. I'm using the GOG version, so the game is updated and is legitime.

Years ago I played it on Windows 7 with a nVIDIA GeForce 6200 and it worked fine. I haven't touch the settings in the graphic card. I only changed the Vsync after trying everything else. I tried to change the register options and I only could fix the stuttering in the loading screen.

This is the only game I've been experiencing this.

EDIT:

I installed dgVoodoo2 and now the game runs better, but not completely smooth. I even could fix the stuttering in the loading screen without modify the register. It seems the stuttering is related when the game has to load a new room. The game is playable now but very annoying when the stuttering appears.
Have you tried another version?
GOG version usually suffers from technical problems
__________________
jamjoom
JAMJOOM is offline   Reply With Quote
Old 25-11-21, 18:47   #7
Tremolo
Hobbyist
 
Join Date: Nov 2016
Posts: 59
Default

Yes, I played the retail version too and runs exactly the same as the GOG version.

Anyway, I finally fixed the problem. I'm using dgVoodoo2, these are the changes I made on settings:

OutputAPI: Direct3D 11 (feature level 11.0)
Videocard: dgVoodoo Virtual 3D Accelerated Card
VRAM: 4096 MB
Force vSync: Enabled
dgVoodoo Watermark: Disabled

Also, I changed the value on DisableDynamicTextures to 0 and EnableDepthofField to 1 into the register.

Last edited by Tremolo; 26-11-21 at 14:40.
Tremolo is offline   Reply With Quote
Old 30-11-21, 12:22   #8
JAMJOOM
Student
 
JAMJOOM's Avatar
 
Join Date: Mar 2020
Location: dubai
Posts: 238
Default

Quote:
Originally Posted by Tremolo View Post
Yes, I played the retail version too and runs exactly the same as the GOG version.

Anyway, I finally fixed the problem. I'm using dgVoodoo2, these are the changes I made on settings:

OutputAPI: Direct3D 11 (feature level 11.0)
Videocard: dgVoodoo Virtual 3D Accelerated Card
VRAM: 4096 MB
Force vSync: Enabled
dgVoodoo Watermark: Disabled

Also, I changed the value on DisableDynamicTextures to 0 and EnableDepthofField to 1 into the register.
What version of Windows are you using, is it original or modified?
__________________
jamjoom
JAMJOOM is offline   Reply With Quote
Old 01-12-21, 20:23   #9
Deathly Karma
Historian
 
Deathly Karma's Avatar
 
Join Date: Mar 2015
Location: United Kingdom
Posts: 393
Default

I used DXVK, you drag and drop the files in the x32 folder into the main folder with tru.exe and it's set up. It'll stutter like mad for a good 30 seconds because it needs to build up a shader cache, but once it does that, it never has to do it again until you update your graphics drivers. Every level will experience a bit of stutter for a few seconds but it goes away quickly. For me, this allowed me to have smooth loading screens and smooth gameplay without stutters on AMD.
__________________
"D'you know, it's going to be real pleasure to shut you up."
Deathly Karma is offline   Reply With Quote
Old 02-12-21, 20:52   #10
Tremolo
Hobbyist
 
Join Date: Nov 2016
Posts: 59
Default

Quote:
Originally Posted by JAMJOOM View Post
What version of Windows are you using, is it original or modified?
Windows 10 original. The problem is related to the game, not my software. I fixed the problem with dgVoodoo2.

Quote:
Originally Posted by Deathly Karma View Post
I used DXVK, you drag and drop the files in the x32 folder into the main folder with tru.exe and it's set up. It'll stutter like mad for a good 30 seconds because it needs to build up a shader cache, but once it does that, it never has to do it again until you update your graphics drivers. Every level will experience a bit of stutter for a few seconds but it goes away quickly. For me, this allowed me to have smooth loading screens and smooth gameplay without stutters on AMD.
Thank you. I'll try DXVK later. But it's working great with dgVoodoo2, not stuttering at all. I think the port of this game is not very good.
Tremolo is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 21:47.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.