www.tombraiderforums.com  

Go Back   www.tombraiderforums.com > Tomb Raider Modding > Tomb Raider Level Editor > Software Development

Reply
 
Thread Tools
Old 06-08-21, 20:00   #941
Axell
Historian
 
Axell's Avatar
 
Join Date: Dec 2013
Location: UK
Posts: 298
Default

Sorry about that, missed that part of Krys' original post.

- New Blending Modes
- Enable new blending modes for particles
- Smooth shadows
- Remove green flare tint
- Extended Steam / Smoke emitter OCBs
- Enable extra smoke emitter flags
- Smoke emitter white OCB 00 settings
- Reverb base
- Reverb Classic Mode
- Reverb Advanced Mode
Axell is offline   Reply With Quote
Old 06-08-21, 20:07   #942
LoreRaider
Archaeologist
 
LoreRaider's Avatar
 
Join Date: Jul 2016
Location: Italy
Posts: 1,564
Default

This should be allright
Have you done any customization into reverb patches?
Also, does it crashes if you play on a new "test" level?
__________________
"Everybody lies, no exceptions."
LoreRaider is offline   Reply With Quote
Old 06-08-21, 20:12   #943
Axell
Historian
 
Axell's Avatar
 
Join Date: Dec 2013
Location: UK
Posts: 298
Default

I've modified the values for each reverb setting, yes, but I haven't modified any of the code.

And it does crash with every other level in my project. Regardless of whether I've modified anything in the map.

If it helps, these are my values for the reverb settings:

Outside: 0
Small Room: 5
Medium Room: 10
Large Room: 20
Pipe: 25

Last edited by Axell; 06-08-21 at 20:16.
Axell is offline   Reply With Quote
Old 06-08-21, 20:25   #944
LoreRaider
Archaeologist
 
LoreRaider's Avatar
 
Join Date: Jul 2016
Location: Italy
Posts: 1,564
Default

^hmm there's something wrong in those values, have you read the user manual as written on the patch?
Positive values will take information from Custom presets list, which goes from 1 to 16 meanwhile, negative values will take information from presets which goes from -1 to -30
That's probably why it crashes, you have set values higher than 16
__________________
"Everybody lies, no exceptions."

Last edited by LoreRaider; 06-08-21 at 20:26.
LoreRaider is offline   Reply With Quote
Old 06-08-21, 20:42   #945
Axell
Historian
 
Axell's Avatar
 
Join Date: Dec 2013
Location: UK
Posts: 298
Default

^ Thanks for that tip, I've fixed the values now to keep them under 16 but I'm still getting the same crashes... I've disabled the settings related to the emitters as well. :/

Can you point me towards the Reverb User Manual? I don't think that was included in the download... It seems that it was what was causing the issues for whatever reason. I started to switch the settings off slowly and once I ticked the Reverb patches, the crashes started happening.

Could this be because I'm using the Reverb Classic Mode patch?

Last edited by Axell; 06-08-21 at 20:47.
Axell is offline   Reply With Quote
Old 06-08-21, 20:46   #946
LoreRaider
Archaeologist
 
LoreRaider's Avatar
 
Join Date: Jul 2016
Location: Italy
Posts: 1,564
Default

^have you ticked any custom preset from the list though? If not that's another reason why it still crashes
For example, if you set "Small Room: 5" you will have to tick "Custom 5" patch as well
The number you set in one of the parameters on the "Reverb Classic Mode" patch relies on the ID of a preset (negative values) or a custom preset (positive values)

For the user manual, check the "Documentation" link here: https://www.tombraiderforums.com/sho...&postcount=848
__________________
"Everybody lies, no exceptions."

Last edited by LoreRaider; 06-08-21 at 20:49.
LoreRaider is offline   Reply With Quote
Old 06-08-21, 20:53   #947
Axell
Historian
 
Axell's Avatar
 
Join Date: Dec 2013
Location: UK
Posts: 298
Default

Thank you so much Lore! I was very ready to delete FLEP completely.

I'll read through the manual properly before I do any further edits!
Axell is offline   Reply With Quote
Old 09-08-21, 15:17   #948
ChocolateFan
Historian
 
ChocolateFan's Avatar
 
Join Date: Dec 2017
Location: I am female
Posts: 421
Default

Axell, you have to mark Sample file size patch. Multiply the default value by two until it stops crashing.

Latest version: https://drive.google.com/file/d/1KOu...ew?usp=sharing.

New patches:
  • Upward standing jump ledge grab animation
  • Ledge release animation
  • Pickup flare frames
  • Pickup item frames
  • Jump delay
  • Dive delay
  • Crawlspace pickup
  • Prevent camera position freeze
  • Customize sas gun
  • Fix bottom right corner bug
All patches by me, except Customize sas gun, which was developed by Troye.

DJ Full made a nice research about the bottom right corner bug here: https://www.tombraiderforums.com/sho...d.php?t=204738. But Lara can stand anywhere. Just the camera cannot.
ChocolateFan is offline   Reply With Quote
Old 09-08-21, 16:31   #949
justin
Professor
 
Join Date: Aug 2001
Location: CT, USA
Posts: 4,309
Default

That lower-right corner bug is wild. Fun read and cool that it can be patched!

What's the crawlspace pickup for? Was there a problem with crawlspace pickups before?
justin is offline   Reply With Quote
Old 09-08-21, 16:42   #950
ChocolateFan
Historian
 
ChocolateFan's Avatar
 
Join Date: Dec 2017
Location: I am female
Posts: 421
Default

No, the old patch works fine, but if you want to customize the low pedestal pickup frame using Pickup item frames then only the new patch can be used.
ChocolateFan is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 06:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.