www.tombraiderforums.com  

Go Back   www.tombraiderforums.com > Tomb Raider Modding > Tomb Raider Level Editor > Next Generation Level Editor

Reply
 
Thread Tools
Old 23-04-19, 09:13   #1
mizuno_suisei
Relic Hunter
 
mizuno_suisei's Avatar
 
Join Date: Jan 2006
Location: Perth, Western Australia
Posts: 6,040
Default PISTOLS and UZIS

PLEASE CLOSE. Issue resolved in TRNG Plugins Thread

I'm having a few trial and error problems regarding the PISTOLS and UZIS manner of shooting.

If you remember from TR1 and 2, If you "turned lara to the side" while shooting at an enemy with any twin guns, Lara will shoot with one. When you turn back at the right moments, she will continue to use both guns but out of sync - creating a different overlapping sound effect (namely for the Uzis).
Effect shown here: https://youtu.be/HdzluhoRg9M

In TR4, this seems to have stayed HOWEVER, not for the Uzis. Comparing the TR4 UZI sound (.8 seconds long) and TR1 UZI sound (1.2 seconds). If I replace the TR4 sound with TR1 exactly, the playback is skewed (all sound.txt PIT values set to 0 and sfx are correct encoding).

If I shorten the TR1 sound to TR4s length - we start getting somewhere. It sounds more legitimate with no skewing although it's not the complete original sound. I've tried removing the uzi_stp sound altogether but it still seems to play the firing sound at a forced .8 seconds and only plays uzi_stp when Lara stops firing completely.

Interestly if I use the TR1 UZI sound over the TR4 Pistols and change its firing rate from 9 to 3, it works flawlessly. No skewing and the turn back off sync trick works wonders.

I might be stepping into areas I'm unsure of. Could the Uzi have a hard coded shooting frame?
__________________
Australian, Japanese speaking TR addict.

Last edited by mizuno_suisei; 10-05-19 at 10:35.
mizuno_suisei is offline   Reply With Quote
Old 23-04-19, 10:39   #2
mizuno_suisei
Relic Hunter
 
mizuno_suisei's Avatar
 
Join Date: Jan 2006
Location: Perth, Western Australia
Posts: 6,040
Default

The default TR4 UZI shooting animation (3) has a few sound effects applied, yet not for the gun but footsteps in and out of water.

If I copy Pistols_Item over Uzi_Item, game crashes before level load. If I delete the animations effects from uzi_item, no notable changes to the normal issue of no overlap
__________________
Australian, Japanese speaking TR addict.
mizuno_suisei is offline   Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 06:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.