www.tombraiderforums.com  

Go Back   www.tombraiderforums.com > Tomb Raider Modding > Tomb Raider Level Editor > Tomb Editor

Reply
 
Thread Tools
Old 06-12-21, 16:50   #141
not again!
Archaeologist
 
not again!'s Avatar
 
Join Date: Feb 2008
Posts: 1,069
Default

A heads-up for Blender users that don't follow its development closely: Blender v3.0 got released a few days ago, with lots of new features and improvements.
not again! is offline   Reply With Quote
Old 06-12-21, 17:33   #142
Kubsy
Explorer
 
Kubsy's Avatar
 
Join Date: Nov 2019
Location: Polska
Posts: 504
Default

Hi I am not sure if it's the right thread but I really need help.

I don't know what is going on but in blender I have a very simple cube which is 8 vertices, when I import it to wadtool, it says 24 vertices!! I don't know what the hell it's going on.

Same with other stuff, I had simple easter eggs which were 77 vertices (3 of them) and wadtool calculated them as a whooping 300 vertices wtf.

I also check on wadtool's vertex remap and each vertice has duplicated to 3, even though I am not duplicating vertices.

Could someone help?

PS: I am very new to blender
__________________
Chronicles Lara: "Whatever"

Last edited by Kubsy; 06-12-21 at 17:36.
Kubsy is offline   Reply With Quote
Old 06-12-21, 19:09   #143
not again!
Archaeologist
 
not again!'s Avatar
 
Join Date: Feb 2008
Posts: 1,069
Default

^^ Using flat shading and sharp edges will increase the vertex count in Tomb Editor, because you can only have sharp edges in the tomb engine by splitting the vertices, doubling and trippling the vertex count. Cube = six faces with four vertices -> 6 x 4 = 24. You can switch between flat and smooth shading by selecting your model in Object Mode and right click:


^^click for bigger view

While smooth shading is best for vertex count it's not always the best looking option; some edges just need to be sharp and the improved aesthetic might be worth the increase in vertex count. In that case it's best to set your model to Smooth Shading and then select those edges that you want to be sharp in Edit Mode and mark them as sharp:





That way you can control which parts of the model will be smooth and which edges will be sharp.

Last edited by not again!; 06-12-21 at 19:20.
not again! is offline   Reply With Quote
Old 06-12-21, 19:43   #144
Kubsy
Explorer
 
Kubsy's Avatar
 
Join Date: Nov 2019
Location: Polska
Posts: 504
Default

Quote:
Originally Posted by not again! View Post
^^ Using flat shading and sharp edges will increase the vertex count in Tomb Editor, because you can only have sharp edges in the tomb engine by splitting the vertices, doubling and trippling the vertex count. Cube = six faces with four vertices -> 6 x 4 = 24. You can switch between flat and smooth shading by selecting your model in Object Mode and right click:

While smooth shading is best for vertex count it's not always the best looking option; some edges just need to be sharp and the improved aesthetic might be worth the increase in vertex count. In that case it's best to set your model to Smooth Shading and then select those edges that you want to be sharp in Edit Mode and mark them as sharp:

That way you can control which parts of the model will be smooth and which edges will be sharp.
Holy shi- Thank you so much this helped :') I didn't know about that and had flat shade turned on.

Thank you so much, I've been trying to figure out what was the problem for about 4 hours
__________________
Chronicles Lara: "Whatever"
Kubsy is offline   Reply With Quote
Old 07-12-21, 07:34   #145
AshySlashy
Student
 
AshySlashy's Avatar
 
Join Date: Dec 2019
Location: St. Petersburg
Posts: 211
Default

Quote:
Originally Posted by not again! View Post
^^ Using flat shading and sharp edges will increase the vertex count in Tomb Editor, because you can only have sharp edges in the tomb engine by splitting the vertices, doubling and trippling the vertex count. Cube = six faces with four vertices -> 6 x 4 = 24. You can switch between flat and smooth shading by selecting your model in Object Mode and right click:

While smooth shading is best for vertex count it's not always the best looking option; some edges just need to be sharp and the improved aesthetic might be worth the increase in vertex count. In that case it's best to set your model to Smooth Shading and then select those edges that you want to be sharp in Edit Mode and mark them as sharp:

That way you can control which parts of the model will be smooth and which edges will be sharp.
Wow, thank you so much. I didn't know that. However, I have the same problem for a long time now, but I don't use sharp edges and the shading is always smooth. For instance, the torso object which consists of torso and backpack in Blender has 247 vertices, but when I import it into WT it has 255 vertices. And I'm puzzled since I use one material for all objects (which lets me import the whole Lara model at once and doesn't split Blender objects into different meshes according to the material in WT).

What might be the case then?
__________________
The one who owns a minigun fears not.

Last edited by AshySlashy; 07-12-21 at 07:36.
AshySlashy is offline   Reply With Quote
Old 07-12-21, 08:01   #146
not again!
Archaeologist
 
not again!'s Avatar
 
Join Date: Feb 2008
Posts: 1,069
Default

^^ the vertices along UV seams will also be split, so I'd suspect that is the reason in your case.
not again! is offline   Reply With Quote
Old 07-12-21, 08:03   #147
AshySlashy
Student
 
AshySlashy's Avatar
 
Join Date: Dec 2019
Location: St. Petersburg
Posts: 211
Default

Quote:
Originally Posted by not again! View Post
^^ the vertices along UV seams will also be split, so I'd suspect that is the reason in your case.
Oh, I forgot about seams. Thanks.
__________________
The one who owns a minigun fears not.
AshySlashy is offline   Reply With Quote
Old 07-12-21, 08:25   #148
not again!
Archaeologist
 
not again!'s Avatar
 
Join Date: Feb 2008
Posts: 1,069
Default

No, hang on, on second thought I'm actually not sure if that's how it goes with TRLE too. It's the case for a lot of other games, but since the UV mapping is converted into something the TR engine can work with, I'm not sure UV seams matter.
edit: but I don't know what else it could be. Odd.

Last edited by not again!; 07-12-21 at 08:27.
not again! is offline   Reply With Quote
Old 07-12-21, 09:00   #149
AshySlashy
Student
 
AshySlashy's Avatar
 
Join Date: Dec 2019
Location: St. Petersburg
Posts: 211
Default

I've checked other meshes with seams (knees, legs), and in WT they have the same vertices count as in Blender. Odd indeed.
__________________
The one who owns a minigun fears not.
AshySlashy is offline   Reply With Quote
Old 07-12-21, 09:33   #150
not again!
Archaeologist
 
not again!'s Avatar
 
Join Date: Feb 2008
Posts: 1,069
Default

Do you have auto smooth enabled for that mesh?
Re-using the screenshot from above:

That could cause some edges to get exported as sharp automatically if the chosen angle value is lower than 180.

I think Blender has auto smooth enabled by default in the start up scene, so maybe it's that?

Last edited by not again!; 07-12-21 at 09:34.
not again! is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 12:39.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.