www.tombraiderforums.com  

Go Back   www.tombraiderforums.com > Tomb Raider Series > The Angel of Darkness

Reply
 
Thread Tools
Old 20-05-22, 16:33   #1361
Kami
Hobbyist
 
Kami's Avatar
 
Join Date: Sep 2018
Location: South Africa
Posts: 61
Default

Could someone please advise on how to get joytokey to work? I cannot control the camera with the controller (xbox360)
__________________
"The entrance is underwater. No problem."
Kami is offline   Reply With Quote
Old 20-05-22, 16:49   #1362
LateRaider
Professor
 
LateRaider's Avatar
 
Join Date: Sep 2014
Location: Ship Pierrson
Posts: 3,498
Default

This is for XInput controllers.

1. Download the profile I posted back here. https://www.tombraiderforums.com/sho...postcount=1359

2. Download JoyToKey. It's free! https://joytokey.net/en/download

3. Extract JoyToKey and the profile.

4. Put them both in the same folder.

5. Launch JoyToKey and be sure the profile is selected.

6. Launch TR:AoD while JoyToKey is still running.

7. At the title menu, go to Options -> Controls -> Keyboard.

8. Click "Default" and exit.

9. Next, go to Options -> Controls -> (your controller name here).

10. Ensure it's set to "Enabled".

11. Click "Default".

12. Bind the buttons as I suggested in my earlier post, linked in Step 1. (Be sure to unbind Stealth, Duck, Cycle Weapons Up, and Cycle Weapons Down in order for the profile to work properly. To unbind an input, hover over it and press Enter as if you were going to bind it, then press Esc to clear the binding.)

13. Now to to Options -> Controls -> Mouse.

14. Go to Sensitivity; move the slider all the way to the left, then move it to the right by one notch.

15. Optionally, set your Y and X Axes how you want. (Default axes have RStick Right look left, and RStick Up look down. What AoD considered "inverted axes" are considered normal axes in modern games.)

16. Exit the Controls Menu.

17. Click "Switch Movement Type (PC - PS2)" to use camera-relative controls. You have to do this last step each time you launch the game, for now.

Weapon switching is bound to Draw Gun + Crouch (Y+LT or △+L2) and Draw Gun + Stealth (Y+RT or △+R2). Since you can't use the D-Pad or Right Stick for this purpose, this way made the most sense.

Edit - I might try to make a video for this lol
__________________
"Come, let's get off this roof, and... I will buy you a milkshake."

Last edited by LateRaider; 22-05-22 at 10:03. Reason: Clearer instructions, now that I'm not half-asleep.
LateRaider is offline   Reply With Quote
Old 20-05-22, 17:28   #1363
Kami
Hobbyist
 
Kami's Avatar
 
Join Date: Sep 2018
Location: South Africa
Posts: 61
Default

Quote:
Originally Posted by LateRaider View Post
Download the profile I posted, download joy to key. unzip joy to key and put the profile in the same folder as the Joy to key application. Launch the angel of darkness whike Joy to key is still running. Set your controller bindings to default, then bind them as I suggested in my previous post. (In order for the profile to fully work, you will have to unbind the weapon cycle hotkeys, duck, and stealth by pressing esc when attempting to rebind them)

Lastly, under the main options menu click on the movement type change to switch to PS2 controls
Thank you
__________________
"The entrance is underwater. No problem."
Kami is offline   Reply With Quote
Old 22-05-22, 08:41   #1364
Kami
Hobbyist
 
Kami's Avatar
 
Join Date: Sep 2018
Location: South Africa
Posts: 61
Default

nevermind*
__________________
"The entrance is underwater. No problem."

Last edited by Kami; 22-05-22 at 09:18.
Kami is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 15:55.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.