www.tombraiderforums.com  

Go Back   www.tombraiderforums.com > Community Forums > Technical Support

Reply
 
Thread Tools
Old 12-11-20, 03:11   #1
Saphyre
Archaeologist
 
Saphyre's Avatar
 
Join Date: Jun 2008
Location: UK, South Yorkshire Gender: Male
Posts: 1,788
Default Issues with Steam versions of Classic Tomb Raiders

Hi everyone.

I recently took ownership of my partner's old Dell laptop, and I figured that since I'm predominantly a Mac user (and thus have been unable to play most if not all of the classic TR's on a PC) I'd sieze this opportunity to start replaying the classics.

I purchased TR: AOD through Steam which works fine so far. However, I also have Tomb Raider 3 and Tomb Raider 4 (also purchased through Steam) which I'm having control issues with.

The games run fine. They open, and I can navigate through the menus and get into the game. However, once I'm in game Lara will occasionally get stuck, almost as if the controls become jammed. For example, I'll run forwards and then she'll just keep going even when I let go of the up cursor key. She'll keep going until she crashes into a wall, at which point there's absolutely no way I can regain control of her. This can happen almost instantly when I start the game, or I can play for about five minutes before it happens.

It happens in both TR:3 and TR:4. I've tried the multipatcher on the Tomb Raider Chronicles site but for some reason it will only install updates for AOD and doesn't find anything for TR3 or 4.

I'm really rusty when it comes to Windows - this is the first Windows computer I've had for personal use in a long time. I've never run the PC versions of Tomb Raider before and I've no experience patching (though I seem to have managed to patch TR: AOD successfully so far).

I have a DXDiag report so you can get a better idea of my hardware:

------------------
System Information
------------------
Time of this report: 11/12/2020, 03:04:50
Machine name: DESKTOP-PP322S7
Machine Id: {013099E3-E570-45F2-98F5-65832050D1AA}
Operating System: Windows 10 Home 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Inspiron 3558
BIOS: A11 (type: UEFI)
Processor: Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz (4 CPUs), ~2.0GHz
Memory: 4096MB RAM
Available OS Memory: 4006MB RAM
Page File: 5588MB used, 1642MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.17763.0001 64bit Unicode


---------------
Display Devices
---------------
Card name: Intel(R) HD Graphics 5500
Manufacturer: Intel Corporation
Chip type: Intel(R) HD Graphics Family
__________________
Bring back Lara's love for beans on toast!

Last edited by Saphyre; 12-11-20 at 03:12.
Saphyre is offline   Reply With Quote
Old 13-11-20, 15:35   #2
Chamayoo
Relic Hunter
 
Chamayoo's Avatar
 
Join Date: Dec 2014
Location: The 90s museum
Posts: 6,523
Default

Have you take a look on the "guides" section in the main page of TR3 and TR4 on Steam ? Sometimes you'll find exactly what you need to do or install. Unfortunately I don't have any solution in mind right now but with luck you may find something there.
__________________
Laura Crotch returns home to inherit Crotch Industries
Chamayoo is offline   Reply With Quote
Old 19-11-20, 23:09   #3
Saphyre
Archaeologist
 
Saphyre's Avatar
 
Join Date: Jun 2008
Location: UK, South Yorkshire Gender: Male
Posts: 1,788
Default

Thanks for your response Chamayoo!

I think I've managed to find out the problem. It seems to be a conflict with the keyboard shortcuts set up in the Intel HD Graphics settings. I think I was unknowingly activating these keyboard shortcuts and Tomb Raider must not have liked it.

Seemed pressing the ctrl + the arrow keys together (or in quick succession of one another) was causing the issue. These were set up to rotate the display in the Intel HD Graphics Settings panel.

I've since gone into the Intel settings panel and disabled all of the keyboard shortcuts, and fingers crossed its sorted out the issue.
__________________
Bring back Lara's love for beans on toast!
Saphyre is offline   Reply With Quote
Old 22-11-20, 13:11   #4
gidierre
Grease Monkey
 
gidierre's Avatar
 
Join Date: Nov 2007
Posts: 1,568
Default

Quote:
Originally Posted by Saphyre View Post
I've since gone into the Intel settings panel and disabled all of the keyboard shortcuts, and fingers crossed its sorted out the issue.


btw there are similar issues skulking out there
just waiting to pop up out of the blue on poor users
first thing coming to mind is precisely: [didn't] want to rotate screen
but it's not only about the very Intel driver
Quote:
[CTRL] + arrow
[CTRL] + [Alt] + arrow
[CTRL] + [Shift] + arrow
see eg https://www.businessinsider.com/how-...n-windows?IR=T
__________________
We often forgive those who bore us--we cannot forgive those who find us boring.

Last edited by gidierre; 22-11-20 at 13:33.
gidierre is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 09:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.